LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 08-02-2007, 03:04 PM   #1
matthew871
LQ Newbie
 
Registered: Jul 2007
Posts: 4

Rep: Reputation: 0
How do I get YMF740 sound card working in Slackware 12?


It was working yesterday. For some reason it just decided to work for a while, but then when I rebooted it's not working anymore. It wasn't working for a long time before, but I thought that's because it was reading my Audigy card or the onboard Intel HDA chip instead. Now I have disabled the onboard sound in BIOS and when I boot up the only card it should be able to find is the one I want to use: YMF740. Typing lspci I get:

06:01.0 Multimedia audio controller: Yamaha Corporation DS1L Audio (rev 04)

so maybe it knows it exists. I've run alsaconf and it lists it there, too, and so I select it, and it lies and says it's all configured perfectly now and that it's unmuted the volumes (why does it have to unmute the volumes? That's stupid). So I type alsactl store just because I'm superstitious and don't know when that works and when it doesn't (since it doesn't print anything back in the console when it works), and it spits back:

alsactl: save_state:1253: No soundcards found...

And that's kind of what I get when I type alsamixer, too, see:

alsamixer: function snd_ctl_open failed for default: No such deviceof

Now both alsactl store and alsamixer was working before I disabled the onboard Intel soundchip, except it was listing that (the Intel one), which is why I disabled it, thinking there was a conflict of having two soundcards read (apparently too much for linux to handle).

And I've read like 3 dozen or more forum threads looking for information about soundcards for Slackware and Ubuntu (had the same unresolved problem on Ubuntu, as seen here: https://answers.launchpad.net/ubuntu/+question/8724 ), but I just don't know what to do. It's annoying. Why doesn't it just work automatically like it does in Windows? Is it because Windows is better?

Yes.

But it was working yesterday! I swear. And I got all the cords plugged in right, and the Intel/HDA on-board sound DOES work, and for a time I did get the Audigy working, too (but that would also stop working sometimes after a reboot). I guess this is why Linux users brag about never having to reboot: because if they did they'd lose vital system components like their sound!

lol

No, seriously. Can anybody help me or have I lost all chance of getting help now with this negative attitude and these little remarks of mine?

Thanks, if anyone can/is willing to help... :-]

(I figure there must be a way to switch soundcards or tell Linux which is the default, so that's what it tries to load... now I'm thinking, though, that it's more like it doesn't have the drivers or something? I have tried modprobe... seems like I keep trying the same commands after reading thread after thread both here and all over the web.)

Last edited by matthew871; 08-02-2007 at 03:21 PM.
 
Old 08-02-2007, 03:32 PM   #2
BCarey
Senior Member
 
Registered: Oct 2005
Location: New Mexico
Distribution: Slackware
Posts: 1,453

Rep: Reputation: Disabled
Can you post the output of lsmod? Have you tried blacklisting the modules for the cards you don't want to use?

Brian
 
Old 08-02-2007, 04:05 PM   #3
Road_map
Member
 
Registered: Jan 2007
Distribution: Slackware
Posts: 341

Rep: Reputation: 31
One way to set a order for 2 audio cards is to edit /etc/modprobe.d/sound
Code:
alias snd-card-0 snd-ymfpci
alias sound-slot-0 snd-ymfpci
alias snd-card-1 snd-intel8x0
alias sound-slot-1 snd-intel8x0
options snd-ymfpci index=0
options snd-intel8x0 index=1

Last edited by Road_map; 08-02-2007 at 04:07 PM.
 
Old 08-04-2007, 07:13 PM   #4
matthew871
LQ Newbie
 
Registered: Jul 2007
Posts: 4

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by BCarey
Can you post the output of lsmod?
This is what I've got for lsmod:
Code:
bash-3.1$ lsmod
Module                  Size  Used by
snd_seq_dummy           6788  0 
snd_seq_oss            32896  0 
snd_seq_midi_event     10112  1 snd_seq_oss
snd_seq                50640  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
snd_pcm_oss            42784  0 
snd_mixer_oss          18048  1 snd_pcm_oss
ipv6                  254496  18 
e100                   35464  0 
mii                     8576  1 e100
pcmcia                 34988  0 
pcmcia_core            36500  1 pcmcia
capability              7304  0 
commoncap               9344  1 capability
lp                     13736  0 
parport_pc             27812  1 
parport                34760  2 lp,parport_pc
pcspkr                  6528  0 
psmouse                39048  0 
snd_ymfpci             59584  0 
gameport               15112  1 snd_ymfpci
snd_ac97_codec         98980  1 snd_ymfpci
ac97_bus                6016  1 snd_ac97_codec
snd_pcm                72068  3 snd_pcm_oss,snd_ymfpci,snd_ac97_codec
snd_opl3_lib           12288  1 snd_ymfpci
snd_timer              22532  4 snd_seq,snd_ymfpci,snd_pcm,snd_opl3_lib
snd_hwdep              10628  1 snd_opl3_lib
snd_page_alloc         11528  2 snd_ymfpci,snd_pcm
snd_mpu401_uart        10496  1 snd_ymfpci
snd_rawmidi            22560  1 snd_mpu401_uart
snd_seq_device         10508  5 snd_seq_dummy,snd_seq_oss,snd_seq,snd_opl3_lib,s                                               nd_rawmidi
snd                    47204  13 snd_seq_oss,snd_seq,snd_pcm_oss,snd_mixer_oss,s                                               nd_ymfpci,snd_ac97_codec,snd_pcm,snd_opl3_lib,snd_timer,snd_hwdep,snd_mpu401_uar                                               t,snd_rawmidi,snd_seq_device
nvidia               7243924  24 
soundcore               9824  1 snd
iTCO_wdt               12964  0 
iTCO_vendor_support     7172  1 iTCO_wdt
shpchp                 33172  0 
pata_cmd64x            10892  0 
sg                     30364  0 
i2c_i801               11408  0 
serio_raw               9220  0 
ata_generic             9220  0 
evdev                  11904  1 
joydev                 12096  0 
intel_agp              25116  1 
agpgart                31432  2 nvidia,intel_agp
Quote:
Have you tried blacklisting the modules for the cards you don't want to use?
No, although should I need to do that when the on-board card is disabled and I only have one card inserted?
Quote:
One way to set a order for 2 audio cards is to edit /etc/modprobe.d/sound
OK, it already had the "alias" parts, but I added the "options" line. Not going to list the Intel HDA ones unless I need to.

Am I supposed to edit a file so that it lists this soundcard, or should I recompile the kernel with the soundcard included? (I remember reading something about compiling it with the kernel or as a module). Do I need to download a driver?

Thanks for the help so far. I appreciate it.

- matthew

Last edited by matthew871; 08-04-2007 at 07:14 PM.
 
Old 08-04-2007, 07:19 PM   #5
matthew871
LQ Newbie
 
Registered: Jul 2007
Posts: 4

Original Poster
Rep: Reputation: 0
Code:
bash-3.1# pwd
/usr/share/alsa/cards
bash-3.1# ls
AACI.conf           CMI8338.conf      ICE1724.conf     TRID4DWAVENX.conf
ATIIXP-MODEM.conf   CMI8738-MC6.conf  ICH-MODEM.conf   USB-Audio.conf
ATIIXP-SPDMA.conf   CMI8738-MC8.conf  ICH.conf         VIA686A.conf
ATIIXP.conf         CS46xx.conf       ICH4.conf        VIA8233.conf
AU8810.conf         EMU10K1.conf      Maestro3.conf    VIA8233A.conf
AU8820.conf         EMU10K1X.conf     NFORCE.conf      VIA8237.conf
AU8830.conf         ENS1370.conf      PC-Speaker.conf  VX222.conf
Audigy.conf         ENS1371.conf      PMac.conf        VXPocket.conf
Audigy2.conf        ES1968.conf       PMacToonie.conf  VXPocket440.conf
Aureon51.conf       FM801.conf        RME9636.conf     YMF744.conf
Aureon71.conf       GUS.conf          RME9652.conf     aliases.alisp
CA0106.conf         HDA-Intel.conf    SI7018           aliases.conf
CMI8338-SWIEC.conf  ICE1712.conf      SI7018.conf
It has a .conf file for YMF744, which I guess came with Slackware or Alsa. So I would think it would be able to use it. Hmm..
 
  


Reply

Tags
slackware12, soundcard


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
sound not working in SUSE 10.2 although sound card correctly configured mhardwick Linux - Software 4 03-05-2007 02:13 PM
Sound Skips After Slackware 11.0 upgrade AC97 sound card using the snd-via82xx driver meetscott Linux - Hardware 3 11-07-2006 11:55 PM
Sound not working in GNOME but sound card test works saravkrish Linux - Hardware 3 02-08-2006 11:03 AM
ALSA not working for Creative Sound Blaster Live 24 Bit sound card vishalsonu Linux - Hardware 7 08-20-2005 01:02 PM
SonicVibes Sound card not working in Slackware 10.1.0 Linux 2.6.10 GCC 3.4.3 sherman22 Linux - Hardware 5 03-05-2005 05:52 PM


All times are GMT -5. The time now is 03:25 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration