LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 05-16-2005, 05:39 AM   #1
dramen
LQ Newbie
 
Registered: May 2005
Location: Vienna, Austria
Posts: 21

Rep: Reputation: 15
glib - version ... problem


hello!

i have got a little problem!

i get the following error message when i want to compile hal:

configure: error: Library requirements (glib-2.0 >= 2.6.0, gobject-2.0 >= 2.6.0, dbus-glib-1 >= 0.33, dbus-1 >= 0.33) not met; consider adjusting the PKG_CONFIG_PATH environment variable if your libraries are in a nonstandard prefix so pkg-config can find them.

i have got glib2-2.6.3 and glib-1.2.10 but not glib-2.6.x
PKG_CONFIG_PATH environment variable .... i don't have this variable!!
and when i type glib-config --version then i get 1.2.10 although i have the version 2.6.3

what's the problem?

-thx-
 
Old 05-16-2005, 06:02 AM   #2
keefaz
Senior Member
 
Registered: Mar 2004
Distribution: Slackware
Posts: 4,617

Rep: Reputation: 136Reputation: 136
What is your output with :
pkg-config glib-2.0 --modversion
 
Old 05-16-2005, 06:13 AM   #3
dramen
LQ Newbie
 
Registered: May 2005
Location: Vienna, Austria
Posts: 21

Original Poster
Rep: Reputation: 15
root@dramen:~# pkg-config glib-2.0 --modversion
2.6.3
 
Old 05-16-2005, 07:02 AM   #4
keefaz
Senior Member
 
Registered: Mar 2004
Distribution: Slackware
Posts: 4,617

Rep: Reputation: 136Reputation: 136
Did you try to skip those configure tests, try ./configure --help to see if
there is a way to skip them
 
Old 05-16-2005, 07:05 AM   #5
acidjuice
Member
 
Registered: Jan 2005
Location: a tiny spot on the iceberg
Distribution: Slackware 10.1 (dropline 2.10, kernel 2.6.11.6)
Posts: 320

Rep: Reputation: 30
which slackware version are you on?
 
Old 05-16-2005, 07:31 AM   #6
dramen
LQ Newbie
 
Registered: May 2005
Location: Vienna, Austria
Posts: 21

Original Poster
Rep: Reputation: 15
yes i tried ./configure --help [ | grep glib] but there was no way to skip it (because glib is very important).

i have got slackware 10.1
 
Old 05-16-2005, 07:35 AM   #7
thepr0fess0r
LQ Newbie
 
Registered: Apr 2005
Location: Rakeigh, NC
Distribution: Slack
Posts: 16

Rep: Reputation: 0
I'm having a similar problem, mine claims

hecking for gtk+-2.0 >= 2.4.0... Requested 'gtk+-2.0 >= 2.4.0' but version of GTK+ is 2.2.1

pkg-config glib-2.0 --modversion

returns 2.6.0

I've compiled and supposedly? installed 2.6.0... what gives?
 
Old 05-16-2005, 08:01 AM   #8
dramen
LQ Newbie
 
Registered: May 2005
Location: Vienna, Austria
Posts: 21

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by thepr0fess0r
I've compiled and supposedly? installed 2.6.0... what gives?
what do you mean by that?
what should i do? reinstall gtk+??
 
Old 05-16-2005, 08:05 AM   #9
gbonvehi
Senior Member
 
Registered: Jun 2004
Location: Argentina (SR, LP)
Distribution: Slackware
Posts: 3,145

Rep: Reputation: 51
dramen, are you meeting the other requirements too? It seems you've the glib the program needs, do you have the others (gobject-2.0 >= 2.6.0, dbus-glib-1 >= 0.33, dbus-1 >= 0.33)?

thepr0fess0r, I don't understand, you're comparing gtk with glib which are very different things...
 
Old 05-16-2005, 08:37 AM   #10
thepr0fess0r
LQ Newbie
 
Registered: Apr 2005
Location: Rakeigh, NC
Distribution: Slack
Posts: 16

Rep: Reputation: 0
You know what? I'm an absolute retard!

I've been updating everything recently, and I've got my wires crossed again!

Why does everything have to start with G?!

gthanks!
 
Old 05-16-2005, 10:57 AM   #11
jong357
Senior Member
 
Registered: May 2003
Location: Columbus, OH
Distribution: DIYSlackware
Posts: 1,914

Rep: Reputation: 52
Yea, I would say it's a dbus problem. gobject comes from glib2 I believe. dbus isn't a very popular prog, neither is hal... But hal does depend on dbus which doesn't come with slack. So if you haven't installed it, it's not there...
 
Old 05-16-2005, 12:18 PM   #12
dramen
LQ Newbie
 
Registered: May 2005
Location: Vienna, Austria
Posts: 21

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by gbonvehi
dramen, are you meeting the other requirements too? It seems you've the glib the program needs, do you have the others (gobject-2.0 >= 2.6.0, dbus-glib-1 >= 0.33, dbus-1 >= 0.33)?
no i don't have them!
 
Old 05-16-2005, 10:10 PM   #13
thepr0fess0r
LQ Newbie
 
Registered: Apr 2005
Location: Rakeigh, NC
Distribution: Slack
Posts: 16

Rep: Reputation: 0
This brings up a problem I've been having for awhile, I need to upgrade both my glib and gtk+,

Code:
checking for pkg-config... /usr/bin/pkg-config
checking for glib-2.0 >= 2.6.0    atk >= 1.0.1    pango >= 1.8.0... Requested 'pango >= 1.8.0' but version of Pango is 1.2.1

configure: error: Library requirements (glib-2.0 >= 2.6.0    atk >= 1.0.1    pango >= 1.8.0) not met; consider adjusting the PKG_CONFIG_PATH environment variable if your libraries are in a nonstandard prefix so pkg-config can find them.
but I supposedly installed glib 2.6.something... well, I ran configure, make, make install anyways...

I guess I just can't get my glib installed....
 
Old 05-16-2005, 10:16 PM   #14
jong357
Senior Member
 
Registered: May 2003
Location: Columbus, OH
Distribution: DIYSlackware
Posts: 1,914

Rep: Reputation: 52
You guys need to start actually reading your errors... It clearly states that the pango on your system is too old. It needs 1.8.0 or greater...
 
Old 05-16-2005, 10:23 PM   #15
thepr0fess0r
LQ Newbie
 
Registered: Apr 2005
Location: Rakeigh, NC
Distribution: Slack
Posts: 16

Rep: Reputation: 0
It also says that glib is too old. I'm more concerned about it right now... it seems to be installed, I've got a glib-2.0 directory in /usr/include, does anyone know what's up?

Oh, slack 9.1 btw.

-R-
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Regarding distribution + kernel version + gcc version + glib version. JCipriani Linux - General 8 04-19-2008 03:54 PM
what is the version of my glib thinhla Linux - Software 3 06-28-2005 08:24 PM
can't install gtk 2.4.4: "Requested 'glib-2.0 >= 2.4.0' but version of GLib is 2.2.3 webazoid Linux - Software 0 07-15-2004 07:07 PM
GLib version redhatnoob Linux - Software 1 02-04-2004 08:43 PM
GLIB version ! >= 2.0.0? ShawnD Linux - Software 4 05-16-2003 07:16 PM


All times are GMT -5. The time now is 04:34 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration