SlackwareThis Forum is for the discussion of Slackware Linux.
Welcome to LinuxQuestions.org, a friendly and active Linux Community.
You are currently viewing LQ as a guest. By joining our community you will have the ability to post topics, receive our newsletter, use the advanced search, subscribe to threads and access many other special features. Registration is quick, simple and absolutely free. Join our community today!
Note that registered members see fewer ads, and ContentLink is completely disabled once you log in.
If you have any problems with the registration process or your account login, please contact us. If you need to reset your password, click here.
Having a problem logging in? Please visit this page to clear all LQ-related cookies.
Introduction to Linux - A Hands on Guide
This guide was created as an overview of the Linux Operating System, geared toward new users as an exploration tour and getting started guide, with exercises at the end of each chapter.
For more advanced trainees it can be a desktop reference, and a collection of the base knowledge needed to proceed with system and network administration. This book contains many real life examples derived from the author's experience as a Linux system and network administrator, trainer and consultant. They hope these examples will help you to get a better understanding of the Linux system and that you feel encouraged to try out things on your own.
Click Here to receive this Complete Guide absolutely free.
i get the following error message when i want to compile hal:
configure: error: Library requirements (glib-2.0 >= 2.6.0, gobject-2.0 >= 2.6.0, dbus-glib-1 >= 0.33, dbus-1 >= 0.33) not met; consider adjusting the PKG_CONFIG_PATH environment variable if your libraries are in a nonstandard prefix so pkg-config can find them.
i have got glib2-2.6.3 and glib-1.2.10 but not glib-2.6.x
PKG_CONFIG_PATH environment variable .... i don't have this variable!!
and when i type glib-config --version then i get 1.2.10 although i have the version 2.6.3
Yea, I would say it's a dbus problem. gobject comes from glib2 I believe. dbus isn't a very popular prog, neither is hal... But hal does depend on dbus which doesn't come with slack. So if you haven't installed it, it's not there...
Originally posted by gbonvehi dramen, are you meeting the other requirements too? It seems you've the glib the program needs, do you have the others (gobject-2.0 >= 2.6.0, dbus-glib-1 >= 0.33, dbus-1 >= 0.33)?
This brings up a problem I've been having for awhile, I need to upgrade both my glib and gtk+,
checking for pkg-config... /usr/bin/pkg-config
checking for glib-2.0 >= 2.6.0 atk >= 1.0.1 pango >= 1.8.0... Requested 'pango >= 1.8.0' but version of Pango is 1.2.1
configure: error: Library requirements (glib-2.0 >= 2.6.0 atk >= 1.0.1 pango >= 1.8.0) not met; consider adjusting the PKG_CONFIG_PATH environment variable if your libraries are in a nonstandard prefix so pkg-config can find them.
but I supposedly installed glib 2.6.something... well, I ran configure, make, make install anyways...