LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 10-21-2009, 10:21 AM   #1
Lufbery
Senior Member
 
Registered: Aug 2006
Location: Harrisburg, PA
Distribution: Slackware 64 14.0
Posts: 1,142
Blog Entries: 29

Rep: Reputation: 119Reputation: 119
Getting Thinkpad scroll button to work in Slackware 13


Hi all,

What's the best way to get my Thinkpad's scroll button working with Slackware 13 (32-bit)? With previous versions, I simply edited the xorg.conf file. But the text below from the changes and hints file indicates a couple of other options:

Quote:
Speaking of Xorg, the version of Xorg shipped with Slackware 13.0 will not
(in most cases) require an /etc/X11/xorg.conf file at all. Configuration of
input devices and such is handled by HAL, and the X server autoconfigures
everything else. You can still create an xorg.conf file if you wish, or you
can create a minimal xorg.conf with only the specific contents that you wish
to override (as an example, to use a binary-only video driver).
Due to removed drivers and other such changes, it's quite possible that your
old xorg.conf will not work correctly with this version of Xorg.

If you need to use a non-US keyboard layout, then copy the file located at
/usr/share/hal/fdi/policy/10osvendor/10-keymap.fdi to /etc/hal/fdi/policy
and edit it to suit your needs. Have a look at the contents of that file
for an example and more information. If you prefer to do this the "old" way
using /etc/X11/xorg.conf, then you can use "X -configure" or "xorgsetup" to
generate an xorg.conf, then add the following lines to the "ServerFlags"
section to disable input device hotplugging via HAL:
Option "AllowEmptyInput" "false"
Option "AutoAddDevices" "false"
Option "AutoEnableDevices" "false"
This is also relevant if you prefer to disable HAL completely for whatever
reason.
Sure enough, I did not need to configure X at all for video and sound to work on my Thinkpad laptop. But the mouse scroll button does not work.

So, do I make an xorg.conf file that only has the mouse input settings in it?

Or, should I edit the relevant HAL policy? If that's the better way, how should I go about doing that?

Regards,
 
Old 10-21-2009, 10:23 AM   #2
Lufbery
Senior Member
 
Registered: Aug 2006
Location: Harrisburg, PA
Distribution: Slackware 64 14.0
Posts: 1,142
Blog Entries: 29

Original Poster
Rep: Reputation: 119Reputation: 119
Ack! Google-fu may have helped: Here are instructions from Thinkwiki to edit HAL to configure the scroll button. I'll give this a try this evening and report back on my success or failure.

Regards,
 
Old 10-21-2009, 10:57 AM   #3
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 5,223

Rep: Reputation: Disabled
For my T400's TrackPoint those settings work. I think this way of scrolling is a big improvement over the standard functionality, I prefer it over anything else.
Another nice feature ( and that works out of the box in Slackware) is that you can slide a finger across the right side of the TrackPad to scroll your window.

Eric
 
Old 10-21-2009, 11:18 AM   #4
w1k0
Senior Member
 
Registered: May 2008
Location: Poland
Distribution: Slackware, Mint
Posts: 1,240

Rep: Reputation: 196Reputation: 196
In the case of my ThinkPad T60 TouchPad scrolling doesn't work out of the box. To enable it I have to use that set of rules:

x11-synaptics.fdi
Code:
<?xml version="1.0" encoding="ISO-8859-1"?>
<deviceinfo version="0.2">
  <device>
    <match key="info.capabilities" contains="input.touchpad">
        <merge key="input.x11_driver" type="string">synaptics</merge>
        <merge key="input.x11_options.SHMConfig" type="string">true</merge>
        <merge key="input.x11_options.TapButton1" type="string">1</merge>
        <merge key="input.x11_options.MaxTapMove" type="string">2000</merge>
        <merge key="input.x11_options.VertEdgeScroll" type="string">true</merge>
        <merge key="input.x11_options.HorizEdgeScroll" type="string">true</merge>
    </match>
  </device>
</deviceinfo>
Because I don't like TouchPad I usually disable it using that rule:

disable-touchpad.fdi
Code:
<match key="info.product" string="SynPS/2 Synaptics TouchPad">
    <merge key="input.x11_options.TouchpadOff" type="string">1</merge>
</match>
To enable TrackPoint scrolling I use the rules mentioned by Lufbery:

mouse-wheel.fdi
Code:
<match key="info.product" string="TPPS/2 IBM TrackPoint">
    <merge key="input.x11_options.EmulateWheel" type="string">true</merge>
    <merge key="input.x11_options.EmulateWheelButton" type="string">2</merge>
    <merge key="input.x11_options.YAxisMapping" type="string">4 5</merge>
    <merge key="input.x11_options.XAxisMapping" type="string">6 7</merge>
    <merge key="input.x11_options.Emulate3Buttons" type="string">true</merge>
    <merge key="input.x11_options.EmulateWheelTimeout" type="string">200</merge>
</match>
 
Old 10-21-2009, 08:48 PM   #5
Lufbery
Senior Member
 
Registered: Aug 2006
Location: Harrisburg, PA
Distribution: Slackware 64 14.0
Posts: 1,142
Blog Entries: 29

Original Poster
Rep: Reputation: 119Reputation: 119
All,

The instructions from Thinkwiki worked perfectly.

Regards,
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
What 12.2 Xorg.conf will make Thinkpad middle mouse button work? slackist Slackware 6 01-09-2009 07:33 PM
Mouse Scroll Button doesn't work with Logitech PS/2 MOuse. duffmckagan Slackware 10 12-02-2008 11:27 PM
Can't get scroll button to work with Slackware 10.0 gbdavidx Slackware 8 10-24-2004 03:52 PM
Thinkpad scroll button wierdness short101 Linux - Laptop and Netbook 1 08-29-2004 10:10 PM
How do I get scroll button on mouse to work .. kato678 Linux - General 1 06-26-2002 09:11 PM


All times are GMT -5. The time now is 05:45 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration