LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 05-30-2006, 02:39 AM   #1
Andriy
Member
 
Registered: Dec 2005
Distribution: Slackware, SLAX, Redhat, Fedora
Posts: 133

Rep: Reputation: 15
Smile Fuse missing?


i want to try a remote filesystem setup using fuse. the problem is that, whenever i mount the filesystem to be used, an error occur saying that it can't find fuse or fuse module is not loaded. however, upon doing lsmod, fuse shows up in there. any hint on how can i cover this up? thanks in advance.
 
Old 05-30-2006, 11:13 PM   #2
theoffset
Member
 
Registered: Aug 2005
Location: Guadalajara, Jal, Mexico
Distribution: Slackware Linux
Posts: 211

Rep: Reputation: 30
Have you tried
Code:
dmesg | tail
to see if there's any module errors, either when loading the module or when mounting the filesystem?
 
Old 05-31-2006, 03:55 AM   #3
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 5,258

Rep: Reputation: Disabled
You might be missing the fuse userspace tools, like "fusermount". Fuse is part of the 2.6 kernel but in order to use it, you also need the fuse utils.

Eric
 
Old 05-31-2006, 06:15 AM   #4
Andriy
Member
 
Registered: Dec 2005
Distribution: Slackware, SLAX, Redhat, Fedora
Posts: 133

Original Poster
Rep: Reputation: 15
I found the fuse.ko in the src folder of my kernel which is 2.6.16.13. However, it doesn't get loaded during boot time and I still have to load it manually using insmod. What I was trying to do actually is to try GmailFS, unfortunately it needs fuse module to be loaded. I finally found a solution as I have said by loading it manually but I wonder if anyone can point out how can I load it automatically at boot time.
 
Old 05-31-2006, 06:33 AM   #5
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 5,258

Rep: Reputation: Disabled
Add this line at the end of the file "/etc/rc.d/rc.modules" :
Code:
/sbin/modprobe fuse
When booting, Slackware will now load the fuse module automatically.

Eric
 
Old 05-31-2006, 06:43 AM   #6
Andriy
Member
 
Registered: Dec 2005
Distribution: Slackware, SLAX, Redhat, Fedora
Posts: 133

Original Poster
Rep: Reputation: 15
Thank you very much Eric.
 
  


Reply

Tags
fuse


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
2.6.14 FUSE and NTFS in Kernel Crito Fedora 3 11-16-2005 08:20 AM
EncFS and fuse EdoardoC MEPIS 0 05-26-2005 11:33 AM
fuse installation africamagical Fedora 0 11-17-2004 09:42 PM
FUSE Installation on Suse 9.1 Personal roseyboy14 Suse/Novell 0 10-30-2004 05:53 PM
Slackware 9.1 with Zoomtown & Fuse sylord Linux - Networking 1 04-09-2004 04:02 AM


All times are GMT -5. The time now is 11:18 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration