LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 07-06-2004, 06:39 PM   #1
javamdk
Member
 
Registered: Jul 2004
Location: Indiana
Distribution: Slackware 10.1, Debian
Posts: 64

Rep: Reputation: 15
Unhappy Folder permission


Hey guys, I'm pretty new to Linux but have used it before. Recently I just installed Slackware 10.0 and love it! I just recently got my mouse wheel to work but now I want to allow myself access to my first hard drive. I have two hard drives, the master is Windows XP and the Slave is Slackware 10.0, I told Slackware during install to make a mount point at book-up to the folder /ntfs-c (this is my C drive for Windows)... I can access the files perfectly under root but I don't want to do that because I don't want to mess certain things up! I have only one other account (joer) and it won't let me open it. I tried to gui method by right clicking the folder under KDE (root) and checked Read access and it came up with an error saying it can't do this action... WHY? lol

So anyhelp would be awesome... I would still like (root) to have access to /ntfs-c as well as (joer)

Last edited by javamdk; 07-06-2004 at 06:41 PM.
 
Old 07-06-2004, 06:44 PM   #2
CartersAdvocate
Member
 
Registered: Sep 2003
Location: Columbus, OH
Distribution: Slackware 12.2
Posts: 166

Rep: Reputation: 30
Try typing (as root):

Code:
chown joer:users /ntfs-c

Last edited by CartersAdvocate; 07-06-2004 at 06:46 PM.
 
Old 07-06-2004, 08:43 PM   #3
gbonvehi
Senior Member
 
Registered: Jun 2004
Location: Argentina (SR, LP)
Distribution: Slackware
Posts: 3,145

Rep: Reputation: 51
javamdk, root will always have access to anything, so don't worry about it
 
Old 07-06-2004, 09:01 PM   #4
javamdk
Member
 
Registered: Jul 2004
Location: Indiana
Distribution: Slackware 10.1, Debian
Posts: 64

Original Poster
Rep: Reputation: 15
Ohh, see I didn't know that hehe, but the chown joer:users /ntfs-c doesn't work... it does say that it changed it to read-only.. then i tried to access it through my joer account and it said I don't have enough permission to view this folder. ??? Any other ideas?

Thanks
 
Old 07-06-2004, 09:18 PM   #5
gbonvehi
Senior Member
 
Registered: Jun 2004
Location: Argentina (SR, LP)
Distribution: Slackware
Posts: 3,145

Rep: Reputation: 51
That's a matter of /etc/fstab
That file is in charge of looking how to mount a partition if it's mentioned there, otherwise you'll have to specify all the parameters each time you mount it.
Here's my ntfs line at /etc/fstab, replace some stuff to suit your config:
/dev/hdb1 /win/c ntfs noauto,gid=100,user,umask=000 1 0

That should work changing of course /dev/hdXX and /win/c to /ntfs-c

If you have any doubts try: man fstab

EDIT: Also remember that ntfs on linux is still being developed, until now the default drivers for ntfs on linux are able to read ok, but you shouldn't try to write to the ntfs partition. A solution is to use a Fat32 partition on Windows.

Last edited by gbonvehi; 07-06-2004 at 09:24 PM.
 
Old 07-06-2004, 10:41 PM   #6
javamdk
Member
 
Registered: Jul 2004
Location: Indiana
Distribution: Slackware 10.1, Debian
Posts: 64

Original Poster
Rep: Reputation: 15
Wow, I'm just learning a whole bunch... I think learning linux really gives you whole new look on things esp. not to take things for granted... But anyways, I replaced the original bookup fstab mount point to this:

/dev/hda1 /ntfs-c ntfs noauto,gid=100,user,umask=000 1 0

and rebooted so it would mount this... loged in as joer and noticed that the padlock was removed from the folder... so i could go into it now, but nothing was in it!! I tried going to Document's and Settings by entering what would be the right path and it says it doesn't exist... so I logged out and went into root and the same thing... couldn't see the files

What could be wrong?
 
Old 07-06-2004, 10:58 PM   #7
gbonvehi
Senior Member
 
Registered: Jun 2004
Location: Argentina (SR, LP)
Distribution: Slackware
Posts: 3,145

Rep: Reputation: 51
That's because noauto flag tells that it shouldn't be mounted automatically on boot.
Issue the command: mount /ntfs-c and it should mount it.
Also, you don't need to reboot for settings to take effect as on Windows, you only need to reboot if you're upgrading the kernel, of course, we always feel better if we reboot

EDIT: Forgot to say, read man mount to see a description of it, it's used to mount any kind of filesystem, ie: the floppy, cdrom, dvd, usb hdd, etc.

Last edited by gbonvehi; 07-06-2004 at 11:01 PM.
 
Old 07-06-2004, 11:06 PM   #8
javamdk
Member
 
Registered: Jul 2004
Location: Indiana
Distribution: Slackware 10.1, Debian
Posts: 64

Original Poster
Rep: Reputation: 15
YAY!!! Thank you sooo very much! Now is there a way to have it boot up automatically... would I just change noauto flag to auto?

Thanks soo much again
 
Old 07-06-2004, 11:29 PM   #9
gbonvehi
Senior Member
 
Registered: Jun 2004
Location: Argentina (SR, LP)
Distribution: Slackware
Posts: 3,145

Rep: Reputation: 51
I'm always glad to help
By removing noauto flag from fstab it should automount when you boot. I don't remember if there's a auto flag, just read the man page, but as i said, just removing it should do the trick.
 
Old 07-07-2004, 11:26 AM   #10
javamdk
Member
 
Registered: Jul 2004
Location: Indiana
Distribution: Slackware 10.1, Debian
Posts: 64

Original Poster
Rep: Reputation: 15
Yeah, I didn't find any auto flag... but by removing the 'noauto,' worked out perfect! Thanks again -Joe
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
how create a folder/permission rusmi Linux - Newbie 7 02-11-2005 10:04 AM
Permission to write to folder Garoth Linux - Software 1 10-09-2004 11:41 PM
adding a stuff to a folder i don't have permission to SurfCHimp Linux - Newbie 3 09-11-2004 11:58 AM
permission denied if I want to create new folder dodo1983 Linux - Newbie 2 08-14-2004 10:46 PM
Permission denied opening a folder phoenixofwater Linux - Newbie 3 07-26-2004 09:45 PM


All times are GMT -5. The time now is 03:41 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration