LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 04-15-2013, 04:25 AM   #1
TommyC7
Member
 
Registered: Mar 2012
Distribution: Slackware, CentOS, OpenBSD, FreeBSD
Posts: 438

Rep: Reputation: Disabled
dynamic skype from SBo aborts


Hi folks,

I was just wondering if I could get some assistance with this. Basically skype doesn't seem to want to run. It was working just fine yesterday and even though I am tracking -current, the last updates were Apr. 11, so I don't think they're the reason behind this.

Basically, here is the error:
Code:
$ skype
Fatal: QWidget: Must construct a QApplication before a QPaintDevice
Aborted
I've googled this already and two results popped up. One about the program prelink which I don't have installed, and the other is about not having all compat32 packages installed that the skype binary requires.

I double checked that I had the compat32 packages by:

1. Re-installing all the compat32 packages after re-downloading them.

2. I re-checked to make sure each shared object that skype links against actually existed on my system (and they do).

I'm at a loss on what the problem might be. I haven't removed a package recently or upgraded anything other than the updates from Apr. 11th. and the multilib stuff.

Does anybody hopefully have any ideas on what might be going on?
 
Old 04-15-2013, 01:21 PM   #2
business_kid
Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 6,617

Rep: Reputation: 585Reputation: 585Reputation: 585Reputation: 585Reputation: 585Reputation: 585
look at the output from ldd /usr/bin/skype |grep found

What you get is missing libraries. It should say nothing. install what it mentions. Then run skype from a terminal and post what it says.
 
Old 04-15-2013, 07:41 PM   #3
TommyC7
Member
 
Registered: Mar 2012
Distribution: Slackware, CentOS, OpenBSD, FreeBSD
Posts: 438

Original Poster
Rep: Reputation: Disabled
The output of ldd is what I used to double-check that I already had all the shared objects as previously stated.
 
Old 04-16-2013, 03:45 AM   #4
business_kid
Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 6,617

Rep: Reputation: 585Reputation: 585Reputation: 585Reputation: 585Reputation: 585Reputation: 585
From memory, there may have been a symlink I added in the compat32 stuff.
/lib/ld-linux.so2-->ld-2.15.so ??

That particular one throws crazy errors when it shows - the last thing it complains about is a missing lib.
 
Old 04-16-2013, 01:26 PM   #5
TommyC7
Member
 
Registered: Mar 2012
Distribution: Slackware, CentOS, OpenBSD, FreeBSD
Posts: 438

Original Poster
Rep: Reputation: Disabled
I'm on -current, so for me it's 2.17 but yes /lib/ld-linux.so.2 is a symlink to /lib/ld-2.17.so
 
Old 04-17-2013, 05:19 AM   #6
business_kid
Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 6,617

Rep: Reputation: 585Reputation: 585Reputation: 585Reputation: 585Reputation: 585Reputation: 585
I'm running dynamic skype here (not very often, I hasten to add) and I stuck the output of ldd up HEREif it helps.
 
Old 04-17-2013, 12:05 PM   #7
TommyC7
Member
 
Registered: Mar 2012
Distribution: Slackware, CentOS, OpenBSD, FreeBSD
Posts: 438

Original Poster
Rep: Reputation: Disabled
Like I said, I've already used ldd myself and as previously stated in my first post, I have already looked up the shared objects to make sure the compat32 ones exist...
 
Old 04-19-2013, 06:09 PM   #8
TommyC7
Member
 
Registered: Mar 2012
Distribution: Slackware, CentOS, OpenBSD, FreeBSD
Posts: 438

Original Poster
Rep: Reputation: Disabled
I've identified the error. For some reason I had uncommented the stripping part of skype. I didn't think that was the problem because the .SlackBuild mentions a segmentation fault but I guess that error message counts.
 
Old 04-20-2013, 03:57 AM   #9
business_kid
Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 6,617

Rep: Reputation: 585Reputation: 585Reputation: 585Reputation: 585Reputation: 585Reputation: 585
If the slackbuild mentioned a segmentation fault, that info should have been in post #1 and we would have got to this a biot sooner, I'm sure.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Nvidia-driver.SlackBuild from SBo (or: I am a bad and sloppy SBo maintainer) kingbeowulf Slackware 8 08-31-2012 03:41 AM
noise in skype to skype calls in skype v2.1 beta for fedora mq15 Linux - Software 0 01-20-2010 01:04 AM
Installation aborts abnormally tuxianD Fedora - Installation 1 08-07-2008 11:26 AM
Keeps telling me YUM is running and aborts Virtuality Linux - Newbie 1 05-30-2007 08:27 AM
cups aborts print jobs sneak Linux - Software 0 11-09-2004 05:45 PM


All times are GMT -5. The time now is 09:29 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration