LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 04-12-2003, 12:26 PM   #1
willywonka
LQ Newbie
 
Registered: Apr 2003
Location: Kansas
Distribution: Slackware 9.0
Posts: 12

Rep: Reputation: 0
Question DMA settings won't save


I'm running Slackware 9.0, and I have:

hdparm -X66 -c3 -d1 /dev/hda
in my /etc/rc.d/rc.local

When linux loads, it works reads that DMA is on, but when I log in and type:
hdparm -Tt /dev/hda
I get really crappy speed, and when I type
hdparm /dev/hda
DMA is turned off, but when i turn it back on again, then it works fine.

Anybody know why I would have to type 'hdparm -X66 -c3 -d1 /dev/hda' again when linux starts? or if there is a better way to enable DMA and hard drives?
 
Old 04-12-2003, 12:46 PM   #2
bynaar
Member
 
Registered: Jul 2002
Posts: 141

Rep: Reputation: 15
This is my setting in rc.local:

hdparm -c 1 -d 1 -k 1 /dev/hdb

You have to use the switch -k, in order to keep the settings.

good luck !
 
Old 04-12-2003, 01:07 PM   #3
willywonka
LQ Newbie
 
Registered: Apr 2003
Location: Kansas
Distribution: Slackware 9.0
Posts: 12

Original Poster
Rep: Reputation: 0
I have tried that at one point, although I did it with '-k1' instead of '-k 1'. At work right now, I will try again.
 
Old 04-12-2003, 01:55 PM   #4
pablob
Member
 
Registered: Apr 2003
Location: Madrid
Distribution: RHAS, Kubuntu, Solaris, TRU64
Posts: 381

Rep: Reputation: 31
Maybe your PATH is not set at the time rc.local is executed.
Try /sbin/hdparm ......

If not, recompile kernel with "Use DMA by default" turned on.
(But that's a major mess for such a problem).
Try making a /etc/rc.d/rc3.d/S90dma
 
Old 04-12-2003, 08:38 PM   #5
willywonka
LQ Newbie
 
Registered: Apr 2003
Location: Kansas
Distribution: Slackware 9.0
Posts: 12

Original Poster
Rep: Reputation: 0
Problem solved, I just did -X69 instead of -X66, and now it works

Don't know why I did -X66, 2X faster now anyway

Did '-k1' also, BTW
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to Save gVIM Settings! simsjr Programming 12 06-13-2014 03:16 AM
how do I save my OSS settings? maerong Ubuntu 1 04-01-2005 08:05 AM
How do I save my settings? laverscheval DamnSmallLinux 2 10-08-2004 09:44 PM
Can't save httpd settings simke Fedora 16 09-27-2004 09:02 PM
DMA setting won't save willywonka Linux - Hardware 6 04-12-2003 08:37 PM


All times are GMT -5. The time now is 09:56 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration