LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 10-30-2005, 10:21 PM   #1
Jeebizz
Senior Member
 
Registered: May 2004
Distribution: Slackware 14.1 64-bit with multilib
Posts: 2,074

Rep: Reputation: 199Reputation: 199
Daylight savings time


Well October is almost over, and last night midnight the hour was supposed to change, on the windows side, it changed automatically, since it had the option to do so with the clock settings, but apparantly Linux did not, I had to manually change the hour back. I live in Dallas TX, but I could not find Dallas as part of the time zone, so I chose America/North_Dakota/Center, for CST. My question is, how do I make sure the settings under linux will change the next time the hours are changed again, during the upcoming spring?

Last edited by Jeebizz; 10-30-2005 at 10:29 PM.
 
Old 10-31-2005, 05:54 AM   #2
MMYoung
Member
 
Registered: Apr 2004
Location: Arkansas
Distribution: Ubuntu 8.10
Posts: 365

Rep: Reputation: 30
When you was setting up Slackware there was an option to set the hardware clock to localtime or UTC. If you choose localtime the next screen allows you to select which timezone you are in which *should* adjust your clock automatically. At least it does for me.

Later,
MMYoung
 
Old 10-31-2005, 07:41 AM   #3
rovitotv
Member
 
Registered: Jan 2003
Location: Dayton, Ohio
Distribution: Slackware 10.2
Posts: 116

Rep: Reputation: 15
Mine new 10.2 install changed OK for me.
 
Old 10-31-2005, 08:08 AM   #4
BroX
Member
 
Registered: Oct 2003
Location: Sweden
Distribution: Slackware64-current
Posts: 745

Rep: Reputation: 64
I've always set up the time as local time but have never noticed that daylight saving time changed automatically.
Slack-current/Fluxbox-cvs/kernel 2.6.14

What am I missing?
 
Old 11-01-2005, 05:07 AM   #5
doc.nice
Member
 
Registered: Oct 2004
Location: Germany
Distribution: Debian
Posts: 274

Rep: Reputation: 34
have a look here...

http://www.tldp.org/HOWTO/Clock-2.html

setting to UTC will do the trick, but be aware of your windows clock

Last edited by doc.nice; 11-01-2005 at 05:10 AM.
 
Old 11-01-2005, 05:50 AM   #6
BroX
Member
 
Registered: Oct 2003
Location: Sweden
Distribution: Slackware64-current
Posts: 745

Rep: Reputation: 64
Quote:
Originally posted by doc.nice
have a look here...

http://www.tldp.org/HOWTO/Clock-2.html

setting to UTC will do the trick, but be aware of your windows clock
Thanks! I'll give that a try! No windows clock here!
Another question: in your link above /etc/localtime is mentioned as a link to /usr/share/zoneinfo/<your-timezone>. But when I checked this file it is not a link but a binary? Is this different in Slack? Is the symlink somewhere else, or can I remove the binary and make it a symlink?

Cheers, Leon.
 
Old 11-01-2005, 05:56 AM   #7
Nobber
Member
 
Registered: Jun 2002
Location: Nova Scotia
Distribution: Debian (home), Kubuntu 7.04 (work)
Posts: 265

Rep: Reputation: 30
Quote:
Originally posted by LJSBrokken
Another question: in your link above /etc/localtime is mentioned as a link to /usr/share/zoneinfo/<your-timezone>. But when I checked this file it is not a link but a binary? Is this different in Slack?
Yes: the file is copied rather than symlinked in Slackware. Don't know why.
 
Old 11-02-2005, 10:53 AM   #8
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: Tupelo, MS
Distribution: Gentoo
Posts: 6,926

Rep: Reputation: 124Reputation: 124
I haven't set my clock to UTC, but to localtime, and it adjusted itself
for Daylight Savings Time. I am running Slackware -current with my
own custom 2.6.13.4 kernel. I also use Fluxbox, not KDE.
 
Old 11-02-2005, 10:55 AM   #9
BroX
Member
 
Registered: Oct 2003
Location: Sweden
Distribution: Slackware64-current
Posts: 745

Rep: Reputation: 64
During the installation I choose the option localtime, but now I'd like to change it to UTC.

In Slack, where do I go for that?

Cheers, Leon.
 
Old 11-02-2005, 11:04 AM   #10
gbonvehi
Senior Member
 
Registered: Jun 2004
Location: Argentina (SR, LP)
Distribution: Slackware
Posts: 3,145

Rep: Reputation: 51
Using as root: /usr/sbin/timeconfig

Or using pkgtool under Setup, choose timeconfig and press Ok
 
Old 11-02-2005, 11:07 AM   #11
BroX
Member
 
Registered: Oct 2003
Location: Sweden
Distribution: Slackware64-current
Posts: 745

Rep: Reputation: 64
Quote:
Originally posted by gbonvehi
Using as root: /usr/sbin/timeconfig
Thankx!
 
Old 11-02-2005, 12:57 PM   #12
dkpw
Member
 
Registered: Sep 2003
Location: Scotland
Distribution: LinuxMint16 & Ubuntu 12.0.4 LTS
Posts: 218

Rep: Reputation: 30
Another way to ensure accurate time is to establish a cron job using NTP.

The command is simply:

Code:
/usr/sbin/ntpdate "your nearest ntp server"
Google for your nearest NTP server and set the cron job to run once a day. This method took care of the daylight savings change.

Regards,

dkpw
 
Old 11-02-2005, 01:45 PM   #13
doc.nice
Member
 
Registered: Oct 2004
Location: Germany
Distribution: Debian
Posts: 274

Rep: Reputation: 34
see http://ntp.isc.org/bin/view/Servers/WebHome for time server adresses
 
Old 11-21-2005, 08:08 PM   #14
archtoad6
Senior Member
 
Registered: Oct 2004
Location: Houston, TX (usa)
Distribution: MEPIS, Debian, Knoppix,
Posts: 4,727
Blog Entries: 15

Rep: Reputation: 231Reputation: 231Reputation: 231
From Post # 1:
Quote:
... so I chose America/North_Dakota/Center, for CST
That may have been your mistake, it gripes me every time I have to use it, but Chicago is the generic CST choice.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Disabling auto conversion to daylight savings time Saxton Linux - General 3 02-12-2009 08:13 AM
Turning Off Daylight Savings Time troy.porter Red Hat 1 03-10-2007 12:02 PM
NTP and Daylight Savings Time jrdioko Linux - Software 8 11-01-2005 09:25 AM
Daylight Savings Time and Linux cereal83 Linux - General 6 10-31-2005 05:28 PM
Daylight savings time Problem bogus__13 Linux - General 1 04-04-2005 10:09 PM


All times are GMT -5. The time now is 09:41 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration