LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 08-15-2011, 03:39 PM   #1
rasseman
LQ Newbie
 
Registered: Jun 2011
Posts: 9

Rep: Reputation: Disabled
cant get internet to work


i installed slackware 13.37 erlier today and got it up and running but i cant get my internet to work. when i open up terminal and type dmesg it says "eth0: no ipv6 routers present" how do i fix this also my router is a dlink dir615 connected to a neatgear wgt624 version 3. thanks for anwsers. also sorry for any miss spellings

Last edited by rasseman; 08-15-2011 at 03:40 PM.
 
Old 08-15-2011, 05:02 PM   #2
ks8
Member
 
Registered: May 2003
Posts: 38

Rep: Reputation: 15
I use Debian, so do not know if this will help.
You need to install a driver for your wgt624. I think it is a atheros chipset. In the case of debian, there is a web page where you can find out how to install the atheros driver. Maybe you can do the same in slackware (best to google slackware atheros wireless). IIRC, you will need madwifi.

Last edited by ks8; 08-15-2011 at 05:03 PM.
 
Old 08-15-2011, 05:10 PM   #3
rasseman
LQ Newbie
 
Registered: Jun 2011
Posts: 9

Original Poster
Rep: Reputation: Disabled
im not using wifi im using lan. iv got one router connected to another router and iv tried to just plug it in to the netgear router but it still dosent work
 
Old 08-15-2011, 05:50 PM   #4
markush
Senior Member
 
Registered: Apr 2007
Location: Germany
Distribution: Slackware
Posts: 3,971

Rep: Reputation: 849Reputation: 849Reputation: 849Reputation: 849Reputation: 849Reputation: 849Reputation: 849
Hello rasseman,

please post the output of
Code:
ifconfig
and provide more information, are you using DHCP? Do you have other computers in the network? do they have a connection?

Please post the significant part of your /etc/rc.d/rc.inet1.conf (the part about eth0).

Markus
 
Old 08-16-2011, 05:26 AM   #5
rasseman
LQ Newbie
 
Registered: Jun 2011
Posts: 9

Original Poster
Rep: Reputation: Disabled
yes i have dhcp. my computer whit windows and my computer whit ubuntu work just fine. when i type if config i get:

ifconfig

eth0 link encap:ethernet hwaddr 00:11:09A:74:A2
inet addr:192.168.0.101 Bcast:192.168.0.255 mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MUT:1500 METRIC:1
RX packets:24 errors:0 dropped:0 overruns:0 frame:0
TX packets:13 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:4001 (3,9 kb) TX bytes:1420 (1,3 kb)
interrupt:16

link encap:local loopback
inet addr:127.0.0.1 mask:255.0.0.0
inet6 addr: :1/128 scope:host
UP LOOPBACK RUNNING MUT:16436 Metric:1
RX packets:4 errors:0 dropped:0 overruns:0 frame:0
TX packets:4 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:240 (240.0 b) TX bytes:240 (240.0 b)

and for some reason even if im logged in as root i get the message premission denied when i type in /etc/rc.d/rc.inet1.conf
 
Old 08-16-2011, 05:31 AM   #6
repo
LQ 5k Club
 
Registered: May 2001
Location: Belgium
Distribution: Linux Mint
Posts: 8,511

Rep: Reputation: 884Reputation: 884Reputation: 884Reputation: 884Reputation: 884Reputation: 884Reputation: 884
Quote:
and for some reason even if im logged in as root i dont get the message premission denied when i type in /etc/rc.d/rc.inet1.conf
You need to open or cat the file
Code:
cat /etc/rc.d/rc.inet1.conf
or
Code:
less /etc/rc.d/rc.inet1.conf
Did you set the default gateway ?
Code:
route -n
Can you ping the gateway?
Can you ping on ip?
Code:
ping 212.100.160.51
Can you ping on name
Code:
ping google.com
Kind regards
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Internet will not work djkooldown Fedora 5 04-04-2007 06:00 PM
Internet: Does not work darthcode Linux - Networking 26 04-20-2005 05:45 PM
Can't Get Internet to Work malikshebaz Red Hat 4 04-16-2005 07:48 PM
internet does not work gorek Linux - Networking 1 12-11-2003 09:30 AM
Help!!!!!!!!!!!!!! Internet does not work? xRomEo Linux - Networking 0 10-02-2002 01:23 PM


All times are GMT -5. The time now is 12:44 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration