LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 09-23-2007, 08:08 PM   #1
eraosso
Member
 
Registered: May 2006
Location: Brazil
Distribution: Slackware 13.37
Posts: 35

Rep: Reputation: 15
Can't connect wireless DLINK card with ndiswrapper and WPA+TKIP


Hi,
a few years ago, I played with Slack 8 and liked it very much. Now I am back into my Linux experiences trying to avoid windows use for any private purpose.
I have Slackware 12 installed on a DELL Inspiron 8200. At first I used wireless with wep encryption without any problems. The PCMCIA wireless card is a D-Link DWL-G650M and I use ndiswrapper with the win driver.
As I mentioned, it was working fine so I assume ndiswrapper is properly installed.

Something went wrong with wpa_supplicant.

DMESG shows:
ndiswrapper version 1.47 loaded (smp=yes)
usbcore: registered new interface driver ndiswrapper
NET: Registered protocol family 10
lo: Disabled Privacy Extensions
pccard: CardBus card inserted into slot 0
ndiswrapper: driver net5513 (D-Link,09/12/2005,1.0.0.56) loaded
PCI: Enabling device 0000:03:00.0 (0000 -> 0002)
ACPI: PCI Interrupt 0000:03:00.0[A] -> Link [LNKD] -> GSI 11 (level, low) -> IRQ 11
PCI: Setting latency timer of device 0000:03:00.0 to 64
ndiswrapper: using IRQ 11
wlan0: ethernet device 00:13:46:c1:55:58 using serialized NDIS driver: net5513, version: 0x10000, NDIS version: 0x501, vendor: 'NDIS Network Adapter', 168C:0020.5.conf
wlan0: encryption modes supported: WEP; TKIP with WPA; AES/CCMP with WPA
ADDRCONF(NETDEV_UP): wlan0: link is not ready
ADDRCONF(NETDEV_UP): wlan0: link is not ready

IWCONFIG WLAN0 shows:
wlan0 IEEE 802.11g ESSID:"Formiguinha" Nickname:"Uberlandia"
Mode:Managed Frequency:2.412 GHz Access Point: Not-Associated
Bit Rate=108 Mb/s
Encryption key : off
Power Management : off
Link Quality:0 Signal level:0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

/etc/rc.d/rc.inet1 wlan0_start shows:
/etc/rc.d/rc.inet1: wlan0 information: 'Any ESSID'

rc.inet1.conf reads:
IFNAME[4]="wlan0"
IPADDR[4]=""
NETMASK[4]=""
USE_DHCP[4]="yes"
DHCP_HOSTNAME[4]=""
#DHCP_KEEPRESOLV[4]="yes"
#DHCP_KEEPNTP[4]="yes"
#DHCP_KEEPGW[4]="yes"
#DHCP_IPADDR[4]=""
WLAN_ESSID[4]="Formiguinha"
WLAN_MODE[4]=Managed
WLAN_RATE[4]="auto"
WLAN_CHANNEL[4]="auto"
#WLAN_KEY[4]="decimal passkey"
WLAN_KEY[4]=HEX passkey

##WLAN_IWPRIV[4]="AuthMode=WPAPSK EncrypType=TKIP WPAPSK=7B1ABEEB5D197741923ED26727569C365E31212096A0EAFAD563B268BAD01CAF TxRate=0"
WLAN_WPA[4]="wpa_supplicant"
WLAN_WPADRIVER[4]="ndiswrapper"

and wpa_supplicant.conf reads:
# See /usr/doc/wpa_supplicant-0.5.7/wpa_supplicant.conf.sample
# for many more options that you can use in this file.

# This line enables the use of wpa_cli which is used by rc.wireless
# if possible (to check for successful association)
ctrl_interface=/var/run/wpa_supplicant
# By default, only root (group 0) may use wpa_cli
#ctrl_interface_group=0
#eapol_version=1
#ap_scan=1
#fast_reauth=1

I have disabled the four lines above

# WPA protected network, supply your own ESSID and WPAPSK here:
network={
# scan_ssid=0
ssid="Formiguinha"
proto=WPA
key_mgmt=WPA-PSK
priority=5
pairwise=CCMP TKIP
group=CCMP TKIP WEP104 WEP40
# psk=DECIMAL passkey
psk=HEX passkey
}

# Plaintext connection (no WPA, no IEEE 802.1X),
# nice for hotel/airport types of WiFi network.
# You'll need a recent version of wireless-tools for this!
network={
# ssid="any"
key_mgmt=NONE
priority=0
}


Any hints on where I went wrong?? Any more info needed?
Thanks a lot for your support and happy slacking!
//ERAOSSO
 
Old 09-24-2007, 03:26 AM   #2
vdemuth
Member
 
Registered: Oct 2003
Location: West Midlands, UK
Distribution: Slackware 14 (Server),Suse 13.1 (Desktop),, Mepis on the wifes lappy
Posts: 770

Rep: Reputation: 94
Try these config files. Just modify for your own use:

within rc.inet1.conf

Code:
IFNAME[4]="wlan0"
IPADDR[4]=""
NETMASK[4]=""
USE_DHCP[4]="yes"
WLAN_WPA[4]="wpa_supplicant"
WLAN_WPADRIVER[4]="wext"
WLAN_WPACONF[4]="/etc/wpa_supplicant.conf"
wpa_supplicant.conf

Code:
ctrl_interface=/var/run/wpa_supplicant
ctrl_interface_group=0
update_config=1

network={
    ssid="YOUR SSID HERE"
    psk=YOUR KEY HERE 
    proto=WPA
    key_mgmt=WPA-PSK
    pairwise=TKIP
    group=TKIP WEP104 WEP40
    disabled=1
}

network={
    ssid=""
    key_mgmt=NONE
    disabled=1
}
 
Old 09-24-2007, 08:39 AM   #3
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: Tupelo, MS
Distribution: Gentoo
Posts: 6,926

Rep: Reputation: 124Reputation: 124
http://alien.slackbook.org/dokuwiki/...kware#wireless

He's responsible for the wireless scripts in Slackware, so use his advice.
 
Old 09-25-2007, 01:06 AM   #4
eraosso
Member
 
Registered: May 2006
Location: Brazil
Distribution: Slackware 13.37
Posts: 35

Original Poster
Rep: Reputation: 15
Thumbs up Issue solved!

Howdy!
It did worke fine! I am actually writing this reply from my recently connected laptop!
I just replaced WLAN_WPADRIVER="wext" and disabled the WLAN_KEY on rc.inet1.conf.

Thanks a lot everyone!
 
Old 09-25-2007, 01:11 AM   #5
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: Tupelo, MS
Distribution: Gentoo
Posts: 6,926

Rep: Reputation: 124Reputation: 124
I'm so excited about your success!

If you are using madwifi, as it sounds like you are, why not use the native madwifi Linux driver rather than ndiswrapper?

If your card uses the Atheros chipset, then madwifi is the Linux driver for you. Just issue "/sbin/lspci | grep -i ethernet" as a normal user. This is the output on one of our computers:
Code:
anna@peter:~$ /sbin/lspci | grep -i ethernet
00:0d.0 Ethernet controller: Atheros Communications, Inc. AR5212 802.11abg NIC (rev 01)
00:12.0 Ethernet controller: VIA Technologies, Inc. VT6102 [Rhine-II] (rev 74)
If you also have an Atheros chipset, we can help you use it's native Linux driver.
 
Old 09-25-2007, 08:55 PM   #6
eraosso
Member
 
Registered: May 2006
Location: Brazil
Distribution: Slackware 13.37
Posts: 35

Original Poster
Rep: Reputation: 15
Hi Bruce,
I am not using Madwifi... when I started configuration of my Slackware 12 on this notebook, I found that my card was not supported yet...
I just checked both madwifi and ndiswrapper home pages and looked for information and could not find my card (D-Link DWL-G650M) on Madwifi page but found this not on ndiswrapper:

#Card: D-Link DWL-G650M
*
Chipset: Atheros
*
Driver: No madwifi support yet. Use ndiswrapper and net5513.inf found on driver CD.

So, I've got an Atheros chipset card but not supported yet with Madwifi.

The output of /sbin/lscpi | grep -i ethernet gives

02:00.0 Ethernet controller: 3Com Corporation 3c905C-TX/TX-M [Tornado] (rev 78)
03:00.0 Ethernet controller: Atheros Communications, Inc. AR5005VL 802.11bg Wireless NIC (rev 01)

I would definitely change to Madwifi when support for the DWL-G650M is implemented.

Thanks again!
 
Old 09-26-2007, 03:34 PM   #7
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 5,393

Rep: Reputation: Disabled
Did you actually try the latest madwifi driver yet on that machine? Never hurts to try.

Eric
 
Old 10-07-2007, 07:51 AM   #8
eraosso
Member
 
Registered: May 2006
Location: Brazil
Distribution: Slackware 13.37
Posts: 35

Original Poster
Rep: Reputation: 15
Sorry for the late response.
I haven't actually installed madwifi drivers. I only followed the info I found regarding what`s supported and what`s not and went for the safe side of using ndiswrapper.
I also have a Toshiba Satellite with AMD64 and Atheros embedded.

I still need to find out how to:
- non-destructively partition the hd pre-installed with WinVista
- compile a kernel for AMD64 and install Slackware12 or use Slamd64

then I will play with madwifi and configure everything again...
Thanks again for your support!
 
Old 12-28-2007, 11:12 AM   #9
eraosso
Member
 
Registered: May 2006
Location: Brazil
Distribution: Slackware 13.37
Posts: 35

Original Poster
Rep: Reputation: 15
MADWIFI from scratch

Hi Eric,
after a couple of months here I am again!
I did a fresh install (Slackware 12) on a "brand new" DELL LATITUDE with a PIII and an HD with 10GB!

Instead of going for NDISWRAPPER (which we solved already) I will try MADWIFI from the beggining.
Following your Dokuwiki, when configuring rc.wireless.conf I face the following situation:

lspci gives:

0:00.0 Host bridge: Intel Corporation 440BX/ZX/DX - 82443BX/ZX/DX Host bridge (rev 03)
00:01.0 PCI bridge: Intel Corporation 440BX/ZX/DX - 82443BX/ZX/DX AGP bridge (rev 03)
00:03.0 CardBus bridge: Texas Instruments PCI1420 PC card Cardbus Controller
00:03.1 CardBus bridge: Texas Instruments PCI1420 PC card Cardbus Controller
00:07.0 Bridge: Intel Corporation 82371AB/EB/MB PIIX4 ISA (rev 02)
00:07.1 IDE interface: Intel Corporation 82371AB/EB/MB PIIX4 IDE (rev 01)
00:07.2 USB Controller: Intel Corporation 82371AB/EB/MB PIIX4 USB (rev 01)
00:07.3 Bridge: Intel Corporation 82371AB/EB/MB PIIX4 ACPI (rev 03)
00:08.0 Multimedia audio controller: ESS Technology ES1983S Maestro-3i PCI Audio Accelerator (rev 10)
00:10.0 Ethernet controller: 3Com Corporation 3c556 Hurricane CardBus [Cyclone] (rev 10)
00:10.1 Communication controller: 3Com Corporation Mini PCI 56k Winmodem (rev 10)
01:00.0 VGA compatible controller: ATI Technologies Inc Rage Mobility M3 AGP 2x (rev 02)
06:00.0 Ethernet controller: Atheros Communications, Inc. AR5005VL 802.11bg Wireless NIC (rev 01)

which is fine, the card is recognized.

lsmod shows:

bash-3.1# lsmod
Module Size Used by
ath_pci 92192 0
wlan 195268 1 ath_pci
ath_hal 193616 1 ath_pci

but ifconfig gives me:


you'll notice the cable (eth0) is up.

bash-3.1# ifconfig -a
eth0 Link encap:Ethernet HWaddr 00:04:76:3F:8AC
inet addr:192.168.6.158 Bcast:192.168.6.255 Mask:255.255.255.0
inet6 addr: fe80::204:76ff:fe3f:8adc/64 Scope:Link
UP BROADCAST NOTRAILERS MULTICAST MTU:1500 Metric:1
RX packets:14979 errors:0 dropped:0 overruns:0 frame:0
TX packets:9172 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:17405094 (16.5 MiB) TX bytes:997672 (974.2 KiB)
Interrupt:11 Base address:0xcc00

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:104 errors:0 dropped:0 overruns:0 frame:0
TX packets:104 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:9632 (9.4 KiB) TX bytes:9632 (9.4 KiB)

and
bash-3.1# ifconfig ath0
ath0: error fetching interface information: Device not found

why is the interface not available? Where did I go wrong?

Thanks for helping!
 
Old 12-28-2007, 11:21 AM   #10
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 5,393

Rep: Reputation: Disabled
From the madwifi compatibility page: you will see several notes stating "AR5005VL chipset not yet supported by MadWifi."

Eric
 
Old 12-28-2007, 11:32 AM   #11
eraosso
Member
 
Registered: May 2006
Location: Brazil
Distribution: Slackware 13.37
Posts: 35

Original Poster
Rep: Reputation: 15
Thansk Eric. I just agreed with you (it never hurts to try) as posted previously.

Thanks again and a great 2008!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Wireless connection blues Mandriva 2007 WPA and TKIP settings Brainjammers Mandriva 4 02-02-2007 07:31 AM
nDiswrapper Dlink Aethros Chipset - Cant Connect To wireless Network AT ALL Damien295x Linux - Wireless Networking 4 09-17-2006 02:15 PM
WPA-PSK TKIP Ndiswrapper - No data issue sti2envy Linux - Wireless Networking 0 03-10-2005 12:53 AM
Belkin wireless card F5D7010 WPA-PAS TKIP Works!!!!!! Tarry LinuxQuestions.org Member Success Stories 3 08-28-2004 08:47 AM


All times are GMT -5. The time now is 08:19 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration