LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices

Reply
 
Search this Thread
Old 03-10-2005, 12:53 AM   #1
sti2envy
Member
 
Registered: Sep 2004
Posts: 43

Rep: Reputation: 15
WPA-PSK TKIP Ndiswrapper - No data issue


I managed to get my my genius gw7200 pci card working with ndiswrapper on winxp drivers. I added WPA-PSK security, enable SSID broadcast on my Linksys WRT54G AP.

[root@toys ~]# iwlist wlan0 scan
wlan0 Scan completed :
Cell 01 - Address: 00:0F:66:XX:XX:XX
ESSID:"blahblah"
Protocol:IEEE 802.11b
Mode:Managed
Frequency:2.457GHz (Channel 10)
Quality:0/100 Signal level:-28 dBm Noise level:-256 dBm
Encryption keyn
Bit Rate:1Mb/s
Bit Rate:2Mb/s
Bit Rate:5.5Mb/s
Bit Rate:11Mb/s
Bit Rate:6Mb/s
Bit Rate:9Mb/s
Bit Rate:12Mb/s
Bit Rate:18Mb/s
Bit Rate:24Mb/s
Bit Rate:36Mb/s
Bit Rate:48Mb/s
Bit Rate:54Mb/s
Extra:bcn_int=100
Extra:atim=0
Extra:wpa_ie=dd160050f20101000050f20201000050f20201000050f20

Output from wpa_cli shows associated with AP:

Selected interface 'wlan0'

Interactive mode

> status
bssid=00:0f:66:XX:XX:XX
ssid=blahblah
pairwise_cipher=TKIP
group_cipher=TKIP
key_mgmt=WPA-PSK
wpa_state=COMPLETED
Supplicant PAE state=AUTHENTICATED
suppPortStatus=Authorized
EAP state=SUCCESS

[root@toys ~]# ifconfig wlan0
wlan0 Link encap:Ethernet HWaddr 00:40:F4:XX:XX:XX
inet addr:192.168.1.2 Bcast:192.168.1.255 Mask:255.255.255.0
inet6 addr: fe80::240:f4ff:fec4:cce9/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:528 errors:0 dropped:0 overruns:0 frame:0
TX packets:1235 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:54485 (53.2 KiB) TX bytes:157794 (154.0 KiB)
Memory:dd020000-dd021fff

[root@toys ~]# route
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
192.168.1.0 * 255.255.255.0 U 0 0 0 wlan0
169.254.0.0 * 255.255.0.0 U 0 0 0 wlan0
default 192.168.1.1 0.0.0.0 UG 0 0 0 wlan0

Pinging to WWW has no response at all, can only ping internal IP's. When pinging domains, dns is resolved properly too.

[root@toys ~]# ping woosh.com
PING woosh.com (202.74.207.101) 56(84) bytes of data.

Does anyone has any ideas how to fix this no data issue??

Last edited by sti2envy; 03-10-2005 at 01:00 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
WPA-PSK w/ ndiswrapper microsoft/linux Linux - Laptop and Netbook 1 08-29-2005 10:02 PM
WPA-TKIP ipw2200 havelino Linux - Wireless Networking 0 04-24-2005 11:24 AM
WPA/TKIP with Knoppix 3.8? Jackie78 Linux - Wireless Networking 0 04-03-2005 02:13 PM
How to use xsupplicant, wpa_supplicant for wpa/tkip/peap-mschapv2 weeds84 Linux - Wireless Networking 2 03-13-2005 06:17 AM
How do i set up WPA PSK with wpa supplicant and linuxant? Eleavings Linux - Wireless Networking 4 12-27-2004 12:24 PM


All times are GMT -5. The time now is 05:53 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration