LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 01-05-2010, 10:24 PM   #1
jcamez
LQ Newbie
 
Registered: Oct 2006
Location: Guaymas, Sonora, Mexico
Distribution: Home: Slackware 12.2, Slackware current.
Posts: 16

Rep: Reputation: 1
canīt boot updated kernel slackware current


Hi Guys:
I updated my kernel in slackware current but canīt install lilo, when i was with my old kernel it gave an error about not finding the sda drives (they were named hda before the upgrade).
I booted into the slackware 13.0 dvd and modified fstab and lilo.conf replacing hda with sda but lilo still gives an error of not finding sda drives.
How can i install lilo so i can boot into my sistem????

Iīm really lost here.
Can anyone help???

Thanks in advance.
 
Click here to see the post LQ members have rated as the most helpful post in this thread.
Old 01-05-2010, 11:02 PM   #2
~sHyLoCk~
Senior Member
 
Registered: Jul 2008
Location: /dev/null
Posts: 1,173
Blog Entries: 12

Rep: Reputation: 129Reputation: 129
Can you post your
Quote:
fdisk -l
after booting with Slackware DVD.
 
Old 01-06-2010, 12:40 AM   #3
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 2,447

Rep: Reputation: 875Reputation: 875Reputation: 875Reputation: 875Reputation: 875Reputation: 875Reputation: 875
you have to substitute every occurence of /dev/hda with sda in lilo.conf but one
Code:
boot=/dev/hda
has to be left because lilo still see the drive as /dev/hda until you reboot and it needs a valid install target. then issue
Code:
lilo
and reboot.
after reboot (remember that in need you can specify the root partition with root=/dev/sdax kernel option at boot prompt) you can fix the line in lilo.conf above.

Last edited by ponce; 01-06-2010 at 12:42 AM.
 
2 members found this post helpful.
Old 01-06-2010, 01:58 AM   #4
samac
Senior Member
 
Registered: Mar 2004
Location: Westray, Orkney
Distribution: Slackware64-14.1 (multi-lib) KDE 4.11.4
Posts: 1,422

Rep: Reputation: 137Reputation: 137
Quote:

you have to substitute every occurence of /dev/hda with sda in lilo.conf but one
Code:

boot=/dev/hda

has to be left because lilo still see the drive as /dev/hda until you reboot and it needs a valid install target
Just had a look at my lilo.conf, setup by -current with the 2.6.32.2 kernel and boot = /dev/sda and it works fine.

samac
 
Old 01-06-2010, 02:28 PM   #5
gegechris99
Member
 
Registered: Oct 2005
Location: France
Distribution: Slackware 14.1 32bit
Posts: 723
Blog Entries: 3

Rep: Reputation: 77
Quote:
Originally Posted by samac View Post
Just had a look at my lilo.conf, setup by -current with the 2.6.32.2 kernel and boot = /dev/sda and it works fine.

samac
I'm planning to upgrade to 2.6.32.2-smp kernel and I need to use an initrd.gz image.

File README.initrd was also updated in -current and it does not contain any warning about change of drive naming convention.

So my question is: which -r option should I use:

Code:
mkinitrd -c -k 2.6.32.2-smp -m ext4 -f ext4 -r /dev/hdd2
or

Code:
mkinitrd -c -k 2.6.32.2-smp -m ext4 -f ext4 -r /dev/sdd2
Feedback from any user who upgraded kernel in -current and who's using initrd.gz image would be appreciated.
 
Old 01-06-2010, 02:42 PM   #6
SqdnGuns
Member
 
Registered: Aug 2005
Location: Fountain Valley, CA / Thailand
Distribution: Slackware64Ū 14.0
Posts: 981

Rep: Reputation: 88
Right from the changelog for current, x86 and x86_64:

Mon Jan 4 21:43:02 UTC 2010
New kernels... and this deserves a mention/warning: the last bits of the "old" IDE/ATA system have been removed now. Everything should be using the libata based drivers now, so if you have any drives that are currently running as /dev/hda, /dev/hdb, etc., when you reboot with these kernels all drives will be renamed as /dev/sda, /dev/sdb, etc. If you had any /dev/sd* already, they might get renamed. Adjustments may be required in /etc/lilo.conf, /etc/fstab, the initrd, and elsewhere. Good luck!
 
Old 01-06-2010, 02:45 PM   #7
gegechris99
Member
 
Registered: Oct 2005
Location: France
Distribution: Slackware 14.1 32bit
Posts: 723
Blog Entries: 3

Rep: Reputation: 77
@SqdnGuns

Yes I've read the Changelog file. My remark about lack of information about change of drive name applied to README.initrd. Thus my question regarding the most appropriate syntax for the mkinitrd command.

Based on your post, I would undestand that I need to use the -r /dev/sdd2 option.

[EDIT] I asked because I plan to run mkinitrd with 2.6.29 kernel running just after upgrading the kernel packages.

Last edited by gegechris99; 01-06-2010 at 02:48 PM. Reason: I asked because mkinitrd would be run with 2.6.29 kernel
 
Old 01-06-2010, 03:20 PM   #8
samac
Senior Member
 
Registered: Mar 2004
Location: Westray, Orkney
Distribution: Slackware64-14.1 (multi-lib) KDE 4.11.4
Posts: 1,422

Rep: Reputation: 137Reputation: 137
I just copied the command for mkinitrd ext3 and modified it for ext4 and kernel 2.6.32.2 and it works just fine. Remembering of course to make a new lilo.conf entry and re-running lilo.

samac
 
Old 01-06-2010, 03:29 PM   #9
gegechris99
Member
 
Registered: Oct 2005
Location: France
Distribution: Slackware 14.1 32bit
Posts: 723
Blog Entries: 3

Rep: Reputation: 77
Thanks samac for quick feedback.

But I'm not sure how to interpret your feedback regarding the -r option. Which one did you use -r /dev/hdxx or - r /dev/sdxx or nothing?

According to "man mkinitrd":

Quote:
-r root partition
Specify the device to be used as the root partition. If
this isn't given, the kernel default will be used (which is
usually fine).
As I'm using /dev/hdd2 as my Slackware partition, there is a good chance that kernel default will not be correct (or am I wrong?).
 
Old 01-06-2010, 03:41 PM   #10
merchtemeagle
Member
 
Registered: Oct 2004
Location: Belgium
Distribution: Slackware 13.37
Posts: 512

Rep: Reputation: 31
I also upgraded to current. I changed all occurences of hda to sda in /etc/fstab, and tried various combinations of hda and sda in lilo.conf (after which I called lilo every time), but no matter what I try, my system always stops after
Loading vmlinuz...........................................................

Is it mandatory to use initrd with this kernel version? (all my partitions are ext4)
 
Old 01-06-2010, 03:45 PM   #11
samac
Senior Member
 
Registered: Mar 2004
Location: Westray, Orkney
Distribution: Slackware64-14.1 (multi-lib) KDE 4.11.4
Posts: 1,422

Rep: Reputation: 137Reputation: 137
Quote:
mkinitrd -c -k 2.6.32.2 -m mbcache:jbd:ext4 -f ext4 -r /dev/sda1
Isn't bash history wonderful.

samac
 
Old 01-06-2010, 04:02 PM   #12
merchtemeagle
Member
 
Registered: Oct 2004
Location: Belgium
Distribution: Slackware 13.37
Posts: 512

Rep: Reputation: 31
Quote:
Originally Posted by merchtemeagle View Post
Is it mandatory to use initrd with this kernel version? (all my partitions are ext4)
Quote:
Originally Posted by samac View Post
Isn't bash history wonderful.
I take that as a yes then
 
Old 01-06-2010, 04:16 PM   #13
samac
Senior Member
 
Registered: Mar 2004
Location: Westray, Orkney
Distribution: Slackware64-14.1 (multi-lib) KDE 4.11.4
Posts: 1,422

Rep: Reputation: 137Reputation: 137
No it is only required when you use the generic.s kernel (recommended) if you use the huge.s kernel you will not need and initrd.gz

samac
 
1 members found this post helpful.
Old 01-06-2010, 04:25 PM   #14
gegechris99
Member
 
Registered: Oct 2005
Location: France
Distribution: Slackware 14.1 32bit
Posts: 723
Blog Entries: 3

Rep: Reputation: 77
Thank you samac.

I'll try with this syntax.
 
Old 01-06-2010, 04:42 PM   #15
merchtemeagle
Member
 
Registered: Oct 2004
Location: Belgium
Distribution: Slackware 13.37
Posts: 512

Rep: Reputation: 31
Quote:
Originally Posted by ponce View Post
you have to substitute every occurence of /dev/hda with sda in lilo.conf but one
Code:
boot=/dev/hda
has to be left because lilo still see the drive as /dev/hda until you reboot and it needs a valid install target. then issue
Code:
lilo
and reboot.
after reboot (remember that in need you can specify the root partition with root=/dev/sdax kernel option at boot prompt) you can fix the line in lilo.conf above.
I managed to get my system running again by using this method. Thanks!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Suggestion for slackware current: Updated slrn andrew.46 Slackware 7 11-08-2008 04:39 PM
kernel-update, a success... BUT... couldn't boot from the updated-kernel Pisces107 Red Hat 7 12-17-2003 02:27 PM
Updated Kernel - Choosing at boot link1305 Linux - General 5 11-25-2003 07:38 PM
howto boot updated kernel assaflavie Linux - Newbie 1 07-03-2003 09:39 AM
Updated Slackware Kernel - no modules Freaksta Linux - Software 6 02-28-2003 10:53 AM


All times are GMT -5. The time now is 09:37 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration