LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 02-02-2013, 02:26 PM   #1
nando321
Member
 
Registered: May 2011
Distribution: Slackware
Posts: 73

Rep: Reputation: 1
Cairo Dock error "No protocol specified". Docky Gtk cannot open display: :0


Hello again. This time I am trying to find out what's going on with Cairo Dock and Docky, when I type in the terminal as root and as non-root (normal user) as well I get that output for Cairo Dock:
Quote:
No protocol specified
And Docky:
Quote:
[Info 16:17:33.908] Docky version: 2.1.0 bzr stacks-2.1.0 r1556
[Info 16:17:33.943] Kernel version: 3.2.29.0
[Info 16:17:33.943] CLR version: 2.0.50727.1433
No protocol specified
[Warn 16:17:33.984] [Gtk] cannot open display: :0
The Docky packages that I've installed are from .deb's to .tgz's that I could convert using alien (I boot the Ubuntu Live DVD, install alien and do the convertion).
What I couldn't do though is install the packages of cairo using sbopkg, I can add them to the queue and download them but the building always fails.

So, that's all I can tell you about it. Any ideas will be appreciated.
Thanks in advance.
 
Old 02-02-2013, 04:41 PM   #2
nando321
Member
 
Registered: May 2011
Distribution: Slackware
Posts: 73

Original Poster
Rep: Reputation: 1
I've got something now. By removing and installing cairo-dock again and its plugins it is working now but I've already had a big fight with this message before and nothing could fix it. This is the damned window that appears every time I log in:
Quote:
Do you want to activate OpenGL?
(To not show this dialog, launch the dock from the Application menu,
or with the -o option to force OpenGL and -c to force cairo.)
I'm telling ya, I've tried all the options with this but nothing solved the problem I tried disabling cairo from the startup, I tried "cairo-dock -c -o", "cairo-dock -c", "cairo-dock -o -c" but none of this options have worked out the problem!

Last edited by nando321; 02-02-2013 at 05:10 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How do I disable autocomplete in Gnome's/Cairo-Dock's "open file" dialog? DaneM Linux - Software 0 07-11-2012 06:27 AM
"Gtk-WARNING **: cannot open display: " when I su dack_x Linux - Software 5 11-03-2007 12:49 PM
The problem about "cairo" in installing of "GTK" :( zhuqlfeixia Linux - Hardware 1 01-28-2006 03:12 PM
"GTK warning :cannot open display" Help me please riya Linux - Newbie 7 01-23-2006 07:04 AM
"GTK-warning**: Cannot open display" Leon S. Kennedy Linux - Newbie 1 07-21-2003 03:05 AM


All times are GMT -5. The time now is 01:52 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration