LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 01-20-2011, 06:59 PM   #1
Stella_C
LQ Newbie
 
Registered: Jan 2011
Posts: 3

Rep: Reputation: 0
Apple Time Capsule DHCP sets bogus hostname


Hi all

During Slackware 13.1 setup, I chose the hostname stella-sl2.

This hostname is also the one that the system is displaying before I configured network access.

After configuring wired network access to my Apple Time Capsule, my hostname suddenly changed to INTERFACE='eth0'.

As a result I'm noticing some very strange things, like the login prompt which has become "INTERFACE='eth0' login: ".

After configuring wireless network access to the Time Capsule, the hostname changed to "INTERFACE='wlan0'". Note that, during boot, wlan0 is brought up AFTER eth0.

Also strange is this:
bash-4.1$ cat /etc/HOSTNAME
INTERFACE='eth0'.DNSSERVERS='10.0.1.1'
bash-4.1$ /bin/hostname
INTERFACE='wlan0'
bash-4.1$

Until now, it was only a minor annoyance, it didn't prevent anything from happening, internet connection was not affected. But now I'm configuring sendmail which needs to talk to a relay SMTP server, and sendmail "HELO"'s itself using the bogus hostname:

>>> HELO INTERFACE='wlan0'
<<< 501 HELO requires valid address
554 5.0.0 Service unavailable

Probably this is caused by the Time Capsule not adhering to standards. However, the Time Capsule's firmware is the latest version, so I cannot fix this.

Is there a way to prevent dhcp from changing the hostname? How can I make sure that the hostname that I configured during setup remains active?

Thank you
Sebastian

Last edited by Stella_C; 01-20-2011 at 07:06 PM.
 
Old 01-20-2011, 07:53 PM   #2
Stella_C
LQ Newbie
 
Registered: Jan 2011
Posts: 3

Original Poster
Rep: Reputation: 0
In meanwhile I found a simple but not very elegant fix.

I removed the bogus hostname and entered my correct hostname in /etc/HOSTNAME

Then I removed write access from that file, to prevent dhcp from modifing it again.

I rebooted, and success, my hostname was stella-sl2 instead of INTERFACE=whatever.

Then I tried to have sendmail relay a mail message to our SMTP relay, again success: "... stat=Sent (Message accepted for delivery...".

It works, but I don't like my workaround as /etc/HOSTNAME should be having its default permissions.

Anyone has another suggestion to prevent dhcp from configuring a bogus hostname?

Last edited by Stella_C; 01-20-2011 at 07:54 PM.
 
Old 01-21-2011, 03:18 PM   #3
GazL
Senior Member
 
Registered: May 2008
Posts: 3,502

Rep: Reputation: 1024Reputation: 1024Reputation: 1024Reputation: 1024Reputation: 1024Reputation: 1024Reputation: 1024Reputation: 1024
One approach might be to change your /etc/dhcpcd.conf, specifically remove the option that requests a host-name on the following line:
Code:
# A list of options to request from the DHCP server.
option domain_name_servers, domain_name, domain_search, host_name
I don't have any Apple stuff and have never encountered this issue before so this is just a guess, but it may be worth a try.

'man dhcpcd' and 'man dhcpcd.conf' may provide other areas to explore.
 
Old 01-21-2012, 05:39 PM   #4
rworkman
Slackware Contributor
 
Registered: Oct 2004
Location: Tuscaloosa, Alabama (USA)
Distribution: Slackware
Posts: 1,945

Rep: Reputation: Disabled
Guess who just ran across this same problem today? :-)
Do you have avahi installed? If so, have a look at /etc/avahi/avahi-dnsconfd.action and its assumptions about /sbin/netconfig. Let me know if you can't figure out the appropriate fix :-)
 
Old 01-29-2012, 04:26 PM   #5
Stella_C
LQ Newbie
 
Registered: Jan 2011
Posts: 3

Original Poster
Rep: Reputation: 0
I had the problem described above in Slackware 13.1. The problem did no longer appear in Slackware 13.37, not sure why exactly but I'm happy.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Time capsule for ubuntu kb2tfa Linux - Software 1 07-03-2009 01:13 PM
Dhcp server reporting bogus mac id while binding. shellarchive Red Hat 3 06-19-2009 03:07 AM
Slackware 11/ipw3945 & Time Capsule WiFi base station connectivity problem slackist Slackware 2 01-04-2009 05:54 AM
Time Capsule - Slackware Linux 1.1.2. AxXium Slackware 6 11-10-2005 11:14 AM
Mandrake Sets Hostname Before Getting IP? mac_phil Mandriva 1 09-30-2003 10:41 AM


All times are GMT -5. The time now is 01:35 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration