LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 04-24-2008, 07:15 AM   #1
thedp
LQ Newbie
 
Registered: Sep 2004
Distribution: Slackware 12.0
Posts: 22

Rep: Reputation: 15
Question After Slackware 12.0 installation


Hello,

Yesterday I've finally installed Slackware 12.0, and it looks GREAT
I would like to configure a couple of things to make it perfect:

- When I start the PC I need to press ENTER for the boot to start when it prompts me for "boot:". How can I skip this and make the Slackware start automatically?

- After Slackware loads it remains in command-line mode, which makes me login and then execute startx. How can I make startx to start automacally before I login, when Slackware finished loading?

- Since this PC is meant to be a remote station without any screen, keyboard or mouse, I need VNC to control it. But currently I need to login and then start vncserver. How can I start vncserver automatically before I login, and login only though the VNC?


Thank you.
 
Old 04-24-2008, 07:24 AM   #2
Nylex
LQ Addict
 
Registered: Jul 2003
Location: London, UK
Distribution: Slackware
Posts: 7,464

Rep: Reputation: Disabled
For the first problem, you'll need to edit /etc/lilo.conf and change the timeout field to 0. After doing this, you'll need to run /sbin/lilo for the changes to take effect. Both editing the file and running lilo will need to be done as root.

For the second problem, you'll need to change your default runlevel to 4. This can be done by editing /etc/inittab and changing the line "id:3:initdefault:" to "id:4:initdefault:". Again, you'll need to be root to edit the file.
 
Old 04-24-2008, 07:29 AM   #3
duryodhan
Senior Member
 
Registered: Oct 2006
Distribution: Slackware 12 Kernel 2.6.24 - probably upgraded by now
Posts: 1,054

Rep: Reputation: 46
Quote:
- Since this PC is meant to be a remote station without any screen, keyboard or mouse, I need VNC to control it. But currently I need to login and then start vncserver. How can I start vncserver automatically before I login, and login only though the VNC?
You will need to add the command that start vnc to /etc/rc.d/rc.local

for e.g if it is 'vncserver'

do in bash shell
Quote:
#which vncserver
#vim /etc/rc.d/rc.local
add the output of which vncserver to a new line in rc.local
 
Old 04-24-2008, 07:32 AM   #4
pwc101
Senior Member
 
Registered: Oct 2005
Location: UK
Distribution: Slackware
Posts: 1,846

Rep: Reputation: 128Reputation: 128
Quote:
Originally Posted by thedp View Post
- Since this PC is meant to be a remote station without any screen, keyboard or mouse, I need VNC to control it. But currently I need to login and then start vncserver. How can I start vncserver automatically before I login, and login only though the VNC?
I've never done this, but I would think adding the appropriate vncserver command to /etc/rc.d/rc.local would do the trick (make sure /etc/rc.d/rc.local is executable). Then, the command will be executed when the machine is turned on, allowing you to connect remotely.
 
Old 04-24-2008, 08:01 AM   #5
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 5,115

Rep: Reputation: Disabled
I used to have the following in my /etc/rc.d/rc.local to start a VNC server for my account:
Code:
su - alien -c "vncserver >/home/alien/log/vncserver.log 2>&1"
You need to run vncserver at least once manually in order to setup the vncpassword.

Eric
 
Old 04-24-2008, 08:28 AM   #6
trashbird1240
Member
 
Registered: Sep 2006
Location: Durham, NC
Distribution: Slackware, Ubuntu (yes, both)
Posts: 463

Rep: Reputation: 31
Smile

Quote:
Originally Posted by Nylex View Post
For the first problem, you'll need to edit /etc/lilo.conf and change the timeout field to 0. After doing this, you'll need to run /sbin/lilo for the changes to take effect. Both editing the file and running lilo will need to be done as root.
You may want to set it to 5 or 10, to give you a chance to boot a different kernel or different OS on the same machine. On the other hand if 5 seconds is too long...

Joel
 
Old 04-24-2008, 10:10 AM   #7
thedp
LQ Newbie
 
Registered: Sep 2004
Distribution: Slackware 12.0
Posts: 22

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by Alien Bob View Post
I used to have the following in my /etc/rc.d/rc.local to start a VNC server for my account:
Code:
su - alien -c "vncserver >/home/alien/log/vncserver.log 2>&1"
You need to run vncserver at least once manually in order to setup the vncpassword.

Eric
Can you please explain this command?
 
Old 04-24-2008, 10:20 AM   #8
thedp
LQ Newbie
 
Registered: Sep 2004
Distribution: Slackware 12.0
Posts: 22

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by duryodhan View Post
You will need to add the command that start vnc to /etc/rc.d/rc.local

for e.g if it is 'vncserver'

do in bash shell
add the output of which vncserver to a new line in rc.local
It's not working, is it possible that /etc/rc.d/rc.local is not executed at startup?
Also, should it be executed after or before user login?

Another thing is the user attachment to the vncserver, I think I need to specify the user that starts the service.
 
Old 04-24-2008, 10:27 AM   #9
pwc101
Senior Member
 
Registered: Oct 2005
Location: UK
Distribution: Slackware
Posts: 1,846

Rep: Reputation: 128Reputation: 128
If /etc/rc.d/rc.local is executable (check with ls -l /etc/rc.d/rc.local), then it'll be executed at startup (before log in). The
Code:
su - insert_your_username_here
part of the command runs the command as though it had been launched by which ever username is specified by "insert_your_username_here".

Test the command as root to see if it launches the vncserver correctly, and then check who owns that process with
Code:
ps -ef | grep vncserver
That should show you the process's information, including who it's owned by.

Last edited by pwc101; 04-24-2008 at 10:28 AM.
 
Old 04-26-2008, 12:00 PM   #10
thedp
LQ Newbie
 
Registered: Sep 2004
Distribution: Slackware 12.0
Posts: 22

Original Poster
Rep: Reputation: 15
Thank you all so much for the replies, everything is working great.
 
  


Reply

Tags
boot, login, slackware, startx, vnc, vncserver


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off



All times are GMT -5. The time now is 08:51 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration