LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 09-02-2009, 01:41 PM   #1
mudherm
LQ Newbie
 
Registered: Nov 2004
Location: BC, Canada.
Distribution: Slackware64 - current
Posts: 20
Blog Entries: 3

Rep: Reputation: 0
4gb memory in Slackware64


I have an older machine with 4gb of memory installed.

I'm using Slack64 generic updated last night from current.

When I looked at config theres no mention of config_highmem so I'm thinking that Slackware64 should see the 4gb.

... and if it doesn't then the problem may well be hardware...

Is this correct or have I missed something?

mudherm
 
Old 09-02-2009, 01:44 PM   #2
H_TeXMeX_H
Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Rep: Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269
highmem is a hack to get more than 4GB (or even 4GB) for 32-bit systems, on a 64-bit system this option does not exist. 4GB should be seen by the system, unless there's some type of BIOS limit.
 
Old 09-02-2009, 01:46 PM   #3
Jeebizz
Senior Member
 
Registered: May 2004
Distribution: Slackware 14.1 64-bit with multilib
Posts: 2,075

Rep: Reputation: 210Reputation: 210Reputation: 210
Do a cat /proc/meminfo or free -m to see.
 
Old 09-02-2009, 01:50 PM   #4
mudherm
LQ Newbie
 
Registered: Nov 2004
Location: BC, Canada.
Distribution: Slackware64 - current
Posts: 20
Blog Entries: 3

Original Poster
Rep: Reputation: 0
I thought so... and I don't have a monitor connected to that PC. In fact I don't have anything but power and a network cable....

Thanks for the help..!
 
Old 09-02-2009, 01:52 PM   #5
Jeebizz
Senior Member
 
Registered: May 2004
Distribution: Slackware 14.1 64-bit with multilib
Posts: 2,075

Rep: Reputation: 210Reputation: 210Reputation: 210
Hrmm, well if you enabled ssh you can simply login remotely. Or briefly connect the monitor back to that particular machine. Hrmm, a KVM-switch sounds very useful in a case like this...
 
Old 09-02-2009, 02:01 PM   #6
mudherm
LQ Newbie
 
Registered: Nov 2004
Location: BC, Canada.
Distribution: Slackware64 - current
Posts: 20
Blog Entries: 3

Original Poster
Rep: Reputation: 0
the machine works great, ssh.. et al'

Infact I've been using it from work but I'm only seeing 2gb of memory not the 4. I didn't want to try anything too fancy with the pacific ocean between me and the physical box but it looks like I'll have to plug stuff into it.

Youre right about a kvm but once I get this sorted I wont need it. I could always use a soft keyboard sharing program but that won't help in this case.

I'll live with the 2gb for now.

cheers

Paul.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
32 bit OS and 4GB memory limit the_gripmaster Linux - General 45 08-07-2011 09:07 PM
32-bit application accessing memory more than 4GB parthi_s Linux - Newbie 2 04-07-2009 07:58 AM
4GB memory issue in Centos 5 LinuxLover Linux - Hardware 2 02-27-2009 08:18 AM
Intel 945 chipset and 4GB of memory danielsbrewer Linux - Hardware 2 08-23-2007 03:25 AM
What's the Max XP memory ( 4GB ? ) deft General 3 01-20-2004 11:16 PM


All times are GMT -5. The time now is 02:05 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration