LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 12-19-2003, 02:17 PM   #1
RTT
Member
 
Registered: Nov 2003
Location: England
Distribution: slackware, FreeBSD
Posts: 33

Rep: Reputation: 15
2.6.0 make module error


hi,

After doing 'make menuconfig' and selecting all the stuff i need, and then 'make bzImage && make modules && make modules_install', about 1/2 way through 'make modules' i get this error ...

Code:
<snip>

  CC [M]  drivers/net/sk98lin/skgepnmi.o
{standard input}: Assembler messages:
{standard input}:10671: Error: value of ffffffffffffff73 too large for field of 1 bytes at 0000000000006a77
make[3]: *** [drivers/net/sk98lin/skgepnmi.o] Error 1
make[2]: *** [drivers/net/sk98lin] Error 2
make[1]: *** [drivers/net] Error 2
make: *** [drivers] Error 2
root@bash:/usr/src/linux#
I appreciate that this might be a totally cryptic error, or not one that is exactly 'answerable'. :/
but... Any help in resolving this issue very much appreciated

Last edited by RTT; 12-19-2003 at 02:31 PM.
 
Old 12-19-2003, 04:29 PM   #2
urka58
Member
 
Registered: Nov 2003
Distribution: slackware 14
Posts: 530

Rep: Reputation: 30
This because Slack 9.0 do not install by default the new module_init_tools required by the 2.6.0 kernel.
You have a couple of choices to fix this.
- install the newest version of module_init_tools and then recompile the kernel
- upgrade to Slack 9.1 It is ready for 2.6.0
Ciao
 
Old 12-19-2003, 04:56 PM   #3
superbondbond
Member
 
Registered: Nov 2002
Posts: 668

Rep: Reputation: 30
I got a very similar error at about the same time last night when I first tried to compile 2.6.0

I am however running 9.1

I'll go back and look into your suggestion urka58. hope that fixes it.

I'm glad I stumbled across this thread.
 
Old 12-19-2003, 06:14 PM   #4
RTT
Member
 
Registered: Nov 2003
Location: England
Distribution: slackware, FreeBSD
Posts: 33

Original Poster
Rep: Reputation: 15
Damnit, looks like module_init_tools didnt update itself properly when i first tried

Nice one urka
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
module-assistant auto-install ov511 ... make: *** [build-stamp] Error 2 brynjarh Linux - Hardware 1 11-13-2005 02:31 PM
module and make problems j0ck Linux - General 1 06-26-2005 02:03 PM
lopster v1.2.2 make error: No rule to make target `m4/glibc21.m4' Kropotkin Fedora 0 10-31-2004 11:19 AM
Error inserting Intel8x0 Module to make Sound Card Work cthrax Linux - Hardware 3 06-14-2004 11:11 PM
make: cc: command not found make: *** [gzip.o]error 127 zyjk Linux - Newbie 5 02-08-2002 09:58 AM


All times are GMT -5. The time now is 05:58 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration