LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 08-07-2009, 04:27 PM   #1
rpedrica
Member
 
Registered: Nov 2008
Location: Cape Town
Distribution: Slackware64 -current
Posts: 208

Rep: Reputation: 27
12.2/current KDE 4 desktop issues


I have a number of unsolved issues with KDE 4.x.x - I'm running -current ( as of today ) at the moment with KDE 4.2.4, NVidia binary driver 185.18.29 and GeFroce 7300GT.

1. konsole - never remembers my selection of 'show in menu' items ( Settings -> Manage Profiles -> select 'show in menu' for each profile ). As I have quite a number of profiles ( about 30 at last count ) it's a pain to go in each time and select 'show in menu' for each profile. Or am I doing something really stupid here?

2. I have an issue, which seems to happen after using OpenOffice apps for a while, with the kwin interface slowing down to a crawl. Any clicks, pop-ups, tool-tips, launch menu selections, panel autohide, etc takes about 5-10 seconds to execute. I'm using Robby Workman's 3.1 OO packages. The problem doesn't happen immediately ( only after a few days ) and I can't pin it down to OO specifically but is seems more than coincidence. 'top' doesn't show any CPU heavy apps running when this happens.

3. the system notifier in the lower right corner persists in showing info about kget even when kget has not items in progress ( see attachment )

4. window placement and sizing is a continuous issue - I normally use the following method:
a. set running app window to desired settings ( eg. full screen, 2nd monitor )
b. right-click title bar and 'Configure Windows Behaviour'
c. select 'window specific'
d. 'new' -> 'detect window properties' -> select app window
e. geometry
f. position -> remember
g. fullscreen -> remember

This is a bit of a lucky draw and sometimes I have to do this a number of times. I have to say that 3.5's window placement was a lot better.

5. folder view naming issue: if I create a link to a folder/app/whatever, then the name of the icon shows up as <name>.desktop. If I create a folder ( eg. ) in a folder view, then it has the correct name.

6. setting a name for an icon in a panel ( right-click -> icon settings ) using the general and/or application tab, does not always take.

7. system settings -> network settings -> network settings just throws a 'cannot parse xml settings' error.

8. k3b ( yes I know it's very alpha status ) crashes on ISO writes. non-ISO data/audio burns are fine.

9. sftp connection to a remote server in konqueror will request username/password 3 times before opening.

I know some of this is user knowledge but any help is appreciated - Regards, Robby
Attached Images
File Type: png kde1.png (35.2 KB, 13 views)
 
Old 08-07-2009, 07:02 PM   #2
justwantin
Member
 
Registered: Aug 2003
Location: Melbourne, Australia
Distribution: Slackware, Slackware ARM, Salix and Porteus
Posts: 567

Rep: Reputation: 45
1. Are you using the konsole configs from kde3? I found this was problematic and started new configs whith kde4

2. Haven't noticed but I built with script from slacky.eu

3. Can't comment ATM not in current

4. Ditto

5&6 Maybe mt reply in this thread might help http://www.linuxquestions.org/questi...around-745797/

7,8&9 I don't use them
 
Old 08-08-2009, 04:45 AM   #3
rpedrica
Member
 
Registered: Nov 2008
Location: Cape Town
Distribution: Slackware64 -current
Posts: 208

Original Poster
Rep: Reputation: 27
Justwantin,

1. I cleared out my konsole configs ( in fact all configs ) from my 3.5 installs and started afresh

2. let me try my own build ...

thanks for 5&6 - I'll take a look at your hints. And now another item that drives me mad:

10. My screensaver does not start automatically! have to use ctrl-l to start it which is a pain.
 
Old 08-08-2009, 05:10 AM   #4
Eternal_Newbie
Member
 
Registered: Jun 2005
Location: The Pudding Isles
Distribution: Slackware 13.37
Posts: 573

Rep: Reputation: 59
7 As far as I know, KDE Network Settings is non-functional with Slackware and has been for a while. If you need a GUI use WICD.
8 Use the KDE 3 K3b in /extra

Last edited by Eternal_Newbie; 08-08-2009 at 05:11 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Slackware-current and kde 4.2 desktop folder view workaround Scuzz Slackware 2 08-08-2009 09:42 AM
current location for setting desktop prefs in kde4 vs kde 3? babag Mandriva 9 05-19-2009 12:51 AM
Detecting the current Desktop manager KDE or GNOME munsingh Linux - Newbie 2 04-16-2009 01:54 AM
Slackware 12.2(current) + KDE 4.1.96 + Xinerama = No Desktop Effects frandalla Slackware 3 01-29-2009 11:22 AM
[solved] kde only show windows from current desktop in taskbar secretlydead Linux - Desktop 1 08-29-2007 01:21 PM


All times are GMT -5. The time now is 07:49 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration