LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 03-13-2013, 12:12 PM   #1
myglide
Member
 
Registered: Mar 2013
Location: Texas
Distribution: slackware 14.0
Posts: 58

Rep: Reputation: Disabled
$DISPLAY is not set or cannot connect to X server


I get this message when I try to use "exec startkde' at the command line. how can I fix this?
 
Old 03-13-2013, 12:22 PM   #2
Mike_M
Member
 
Registered: Mar 2011
Location: California
Distribution: Slackware
Posts: 116

Rep: Reputation: 50
My guess would be that you don't have an X server running. Run "startx" from the command line. If KDE isn't correctly set up as your desktop environment, first run "xwmconfig" and choose the option for xinitrc.kde. Then run "startx" to launch X and KDE.
 
2 members found this post helpful.
Old 03-13-2013, 12:38 PM   #3
myglide
Member
 
Registered: Mar 2013
Location: Texas
Distribution: slackware 14.0
Posts: 58

Original Poster
Rep: Reputation: Disabled
that did it

thank you for your reply. startx worked when I entered it from root on the command line. a gui came up now i will figure out if its kde or not.
 
Old 03-13-2013, 03:48 PM   #4
maciuszek
Member
 
Registered: Nov 2010
Location: Toronto, Ontario
Distribution: Slackware + FreeBSD
Posts: 59

Rep: Reputation: 17
an addition:
since your mentioning of kde is redundant to this thread topic, im assuming you still wanted general information .. have a look at .[xsession,xinitrc] in your homedir and or /etc/X11/xinit/
... changing what startx invokes can also be automated with the script xwmconfig (you can select kde).

Last edited by maciuszek; 03-13-2013 at 05:42 PM.
 
Old 03-13-2013, 04:55 PM   #5
myglide
Member
 
Registered: Mar 2013
Location: Texas
Distribution: slackware 14.0
Posts: 58

Original Poster
Rep: Reputation: Disabled
thanks for your reply maciuszek. i remember seeing the xwmconfig app during install. xsession looks...different. i'll have to work on the commands to look at the other 2.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
xlib:unable to connect to server display dsschanze Linux - Software 1 11-28-2012 05:48 AM
Can't connect to X11 window server using ':0.0' as the value of the DISPLAY variable. defa0009 Linux - General 13 01-20-2012 02:55 PM
Can't connect to X11 window server using ':0' as the value of the DISPLAY variable. chakrinu Linux - Server 3 12-21-2010 06:59 PM
Problem starting gui, "$DISPLAY is not set or cannot connect to the x server" GlennsPref Mandriva 14 02-28-2009 06:15 PM
Server Status can not display by XDMCP connect taisuke Linux - Networking 1 08-26-2004 09:37 PM


All times are GMT -5. The time now is 07:46 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration