LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   $DISPLAY is not set or cannot connect to X server (http://www.linuxquestions.org/questions/slackware-14/%24display-is-not-set-or-cannot-connect-to-x-server-4175453930/)

myglide 03-13-2013 12:12 PM

$DISPLAY is not set or cannot connect to X server
 
I get this message when I try to use "exec startkde' at the command line. how can I fix this?

Mike_M 03-13-2013 12:22 PM

My guess would be that you don't have an X server running. Run "startx" from the command line. If KDE isn't correctly set up as your desktop environment, first run "xwmconfig" and choose the option for xinitrc.kde. Then run "startx" to launch X and KDE.

myglide 03-13-2013 12:38 PM

that did it
 
thank you for your reply. startx worked when I entered it from root on the command line. a gui came up now i will figure out if its kde or not.

maciuszek 03-13-2013 03:48 PM

an addition:
since your mentioning of kde is redundant to this thread topic, im assuming you still wanted general information .. have a look at .[xsession,xinitrc] in your homedir and or /etc/X11/xinit/
... changing what startx invokes can also be automated with the script xwmconfig (you can select kde).

myglide 03-13-2013 04:55 PM

thanks for your reply maciuszek. i remember seeing the xwmconfig app during install. xsession looks...different. i'll have to work on the commands to look at the other 2.


All times are GMT -5. The time now is 10:46 PM.