LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Sabayon
User Name
Password
Sabayon This forum is for the discussion of Sabayon Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 01-04-2014, 11:52 AM   #1
fuorviato
Member
 
Registered: Dec 2013
Location: Poland
Distribution: Sabayon/Gentoo 64bit
Posts: 215

Rep: Reputation: 14
glxinfo shows old mesa instead of the upgraded one


I'm trying to launch a game: metro low light. It needs some higher mesa version than the default one provided by sabayon (9.2.2), mostly due to OpenGL 3.3 so I thought about upgrading it to 10.01 which is the most recent release upstream.
I just pulled in the sources directly from the website, made sure all the deps were in the system, ran the configure scripts and eventually, installed the libs along with the dri drivers.
Now, I'd expect glxinfo to show that mesa is upgraded but instead:

Code:
OpenGL version string: 3.0 Mesa 9.2.2
I have also found out that it may be "mesa-progs" package which is outdated having problems at recognizing the correct version, but it's up to 8.1.0 which is the most recent.

Do you have any idea why 9.2.2 is still there

thanks in advance
 
Old 01-05-2014, 10:46 PM   #2
fuorviato
Member
 
Registered: Dec 2013
Location: Poland
Distribution: Sabayon/Gentoo 64bit
Posts: 215

Original Poster
Rep: Reputation: 14
Anybody?
 
Old 01-05-2014, 11:40 PM   #3
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Hanover, Germany
Distribution: Gentoo, Slackware
Posts: 14,903
Blog Entries: 2

Rep: Reputation: 3812Reputation: 3812Reputation: 3812Reputation: 3812Reputation: 3812Reputation: 3812Reputation: 3812Reputation: 3812Reputation: 3812Reputation: 3812Reputation: 3812
I don't have an answer to your question, but I can save you some time. On my Radeon HD6870 with the latest libdrm, Mesa 10.0.1 and LLVM/Clang from git Metro Last Light does not work correctly.
 
1 members found this post helpful.
Old 01-06-2014, 01:39 AM   #4
fuorviato
Member
 
Registered: Dec 2013
Location: Poland
Distribution: Sabayon/Gentoo 64bit
Posts: 215

Original Poster
Rep: Reputation: 14
Quote:
Originally Posted by TobiSGD View Post
I don't have an answer to your question, but I can save you some time. On my Radeon HD6870 with the latest libdrm, Mesa 10.0.1 and LLVM/Clang from git Metro Last Light does not work correctly.
OK. Thanks for the update. Just to make sure - you're talking about steam, native linux version, right?
 
Old 01-06-2014, 10:01 AM   #5
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Hanover, Germany
Distribution: Gentoo, Slackware
Posts: 14,903
Blog Entries: 2

Rep: Reputation: 3812Reputation: 3812Reputation: 3812Reputation: 3812Reputation: 3812Reputation: 3812Reputation: 3812Reputation: 3812Reputation: 3812Reputation: 3812Reputation: 3812
Yes, I bought the game on the Halloween sales and can't wait to play it, too, but I have to wait until the radeon driver supports it.
Luckily, radeon development is rather fast in the last time, so I think it won't be very long until the game works.
 
Old 01-07-2014, 03:26 AM   #6
fuorviato
Member
 
Registered: Dec 2013
Location: Poland
Distribution: Sabayon/Gentoo 64bit
Posts: 215

Original Poster
Rep: Reputation: 14
Quote:
Originally Posted by TobiSGD View Post
Yes, I bought the game on the Halloween sales and can't wait to play it, too, but I have to wait until the radeon driver supports it.
Luckily, radeon development is rather fast in the last time, so I think it won't be very long until the game works.
As far as I understand you haven't tried to install catalyst driver and run the game on it. Have you?
How did you get mesa 10.x into your system? By upgrading or new install?
 
Old 01-07-2014, 09:47 AM   #7
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Hanover, Germany
Distribution: Gentoo, Slackware
Posts: 14,903
Blog Entries: 2

Rep: Reputation: 3812Reputation: 3812Reputation: 3812Reputation: 3812Reputation: 3812Reputation: 3812Reputation: 3812Reputation: 3812Reputation: 3812Reputation: 3812Reputation: 3812
Quote:
Originally Posted by fuorviato View Post
As far as I understand you haven't tried to install catalyst driver and run the game on it. Have you?
How did you get mesa 10.x into your system? By upgrading or new install?
With Catalyst the game should run fine, but I haven't tried it. When using Catalyst you don't need to pay attention to Mesa, it is not used with that anyways.
I compiled Mesa 10.0.1 from source using the Slackbuild (as I have done with LLVM/Clang and libdrm), a method that doesn't apply to Gentoo/Sabayon. I don't know how the proper way to do that on Sabayon, but I am fairly sure that it should be quite easy on Gentoo.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] keyboard stopped working in X when I upgraded udev from 1.75 to 1.82After I upgraded RandomTroll Slackware 3 07-26-2012 02:48 PM
Mesa with DRI custom build shows black 3D windows (glxgears...) arond Linux - Software 0 08-20-2010 01:38 PM
[SOLVED] glxinfo question in new mesa package amiga32 Slackware 8 09-21-2009 05:16 AM
Graphics card supports opengl 2.1, but glxinfo shows only 1.4 WhatsUnderThere Linux - Hardware 3 02-25-2009 11:23 PM
Installing Mesa & Mesa-demos... bozotix Linux - Software 2 05-09-2002 12:55 AM


All times are GMT -5. The time now is 12:36 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration