LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 08-20-2010, 01:38 PM   #1
arond
LQ Newbie
 
Registered: Dec 2009
Distribution: OpenSuse 11.3
Posts: 5

Rep: Reputation: 0
Mesa with DRI custom build shows black 3D windows (glxgears...)


Hi, I'm using Opensuse 11.3 with the xorg and other video related packages from the X11org repo.

I have a question concerning the Mesa 3d library. The version from the X11org repository works well. However, building and installing Mesa by myself causes that certain 3d applications (glxgears or xmoto) only show a black screen. On both cases I can run compiz, which works quite well.

I have configured the custom Mesa build as follows (also tried enabling gallium), and in practice I use the i915 dri driver.

Quote:
prefix: /usr
exec_prefix: ${prefix}
libdir: ${exec_prefix}/lib
includedir: ${prefix}/include

Driver: dri
OSMesa: no
DRI drivers: i810 i915 i965 mach64 mga r128 r200 r300 r600 radeon savage sis tdfx unichrome swrast
DRI driver dir: ${libdir}/dri
Use XCB: no

Gallium: no

Shared libs: yes
Static libs: no
EGL: glx dri2
GLU: yes
GLw: yes (Motif: no)
glut: no
Demos: no

CFLAGS: -g -O2 -Wall -Wmissing-prototypes -std=c99 -ffast-math -fvisibility=hidden -fno-strict-aliasing -m32 -fPIC -m32
CXXFLAGS: -g -O2 -Wall -fno-strict-aliasing -m32 -fPIC -m32
Macros: -D_GNU_SOURCE -DPTHREADS -DHAVE_POSIX_MEMALIGN -DUSE_EXTERNAL_DXTN_LIB=1 -DIN_DRI_DRIVER -DGLX_DIRECT_RENDERING -DGLX_INDIRECT_RENDERING -DHAVE_ALIAS -DHAVE_XEXTPROTO_71 -DUSE_X86_ASM -DUSE_MMX_ASM -DUSE_3DNOW_ASM -DUSE_SSE_ASM
My question is what makes the opensuse build of Mesa different than my custom build? I see no big differences in the build configuration here: https://build.opensuse.org/package/v...ect=X11%3AXOrg

Also, I tried xlib instead of dri and that works, but really slow so not an option. (Im using the i586 version of the packages)


Thanks!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Mesa DRI why so old? gbowden Slackware 1 09-25-2009 09:34 AM
WEBCAM: Stickam shows black screen when Cheese shows cam 449 Linux - Software 16 08-04-2009 03:23 AM
Mesa linux-dri or linux-dri-x86 Won't Make Muraii Linux - Desktop 2 09-15-2006 12:19 AM
DRI and Mesa steelz Linux - Software 2 06-17-2005 09:05 AM
Glide? Mesa? DRI? amnesty_puppy Linux - Newbie 1 11-20-2004 06:47 PM


All times are GMT -5. The time now is 03:29 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration