LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices



Reply
 
Search this Thread
Old 06-16-2013, 10:07 PM   #16
GlennsPref
Senior Member
 
Registered: Apr 2004
Location: Brisbane, Australia
Distribution: Mageia Studio-13.37 Kubuntu.
Posts: 3,325
Blog Entries: 33

Rep: Reputation: 199Reputation: 199

Why did you have to configure and make squid instead of an rpm package?
Quote:
by the way now I've compiled the squid proxy server from source code...
It's been years (and years)since I have had to do that for squid.

Still looking.....

this string...
Quote:
echo 1 > /proc/sys/net/ipv4/ip_forward
will not stick on reboot, the /etc/sysctl.conf file takes care of that, you may be switching it off with the /etc/sysctl.conf script.

for now....
 
Old 06-19-2013, 12:03 AM   #17
s4starb4boy
LQ Newbie
 
Registered: Jun 2013
Posts: 20

Original Poster
Rep: Reputation: Disabled
Quote:
Why did you have to configure and make squid instead of an rpm package?
because I want to learn and fix the issue...

Now I've decided to uninstall teh squid and only configure iptables either is it working or not...I've watched one video series on youtube I'll follow it step by step. if I am not wrong I am still stick with my words that culprit could be or is "iptables"...so I will uninstall squid and only configure the iptables ad let the client pass through it lets see what happened...

here is the link I am going to follow...
https://www.youtube.com/watch?v=zG51...lbRwkZ-X968wVI
 
Old 06-22-2013, 12:54 AM   #18
s4starb4boy
LQ Newbie
 
Registered: Jun 2013
Posts: 20

Original Poster
Rep: Reputation: Disabled
Successful!
after a long struggle at last I got the one step success...
I didn't install SQUID and decide to share internet via iptables either is it work or not...

I followed this link..

https://www.centos.org/modules/newbb...topic_id=42474

from there these commands works for me...


/sbin/iptables -A FORWARD -i eth1 -o eth0 -m state --state ESTABLISHED,RELATED -j ACCEPT
/sbin/iptables -t nat -A POSTROUTING -s 192.168.0.0/24 -o eth0 -j MASQUERADE
/sbin/iptables-save > /etc/sysconfig/iptables
/sbin/service iptables restart

I've also set ip_forward to 1 in two places...

echo 1 > /proc/sys/net/ipv4/ip_forward

and

sysctl -w net.ipv4.ip_forward=1

then restarted the centOS 6.4 server and I am done!

I am very happy but now I would like to install SQUID Proxy Binary Package and would configure it as transparent PROXY SERVER.thats what I want...
 
1 members found this post helpful.
Old 06-22-2013, 08:08 PM   #19
GlennsPref
Senior Member
 
Registered: Apr 2004
Location: Brisbane, Australia
Distribution: Mageia Studio-13.37 Kubuntu.
Posts: 3,325
Blog Entries: 33

Rep: Reputation: 199Reputation: 199
Hi, you might find that iptables will complain....
Code:
 state --state
no longer supported...depreciated...

any where you see it in iptables script, replace it with
Code:
 conntrack --ctstate
So far, so good.
 
Old 06-25-2013, 12:37 AM   #20
s4starb4boy
LQ Newbie
 
Registered: Jun 2013
Posts: 20

Original Poster
Rep: Reputation: Disabled
Thanks Buddy! your given command
Quote:
conntrack --ctstate
is working too. I am going to play with SQUID in next few days.
 
Old 07-01-2013, 11:59 PM   #21
s4starb4boy
LQ Newbie
 
Registered: Jun 2013
Posts: 20

Original Poster
Rep: Reputation: Disabled
Hurrrry!
Thanks God! after a long ad long struggle now I am able to deploy SQUID as Transparent proxy server below is a rule set for iptables that works for me all other configuration remains same as above(previously posted)..

Quote:
iptables -t nat -A PREROUTING -i eth1 -p tcp --dport 80 -j DNAT --to 192.168.0.253:3128
iptables -t nat -A PREROUTING -i eth0 -p tcp --dport 80 -j REDIRECT --to-port 3128
iptables -I INPUT -s 192.168.0.0/16 -p tcp --dport 3128 -j ACCEPT
now I only have to set up 192.168.0.253 as gate on client machine that works for me.

I really thank you all who consider my post and gave comments and suggestions thank you all.
 
Old 07-03-2013, 01:20 AM   #22
GlennsPref
Senior Member
 
Registered: Apr 2004
Location: Brisbane, Australia
Distribution: Mageia Studio-13.37 Kubuntu.
Posts: 3,325
Blog Entries: 33

Rep: Reputation: 199Reputation: 199
Thank you, I'm glad you got it working.

Please mark your post as SOLVED. (thread tools)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem with rules in transparent squid proxy server hainguyenle89 Linux - Newbie 5 11-23-2011 02:54 AM
Squid as Transparent Proxy Server sudhirmhrj Linux - Newbie 8 07-01-2010 10:13 AM
squid proxy server and transparent issue kwaslee Linux - Server 1 04-13-2010 05:00 AM
Deploying a transparent socks 5 proxy on network hostmaster Linux - Software 0 02-14-2007 12:10 AM
transparent squid proxy server alvi2 Linux - Networking 4 02-24-2005 02:18 PM


All times are GMT -5. The time now is 06:21 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration