LinuxAnswers - the LQ Linux tutorial section.
Go Back > Forums > Linux Forums > Linux - Distributions > Red Hat
User Name
Red Hat This forum is for the discussion of Red Hat Linux.


  Search this Thread
Old 01-18-2013, 05:12 PM   #1
Registered: Jun 2012
Posts: 255

Rep: Reputation: Disabled
Network broadcast doesn't work in %pre script

I have a tool that I want to run in the %pre script of a kickstart install but it complains that the "network is not reachable". I can assign an IP address to eth0 while running in %pre and can access external addresses via unicast, but attempts to use broadcast messages fail.

Is there something I need to do to enable broadcast support while running in a %pre script?
Old 01-18-2013, 11:08 PM   #2
Registered: Jun 2012
Posts: 255

Original Poster
Rep: Reputation: Disabled
Based on some testing and some searches, one potential issue is that broadcasts don't work if a default route isn't defined. That doesn't make sense to me. The dhclient program for example uses a broadcast protocol under the covers to obtain IP information, and the whole intent is it can be used when a system doesn't have any IP information, and that includes no default gateway defined. So the very fact that dhclient works within the environment where the %pre script runs means that I should be able to write my own tool (I'm using Python) to use a broadcast protocol.

Perhaps I need to resort to raw sockets?


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Script on NIC Up - Doesn't Work Quantumstate Linux - Networking 2 01-19-2012 11:23 AM
LXer: Introducing Winesharer - so pre-alpha it doesn't even work LXer Syndicated Linux News 0 08-02-2009 02:30 PM
Network Manager 0.7 doesn't work or something wrong with my network card? G3N1USS Linux - Networking 0 12-06-2008 03:07 PM
'export' from a script doesn't work, why? sylvain_gnu Debian 3 04-20-2004 01:42 PM
mod_rewrite script doesn't work. Travis86 Linux - Networking 0 04-10-2004 09:45 PM

All times are GMT -5. The time now is 08:12 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration