Welcome to the most active Linux Forum on the web.
Go Back > Forums > Linux Forums > Linux - Distributions > Red Hat
User Name
Red Hat This forum is for the discussion of Red Hat Linux.


  Search this Thread
Old 09-16-2012, 04:07 PM   #1
Registered: Jun 2012
Posts: 264

Rep: Reputation: Disabled
Kickstart script isn't running in custom iso

I went through the process described here to create my own custom iso. My intent is to have a hands-free install once the DVD starts to boot. The link I'm using as reference describes creating a custom kickstart file and I can see it included on my custom iso as /ks/ks.cfg.

When I create a DVD with this image, it runs the normal interactive install steps, not the hands-free install I was trying to achieve.

My understanding is that this is possible with kickstart. Any suggestions what I am doing wrong?
Old 09-18-2012, 09:55 AM   #2
Registered: Aug 2002
Posts: 15,834

Rep: Reputation: 1797Reputation: 1797Reputation: 1797Reputation: 1797Reputation: 1797Reputation: 1797Reputation: 1797Reputation: 1797Reputation: 1797Reputation: 1797Reputation: 1797
I have never attempted what you are trying to accomplish but the posted site should work. Basically you modify the isolinux menu to automatically boot the desired image / options.
Old 09-18-2012, 10:03 AM   #3
Registered: Jun 2012
Posts: 264

Original Poster
Rep: Reputation: Disabled
This looks promising. Thanks very much for the link.
Old 09-18-2012, 04:28 PM   #4
Registered: Jun 2012
Posts: 264

Original Poster
Rep: Reputation: Disabled
This did in fact solve my problem. Thanks again. One follow-up question: I can make a customized isolinux.cfg and define a default menu entry that automatically performs a kickstart install after the menu timeout occurs. I've tested this from a DVD and it works exactly as I need it. The only problem is I'd much rather test it via a VM so I don't have to keep burning DVDs. However, when I create a VM using virt-install, it appears to skip by my custom menu and go immediately to the first install screen, prompting me to hit OK. It bypasses my kickstart script as well.

I'm using a command similar to this:

virt-install --connect=qemu:///system --network bridge=br0 --extra-args="text console=tty0 utf8 console=ttyS0,115200" --name=vmtest --nographics --location=/tmp/custom.iso ...

If I use this command instead:

virt-install --connect=qemu:///system --network bridge=br0 --extra-args="ks=cdrom:/ks/ks.cfg text console=tty0 utf8 console=ttyS0,115200" --name=vmtest --nographics --location=/tmp/custom.iso ...

my custom kickstart script runs as expected, but I still don't see my custom install menu. I'm assuming my virt-install command is slightly wrong, but I've tried various options with no luck. Can anyone suggest a solution? Note that I am running a text only install.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Running startup script fails because network share isn't ready (Perforce on Debian) tstein Linux - Software 1 05-21-2012 06:57 PM
Find X resolution from a script when X isn't running. arizonagroovejet Linux - General 2 11-04-2008 01:53 PM
Script i created isn't running on Shutdown WHY aaarrghh?? helptonewbie Linux - General 18 01-07-2008 04:46 PM
running %post script for Mailserver through kickstart abhi2778 Fedora 0 09-06-2006 03:12 AM
cron is not workin well running a custom script on Slackware 10.1... sugar2 Linux - Software 3 08-24-2006 07:41 PM

All times are GMT -5. The time now is 08:24 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration