LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Red Hat
User Name
Password
Red Hat This forum is for the discussion of Red Hat Linux.

Notices



Reply
 
Search this Thread
Old 07-19-2004, 08:34 AM   #1
satimis
Senior Member
 
Registered: Apr 2003
Posts: 3,428

Rep: Reputation: 53
INIT:Id "x" respawning too fast: disabled for 5 minutes problem


Hi folks,

RH8.0

On booting following warning popup;

INIT:Id "x" respawning too fast: disabled for 5 minutes

Neither
kill -SIGHUP 1

nor
telinit q

could solve the problem. Rebooting and 'Shutdown and reboot' PC have no effect.

cat /etc/inittab
......
id:5:initdefault:
......
# Run gettys in standard runlevels
1:2345:respawn:/sbin/mingetty tty1
2:2345:respawn:/sbin/mingetty tty2
3:2345:respawn:/sbin/mingetty tty3
4:2345:respawn:/sbin/mingetty tty4
5:2345:respawn:/sbin/mingetty tty5
6:2345:respawn:/sbin/mingetty tty6
# Run xdm in runlevel 5
# xdm is now a separate service
x:5:respawn:/etc/X11/prefdm -nodaemon

cat /etc/X11/XF86Config
......
Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "NEC XV15+"
DisplaySize 260 195
HorizSync 31 - 65
VertRefresh 55 - 100
Option "dpms"
.....

cat /etc/sysconfig/init
$ cat /etc/sysconfig/init
# color => new RH6.0 bootup
# verbose => old-style bootup
# anything else => new style bootup without ANSI colors or positioning
BOOTUP=color
# column to start "[ OK ]" label in
RES_COL=60
# terminal sequence to move to that column. You could change this
# to something like "tput hpa ${RES_COL}" if your terminal supports it
MOVE_TO_COL="echo -en \\033[${RES_COL}G"
# terminal sequence to set color to a 'success' color (currently: green)
SETCOLOR_SUCCESS="echo -en \\033[0;32m"
# terminal sequence to set color to a 'failure' color (currently: red)
SETCOLOR_FAILURE="echo -en \\033[0;31m"
# terminal sequence to set color to a 'warning' color (currently: yellow)
SETCOLOR_WARNING="echo -en \\033[0;33m"
# terminal sequence to reset to the default color.
SETCOLOR_NORMAL="echo -en \\033[0;39m"
# default kernel loglevel on boot (syslog will reset this)
LOGLEVEL=3
# Set to anything other than 'no' to allow hotkey interactive startup...
PROMPT=yes


GUI login failed to start

startx
can start KDE desktop either as root or user

Any advise. TIA

B.R.
satimis
 
Old 07-19-2004, 09:54 AM   #2
linuxboy123
LQ Newbie
 
Registered: Dec 2003
Posts: 8

Rep: Reputation: 0
Dear satimis,

this is an error with your /etc/X11/XF86Config-4 file.
This happens to me when I have configured for the wrong video card or use the wrong driver.
With RH 8.0, it should do all of that for you though...

Hope this helps,
linuxboy123
 
Old 07-19-2004, 11:33 AM   #3
satimis
Senior Member
 
Registered: Apr 2003
Posts: 3,428

Original Poster
Rep: Reputation: 53
Quote:
Originally posted by linuxboy123
this is an error with your /etc/X11/XF86Config-4 file.
This happens to me when I have configured for the wrong video card or use the wrong driver.
With RH 8.0, it should do all of that for you though...
Hi linuxboy123,

Tks for your advice.

This box has been working for sometimes without booting problem.

cat /etc/X11/XF86Config
......
.......
Section "Device"
Identifier "Videocard0"
Driver "nv"
VendorName "Videocard vendor"
BoardName "NVIDIA GeForce 2 MX (generic)"
VideoRam 32768
........

the BroadName is correct.

/etc/X11/XFree86Config-4
is only an empty file.

What Redhat command shall I use to re-config video card?

TIA

B.R.
satimis
 
Old 07-20-2004, 09:08 AM   #4
linuxboy123
LQ Newbie
 
Registered: Dec 2003
Posts: 8

Rep: Reputation: 0
satimis

Try using /usr/bin/X11/Xconfigurator.

Look at the man page first though.

linuxboy123
 
Old 07-22-2004, 07:03 AM   #5
satimis
Senior Member
 
Registered: Apr 2003
Posts: 3,428

Original Poster
Rep: Reputation: 53
Quote:
Originally posted by linuxboy123
satimis

Try using /usr/bin/X11/Xconfigurator.

Look at the man page first though.

linuxboy123
Hi linuxboy 123.

can't find /usr/bin/X11/Xconfigurator

Neither

# which Xconfigurator

nor

# loacate Xconfigurator

can find it.

satimis
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
X Server broken. start w/ "INIT: ld "x" respawning too fast: disabled for 5 minutes&q tektone Linux - Hardware 5 07-25-2007 08:18 PM
RH9 INIT: ID "x" respawning too fast: disabled for 5 minutes valimare Linux - Newbie 4 02-16-2007 05:53 AM
INIT:Id "x" respawning too fast,disabled for 5 minutes gepo Linux - Newbie 1 05-29-2005 11:03 PM
INIT: Id "x" respawning too fast: disabled for 5 minutes" Lego3 Linux - Software 0 06-16-2004 09:01 AM
INIT: Id "x" respawning too fast: disabled 5 minutes maddskillz Mandriva 1 10-10-2003 11:06 PM


All times are GMT -5. The time now is 04:14 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration