LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Red Hat
User Name
Password
Red Hat This forum is for the discussion of Red Hat Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 03-20-2013, 01:08 PM   #1
PeterSteele
Member
 
Registered: Jun 2012
Posts: 190

Rep: Reputation: Disabled
How can I set the default desktop to KDE in CentOS 6.4?


I always run KDE, and under CentOS 6.3 I could set the default desktop to KDE by setting /etc/sysconfig/desktop to

DESKTOP="KDE"
DISPLAYMANAGER="KDE"

This does not seem to work under CentOS 6.4. I tried changing DISPLAYMANAGER to KDM but that didn't work. I've tried other variations as well, but I always get gnome. What has changed in 6.4 that's preventing me from getting KDE?
 
Old 03-20-2013, 01:22 PM   #2
PeterSteele
Member
 
Registered: Jun 2012
Posts: 190

Original Poster
Rep: Reputation: Disabled
Note: According to /etc/X11/prefdm, I need to set DISPLAYMANAGER to KDE:

Code:
...
if [ -f /etc/sysconfig/desktop ]; then
        . /etc/sysconfig/desktop
        if [ "$DISPLAYMANAGER" = GNOME ]; then
                preferred=/usr/sbin/gdm
                quit_arg="--retain-splash"
        elif [ "$DISPLAYMANAGER" = KDE ]; then
                preferred=/usr/bin/kdm
...
This is what I've been using under 6.3 and it works. Not 6.4 though. Something odd is going on. I decided to change it back to KDE and what I get is the expected KDE login but then I end up in a plain vanilla desktop with a basic unadorned xterm. I tried running kdm in this window but nothing happens. What is the command to launch KDM interactively. Not that I want this to be the solution. There must be a way to set KDE as the default.

Last edited by PeterSteele; 03-20-2013 at 01:29 PM.
 
Old 03-20-2013, 03:02 PM   #3
mddesai
Member
 
Registered: Mar 2013
Location: Bengaluru, India
Distribution: Redhat, Arch
Posts: 476

Rep: Reputation: 132Reputation: 132
Quote:
This does not seem to work under CentOS 6.4. I tried changing DISPLAYMANAGER to KDM but that didn't work. I've tried other variations as well, but I always get gnome. What has changed in 6.4 that's preventing me from getting KDE?
What i am missing here... i also run Centos 6.4 KDE. When i installed "kde desktop", and rebooted the machine at login screen at bottom i selected "kde". since then every-time it logs in to kde desktop automatically ...
 
Old 03-20-2013, 03:26 PM   #4
PeterSteele
Member
 
Registered: Jun 2012
Posts: 190

Original Poster
Rep: Reputation: Disabled
I guess this was a case of user-error. I forgot that you have to select the session type during the login; it's been a year or so since I last did this. After setting the session type to KDE, I am now successfully running KDE as my default.

Out of curiosity, did you have to edit /etc/sysconfig/desktop manually? I definitely had to do that. Without doing that, I just got the default login screen which does not have the session type.

What's in your /etc/sysconfig/desktop file?
 
Old 03-20-2013, 03:34 PM   #5
mddesai
Member
 
Registered: Mar 2013
Location: Bengaluru, India
Distribution: Redhat, Arch
Posts: 476

Rep: Reputation: 132Reputation: 132
Quote:
Out of curiosity, did you have to edit /etc/sysconfig/desktop manually? I definitely had to do that. Without doing that, I just got the default login screen which does not have the session type.
No. I did not edit any config files. In fact i even didn't knew i have to change some config files to get kde.

Quote:
What's in your /etc/sysconfig/desktop file?
Code:
[root@cent64 ~]# cat /etc/sysconfig/desktop
cat: /etc/sysconfig/desktop: No such file or directory
 
Old 03-21-2013, 06:57 AM   #6
PeterSteele
Member
 
Registered: Jun 2012
Posts: 190

Original Poster
Rep: Reputation: Disabled
That's odd. For me, if this file doesn't exist, I don't get the kde login where I can set the session type, I just get the normal gnome login.

When you say that you installed "kde desktop", how did you do this. In my case, when I did my CentOS install, during the phase where you can select the type of system you want, I selected "Customize now" and added several additional packages, one of them being KDE. Is this what you did, or did you install KDE after the main OS install, via the gnome package manager?
 
Old 03-21-2013, 08:31 AM   #7
mddesai
Member
 
Registered: Mar 2013
Location: Bengaluru, India
Distribution: Redhat, Arch
Posts: 476

Rep: Reputation: 132Reputation: 132
Quote:
I don't get the kde login where I can set the session type, I just get the normal gnome login.
if you are refering to just login screen, then i dont know. since its my home pc and i'm the only user, i have setup to autologin. so i dont get login screen. if i want to swap between gnome and kde, i just disable autologin at that time and choose desktop type. i usually prefer gnome though. its simple and clean.

Quote:
Is this what you did, or did you install KDE after the main OS install, via the gnome package manager?
while installing centos i did not choose kde desktop. i have setup local repository. so i installed through it.
Code:
# yum groupinstall "kde desktop" --disablerepo=base

Last edited by mddesai; 03-21-2013 at 09:36 AM.
 
Old 03-21-2013, 08:58 AM   #8
mddesai
Member
 
Registered: Mar 2013
Location: Bengaluru, India
Distribution: Redhat, Arch
Posts: 476

Rep: Reputation: 132Reputation: 132
ok i just did this, and i'm getting kde login screen. looks good. But i still prefer autologin.

vi /etc/sysconfig/desktop
DESKTOP="KDE"
DISPLAYMANAGER="KDE"
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to set IceWM as default desktop environment [OpenBSD] suttiwit *BSD 1 09-30-2012 12:49 PM
How to set default desktop for user yungblood Linux - Software 1 08-20-2009 09:54 PM
How to make KDE my default on CentOS kencl Linux - Newbie 4 11-13-2005 10:18 AM
set thunderbird as default in KDE 3.x hlpboplz Linux - Newbie 4 09-25-2005 12:30 PM
how to set kde as default kde when i log in fedora core 3? Itachi Fedora 3 09-07-2005 02:29 AM


All times are GMT -5. The time now is 07:41 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration