Register a domain and help support LQ
Go Back > Forums > Non-*NIX Forums > Programming
User Name
Programming This forum is for all programming questions.
The question does not have to be directly related to Linux and any language is fair game.


  Search this Thread
Old 05-09-2006, 11:32 AM   #1
Registered: Jul 2004
Distribution: Slackware, Suse
Posts: 46

Rep: Reputation: 15
[mod_perl] require error

Hey guys,

I am having trouble to run serveral cgi-scripts with my apache/mod_perl setup.
The setup works fine but I have two scripts which won't work.

With the first one I get this error:

Software error
ModPerl::Util::exit: (120000) exit was called

In the last line of the script I call the exit() funktion. Why should that be an error? Does mod_perl do not know exit()?

And then I have a second script where I have a require command.

require $page.".cgi"

where $page is the name of the script that I want to start!

I cannot find the mistake here.
Any Idea?



Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
mod_perl requirements dsids Linux - Software 0 03-21-2006 07:09 AM
mod_perl make && make test error rino.caldelli Linux - Software 0 02-17-2006 06:10 PM
Mod_Perl 2.0 random server error libsys Linux - Software 1 05-13-2005 12:29 AM
mod_perl? ziggie216 Linux - Software 0 12-15-2003 07:17 PM
Apache 2.0.45 and mod_perl arkopolo Linux - Software 0 07-03-2003 03:06 PM

All times are GMT -5. The time now is 08:35 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration