LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > MEPIS
User Name
Password
MEPIS This forum is for the discussion of MEPIS Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 09-20-2005, 03:45 PM   #1
benn333
LQ Newbie
 
Registered: May 2005
Location: Dublin, IE
Distribution: Kubuntu & Debian Sarge
Posts: 8

Rep: Reputation: 0
fstab changes lost after reboot


Not sure if this is caused by Mepis or not... I'm attempting to automatically mount my hdc1 and hdd1 drives when Mepis starts. I've modified their entries to the following in /etc/fstab:

/dev/hdc1 /mnt/hdc1 vfat auto,users,exec,umask=000 0 0
/dev/hdd1 /mnt/hdd1 vfat auto,users,exec,umask=000 0 0

However, when I restart the computer, the "auto" entry changes back to "noauto". Any idea what is causing this?


Full fstab file:

# Static entries below, do not use 'users' option in this area
/dev/hda6 / ext3 defaults,noatime 1 1
/dev/hda5 swap swap sw,pri=1 0 0
none /proc proc defaults 0 0
none /proc/bus/usb usbfs devmode=0666 0 0
none /dev/pts devpts mode=0622 0 0
none /sys sysfs defaults 0 0
# Dynamic entries below, identified by 'users' option
/dev/hda1 /mnt/hda1 ntfs noauto,users,exec,ro,umask=0222 0 0
/dev/hdc1 /mnt/hdc1 vfat noauto,users,exec,umask=000 0 0
/dev/hdd1 /mnt/hdd1 vfat noauto,users,exec,umask=000 0 0
/dev/cdrom /mnt/cdrom udf,iso9660 noauto,users,dev,ro 0 0
/dev/floppy /mnt/floppy vfat,ext2,hfsplus noauto,users,dev,sync,dirsync 0 0
 
Old 09-20-2005, 04:34 PM   #2
mos
Member
 
Registered: May 2005
Location: Orlando, Fl
Distribution: ArchLinux (Can use any distro though)
Posts: 231

Rep: Reputation: 30
move them above the dynamic entries line, everything below gets regenerated on boot
 
Old 09-20-2005, 04:38 PM   #3
Matir
Moderator
 
Registered: Nov 2004
Location: San Jose, CA
Distribution: Ubuntu
Posts: 8,506

Rep: Reputation: 116Reputation: 116
It is not the dynamic entries line that matters, but the "users" option in the mounting option. It's stupid that Mepis uses "users", when "managed" is used by fstab-sync and others. I say it's stupid not because it's different but because users has a long recognized meaning of allowing ANY user to mount/unmount the drive in question.

Long story short: remove the "users," option.
 
Old 09-20-2005, 05:54 PM   #4
mos
Member
 
Registered: May 2005
Location: Orlando, Fl
Distribution: ArchLinux (Can use any distro though)
Posts: 231

Rep: Reputation: 30
no you can leave the users option alone, only things below it are considered valid. As the op of #mepis I deal with this question quite frequently, only that which is below that comment is mannaged. the users line is irrelevent.
 
Old 09-20-2005, 09:07 PM   #5
Matir
Moderator
 
Registered: Nov 2004
Location: San Jose, CA
Distribution: Ubuntu
Posts: 8,506

Rep: Reputation: 116Reputation: 116
Then the comment in the file ("# Dynamic entries below, identified by 'users' option") is very poorly phrased. It implies, to me anyway, that the 'users' field is key.

I have to wonder what kind of affect modifying/adding comments in fstab has on the Mepis management software.
 
Old 09-20-2005, 09:12 PM   #6
mos
Member
 
Registered: May 2005
Location: Orlando, Fl
Distribution: ArchLinux (Can use any distro though)
Posts: 231

Rep: Reputation: 30
editing that line, or just deleting it all together makes the whole thing set in stone, and screws up hardware detection
 
Old 09-20-2005, 09:31 PM   #7
Matir
Moderator
 
Registered: Nov 2004
Location: San Jose, CA
Distribution: Ubuntu
Posts: 8,506

Rep: Reputation: 116Reputation: 116
Interesting. Seems pretty inefficient to me, but to each their own.
 
Old 09-21-2005, 03:44 AM   #8
benn333
LQ Newbie
 
Registered: May 2005
Location: Dublin, IE
Distribution: Kubuntu & Debian Sarge
Posts: 8

Original Poster
Rep: Reputation: 0
Okay, so I see how adding hdc and hdd to the static portion of fstab should do what I'm trying to do (automatically mount the drives at startup). However, what hardware detection features will I be screwing up? Is there another way, possibly within the user interface, to get these drives to automatically mount?

On a side note, it seems logical that Mepis should mount these drives automatically. (I'm running Debian Sarge on another system and all hard drives come up mounted when I boot the computer.) Before looking into logging a Mepis enhancement request, can someone confirm/refute that Mepis does not/does mount extra drives? Just want to confirm that it's the distro and not me.
 
Old 09-21-2005, 03:04 PM   #9
mos
Member
 
Registered: May 2005
Location: Orlando, Fl
Distribution: ArchLinux (Can use any distro though)
Posts: 231

Rep: Reputation: 30
it does not automount anything but / and /home thats something you would have to take up with warren.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
fstab remain unchanged at reboot ago.homer Linux - Newbie 1 04-20-2005 05:24 AM
Lost mouse after reboot+lost modem BACTRATE Mandriva 3 04-07-2005 06:45 AM
fstab changes and symlinks gone after reboot in FC3 GKid Fedora 1 03-15-2005 11:55 AM
fstab changes for USB DVD+RW lost on reboot TomF Linux - General 1 10-18-2004 01:24 PM
Fstab entries vanish after reboot zoropio Fedora 1 02-01-2004 06:48 AM


All times are GMT -5. The time now is 07:02 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration