LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva
User Name
Password
Mandriva This Forum is for the discussion of Mandriva (Mandrake) Linux.

Notices

Reply
 
Search this Thread
Old 11-01-2006, 08:18 AM   #1
sekelsenmat
Member
 
Registered: Apr 2005
Location: São Paulo - Brazil
Distribution: Mageia Linux 1
Posts: 353

Rep: Reputation: 30
Replace Command Line Interface


Hello,

I installed Mandriva 2007 on a quite old computer (400MHz, 96MB RAM), and I am using the purely textual interface. (No window manager).

But the command-line interface provided with Mandriva is extremely slow on this computer. If I issue the command "ls -l" sometimes it won't show anything, until I press a second enter.

Other times it will just very slowly put one line at a time, instead of scrolling the contents of ls -l very rapdly like I expect.

And after using it for some time, it will even stop reading keyboard characters correctly. some keyboard characters are correct, but if I press c it will show a copyright simbol etc.

I think this is because Mandriva uses that partially graphical command line interface, with a Mandriva logo on the right part of the screen.

How can I switch to a 100% textual interface? I mean, I want to get rid of the eye-candy stuff to get a faster system.

Thanks.
 
Old 11-01-2006, 08:30 AM   #2
uselpa
Senior Member
 
Registered: Oct 2004
Location: Luxemburg
Distribution: Slackware, OS X
Posts: 1,507

Rep: Reputation: 46
In your boot loader, there's probably a "vga=773" parameter (the value may be different) passed to your kernel. Change that to "vga=normal".
 
Old 11-01-2006, 08:35 AM   #3
reddazz
Guru
 
Registered: Nov 2003
Location: N. E. England
Distribution: Fedora, CentOS, Debian
Posts: 16,298

Rep: Reputation: 73
On Mandriva, when you are in the command line, you are strictly in the command line. The logo you see in the back should not really affect performance which makes me think that there is something else causing your problems. Anyway try editing your /etc/lilo.conf or /boot/grub/menu.lst and in the kernel parameters section and change "vga=7xx" to "vga=normal" or completely remove the "vga=7xx" line.
 
Old 11-01-2006, 09:20 AM   #4
sekelsenmat
Member
 
Registered: Apr 2005
Location: São Paulo - Brazil
Distribution: Mageia Linux 1
Posts: 353

Original Poster
Rep: Reputation: 30
Thanks for the hints.

I removed some modules from startup, like atd, nfs, nfslock and some other modules I don't use and the problems were solved! The system is 10 times more responsive now, and no more annoying bugs.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
command line edit -- global find/replace on text file w/o going into vi car182 Linux - Newbie 4 05-25-2006 05:42 PM
Can only use command line interface! The helpless one Linux - Newbie 6 03-12-2006 03:42 PM
How do I learn command line interface? arnicainthemembrane Linux - Newbie 4 03-03-2006 06:51 PM
find and replace in files from command line dexter_modem Linux - General 4 06-10-2003 11:27 AM
Which distro has the best command line interface ? lostboy Linux - Distributions 11 03-22-2003 07:34 AM


All times are GMT -5. The time now is 08:12 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration