LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva
User Name
Password
Mandriva This Forum is for the discussion of Mandriva (Mandrake) Linux.

Notices

Reply
 
Search this Thread
Old 09-20-2005, 01:22 PM   #1
vital_101
Member
 
Registered: Jul 2005
Location: Mount Pleasant, Michigan
Distribution: Ubuntu Jaunty 9.04
Posts: 82

Rep: Reputation: Disabled
Listening for incoming connections


Hi,

I'm using Mandriva 10.1 on my PC, and I want to be able to access it remotely. Is there anything special I need to do to make my computer listen for incoming connections (of the telnet type)? I'm using a cable modem, split through a router to connect to the internet. Will this be a problem? If you need any more information, just ask and I'll see if I can provide.

Thanks,
Vital_101
 
Old 09-20-2005, 02:06 PM   #2
Matir
Moderator
 
Registered: Nov 2004
Location: San Jose, CA
Distribution: Ubuntu
Posts: 8,507

Rep: Reputation: 117Reputation: 117
I strongly suggest you install OpenSSH, if not already installed, and use SSH instead of telnet as its encrypted. Then, configure your router to portforward port 22 to the Linux box in question.
 
Old 09-20-2005, 02:13 PM   #3
vital_101
Member
 
Registered: Jul 2005
Location: Mount Pleasant, Michigan
Distribution: Ubuntu Jaunty 9.04
Posts: 82

Original Poster
Rep: Reputation: Disabled
Okay, I can install OpenSSH, but I'm not certain how to go about configuring my router. I'm using a belkin wireless router (except I'm connected through a Cat5 cable since I couldn't get my wireless to work). I'm completely new to the configuring of routers. Any help in that area would be great. Thanks.

/vital_101
 
Old 09-20-2005, 02:20 PM   #4
Matir
Moderator
 
Registered: Nov 2004
Location: San Jose, CA
Distribution: Ubuntu
Posts: 8,507

Rep: Reputation: 117Reputation: 117
If you can give me a specific model number, I'd be happy to look in the manual and refer you to the appropriate directions. It's often also called "Application Forwarding" with some routers.
 
Old 09-20-2005, 02:38 PM   #5
vital_101
Member
 
Registered: Jul 2005
Location: Mount Pleasant, Michigan
Distribution: Ubuntu Jaunty 9.04
Posts: 82

Original Poster
Rep: Reputation: Disabled
the model number is F5D7230-4
 
Old 09-20-2005, 04:26 PM   #6
Matir
Moderator
 
Registered: Nov 2004
Location: San Jose, CA
Distribution: Ubuntu
Posts: 8,507

Rep: Reputation: 117Reputation: 117
On page 70 of the printed manual, it describes "Internal Forwarding". From your router's configuration, you'll need to select Firewall -> Internal Forwarding from the menu on the left side. Select enable, add a description (like "SSH"), set the port range to 22 to 22, protocol TCP, and set the private IP address to that of your Linux box. Private port should also be 22 to 22. For reference, the manual can be downloaded from Belkin.
 
Old 09-20-2005, 04:31 PM   #7
vital_101
Member
 
Registered: Jul 2005
Location: Mount Pleasant, Michigan
Distribution: Ubuntu Jaunty 9.04
Posts: 82

Original Poster
Rep: Reputation: Disabled
Thanks for all the help. To connect to my linux box now, do I type in my linux box ip address, or the ipaddress that I get from going to someplace like http://whatismyipaddress.com ?
 
Old 09-20-2005, 04:46 PM   #8
Matir
Moderator
 
Registered: Nov 2004
Location: San Jose, CA
Distribution: Ubuntu
Posts: 8,507

Rep: Reputation: 117Reputation: 117
To connect to it (from outside your LAN) you'll need to use your so-called "world routable IP address"... aka, the address from http://whatismyipaddress.com.
 
Old 09-20-2005, 06:52 PM   #9
vital_101
Member
 
Registered: Jul 2005
Location: Mount Pleasant, Michigan
Distribution: Ubuntu Jaunty 9.04
Posts: 82

Original Poster
Rep: Reputation: Disabled
I have everything set up as it should be, however, I still can't connect to my computer remotely. Is it possible that my cable provider is blocking things of this sort somehow? And if so, is there anything I can do about it?
 
Old 09-20-2005, 08:26 PM   #10
tkedwards
Senior Member
 
Registered: Aug 2004
Location: Munich, Germany
Distribution: Opensuse 11.2
Posts: 1,549

Rep: Reputation: 51
Quote:
Is it possible that my cable provider is blocking things of this sort somehow? And if so, is there anything I can do about it?
Its possible but unlikely - most cable providers (including mine ) block things like HTTP and SMTP. You can easily switch ssh to run on another port, in fact I'd recommend it as it means you won't suffer from all those password brute-force attempts. To do that edit /etc/ssh/sshd_config and change 'Port 22' to 'Port xxx' where xxx is some port number.

Another thing to check is have a look in the file /var/log/messages and see if there's any messages from shorewall indicating that your attempts to connect are being blocked.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
cannot Allowing Incoming X Connections with xhost + libin88 Linux - Enterprise 1 11-09-2005 03:25 PM
Discovering the true IP of incoming connections fibbi Linux - Networking 2 06-14-2005 01:46 AM
restricting incoming connections, using sockets SoulSkorpion Programming 2 10-20-2004 03:15 AM
Allowing incoming connections only from a spesific country? herc Linux - Security 1 04-12-2004 02:56 AM
Sendmail and incoming connections mike_smith Linux - Networking 3 01-19-2004 06:05 PM


All times are GMT -5. The time now is 03:35 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration