LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva
User Name
Password
Mandriva This Forum is for the discussion of Mandriva (Mandrake) Linux.

Notices

Reply
 
Search this Thread
Old 05-18-2004, 09:56 AM   #1
prara
LQ Newbie
 
Registered: Aug 2003
Distribution: Mandriva, Ubuntu, Fedora
Posts: 24

Rep: Reputation: 15
Dual-booting Fedora 2 and Mandrake 10 Community


I have Mandrake 10 Community and installed a copy of Fedora Core 2 test3. I did not install the default bootloader (Grub) of Fedora because I prefer the Lilo in Mandrake. How do I add Fedora in Lilo:

1) fedora is installed in /dev/hdb (2nd hard disk)
2) fedora's /boot is in /dev/hdb1 (1st partition) and root is in /dev/hdb2 (2nd partition)

What settings do I make in Mdk10 lilo to make it point to the right root, make sure it finds the right /boot?

*****
FIELDS TO BE FILLED UP:

-this is what we put in (or what turned up after we put it in)

Label: fedora
Image: /boot/vmlinuz
Root: /dev/hdb2
Append: devfs=mount init=/sbin/init

Advanced Settings
Video Mode: Normal
Initrd: /boot/initrd-2.6.3-4mdk.img

*****
WHAT WENT WRONG

while booting fedora, I came across the ff errors

-FATAL cannot load /lib/modules blablabla (too fast)
-rm blablabla failed ? readonly filesystem
-a whole bunch of readonly filesystem errors
-kudzu asking me to reconfigure hardware that I already configged at installation

*****
WHAT'S BEEN DONE:
in mdk10, I mounted the fedora hard disk on /mnt/fedora

/mnt/fedora/boot has vmlinuz-2.6.5-1.327, which I assume is the image to load
it also has a initrd-2.6.5-1.327.img, which I assume is the initrd to load

I went to /mnt/fedora/boot and made a symlink vmlinuz which pointed to the vmlinuz-2.6.5-1.327 in /mnt/fedora/boot. That's why I wrote /boot/vmlinuz as the image

I have already tried changing the INITRD field to /boot/initrd-2.6.5-1.327.img. For some strange reason it keeps going back to the mdk initrd

I have also tried using /mnt/fedora/boot/vmlinuz and /mnt/fedora/boot/initrd... but the same problem appears

*****
WHAT MAY HAVE GONE WRONG


-The Lilo gui tool might be making assumptions that we will only be booting one linux system and that all the boot stuff are in the /boot of mdk10 (and does not know how to look for anything else) but if this is the case, then why is it that when I used /mnt/fedora/boot..., it still could not find the stuff?

-The Lilo gui tool was informed that the root was in /dev/hdb2, but was never told that the /boot was in /dev/hdb1 (OMGWTFLOL!). Having checked that fstab of fedora, I don't see how the system knows where to find its own boot... (honest!)

-Installation was a big mess (I don't really think so)

-other stuff that YOU are here to say.
 
Old 05-18-2004, 07:06 PM   #2
jailbait
Guru
 
Registered: Feb 2003
Location: Blue Ridge Mountain
Distribution: Debian Wheezy, Debian Jessie
Posts: 7,522

Rep: Reputation: 177Reputation: 177
"Initrd: /boot/initrd-2.6.3-4mdk.img"

This is the name of the initrd in your Mandrake /boot directory. You need to change this to the name of the initrd in your Fedora /boot directory. After you make the change you need to run the lilo command to make the changes take effect. Go to a command prompt and run:
lilo

___________________________________
Be prepared. Create a LifeBoat CD.
http://users.rcn.com/srstites/LifeBo...home.page.html

Steve Stites

Last edited by jailbait; 05-18-2004 at 07:09 PM.
 
Old 06-04-2004, 09:31 PM   #3
cprogrck
Member
 
Registered: May 2004
Posts: 91

Rep: Reputation: 15
I'm having that same problem. I installed madrake 10 after I installed fedora core2. Can you help me configure Lilo? I have no idea how to configure it because I've always used redhat (hence Grub). I've also tried reinstalling Fedora core 2 but I can't because the installation won't detect my hard drive partitions. It say that they are set up wrong or somthing like that. Also, for some odd reason nothing is under my fedora boot directory (I have no idea why not) I mounted my fedora partition in madrake. What is going on? It makes no sense what so ever.
 
Old 07-03-2004, 07:10 AM   #4
prara
LQ Newbie
 
Registered: Aug 2003
Distribution: Mandriva, Ubuntu, Fedora
Posts: 24

Original Poster
Rep: Reputation: 15
After mounting the fedora /boot you have to call the kernel image relative to your mandrake system.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Booting problem with Mandrake 10 Community Vampirite Mandriva 9 12-27-2005 06:57 AM
Dual Monitoring with Mandrake 10 Community DYNO Linux - Newbie 4 11-11-2004 06:05 PM
dual booting fedora core 2 and mandrake: can't boot mandrake any more mgyamada Fedora 1 10-04-2004 07:39 AM
Dual-booting Fedora 2 and Mandrake 10 Community prara Fedora 1 05-18-2004 02:09 PM
Mandrake 10 Community Dual boot with XP problem matex Mandriva 7 05-10-2004 06:59 AM


All times are GMT -5. The time now is 11:08 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration