LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices

Reply
 
Search this Thread
Old 12-11-2004, 01:03 PM   #1
justagirl
LQ Newbie
 
Registered: Dec 2004
Distribution: suse 9.2
Posts: 8

Rep: Reputation: 0
wireless works, cant get online


i installed suse 9.2 and got the wireless card to connect and the monitor program says its working fine, but it never goes online. i can get online with the ethernet, installed the patched and such but nothing seems to help. the pdf document said kinternet would be in the tray, but ive never seen it nor kow how to activate it.

presario 2100 laptop
athalon xp 2400
prism 2.5 wireless
cable modem
mn-500 wireless router

i'm experienced with windows, but know nothing about linux. please speak in newbie terms!

thanks!
 
Old 12-11-2004, 01:17 PM   #2
2Gnu
Senior Member
 
Registered: Jan 2002
Location: Southern California
Distribution: Slackware 14.0
Posts: 1,874

Rep: Reputation: 49
There are two major steps to making a wireless connection work: associating with the access point (it sounds as though you got that far) and bringing up the interface. SuSE probably has a GUI for it, but try either ifup eth0 or ifconfig eth0 up in the command line.

Post the output of ifconfig and iwconfig to see if you're associated and getting a valid IP and route.
 
Old 12-11-2004, 01:23 PM   #3
nirvanix
Member
 
Registered: May 2003
Location: Calgary, Canada
Distribution: Arch Linux
Posts: 194

Rep: Reputation: 30
2Gnu is correct, although I might add that your wireless device might have gotten defined as eth0, eth1, or even wlan0, depending on what other network devices are already defined and how the config was set up. Hence, you might have to issue: ifconfig eth0 up OR
ifconfig eth1 up, or ifconfig wlan0 up to get it working.
 
Old 12-11-2004, 02:24 PM   #4
justagirl
LQ Newbie
 
Registered: Dec 2004
Distribution: suse 9.2
Posts: 8

Original Poster
Rep: Reputation: 0
not newbie enough! i dont know how to enter these commands. i also can't find a newbie guide that explains these things. the included manual doesn't explain anything. they always seem to tell me how to install the os, and thats the end. know of a good newbie guide?

my card is identified as wifi0 in a taskbar applet (i cant find its name) but in the wireless network configuration gui it is called wlan0.
 
Old 12-11-2004, 03:30 PM   #5
snecklifter
Member
 
Registered: Mar 2004
Location: UK/West Yorkshire/Huddersfield
Distribution: Fedora 7
Posts: 982

Rep: Reputation: 30
Hello justagirl,

Please consider us your knights in shining armour. I'm guessing its wlan0 and the applet - possibly Kwififmanager - is calling it wifi0. Not very helpful I guess. To get the true
name of the interface you need to open a terminal program (konsole in KDE) and become root. Do this by typing
Code:
su
followed by the password if there is one.
Then type these commands and post back the output.
Code:
ifconfig
Code:
iwconfig
Code:
iwlist wlan0 scanning
and we'll see what we shall see.
Regards
Sir Chris
 
Old 12-11-2004, 05:04 PM   #6
justagirl
LQ Newbie
 
Registered: Dec 2004
Distribution: suse 9.2
Posts: 8

Original Poster
Rep: Reputation: 0
wow. i cant believe i was forgetting to log in as root. *sigh* the applet now says wlan0, so im not sure whats going on. im connected to the internet via ethernet cable plugged into the same wireless router, so these results may be somewhat bizarre.

*** ifconfig:


eth0 Link encap:Ethernet HWaddr 00:0B:CD:87:A2:C2
inet addr:192.168.2.7 Bcast:255.255.255.255 Mask:255.255.255.0
inet6 addr: fe80::20b:cdff:fe87:a2c2/64 Scope:Link
UP BROADCAST NOTRAILERS RUNNING MULTICAST MTU:1500 Metric:1
RX packets:7885 errors:0 dropped:0 overruns:0 frame:0
TX packets:7819 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:7101587 (6.7 Mb) TX bytes:1123669 (1.0 Mb)
Interrupt:11

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:1070 errors:0 dropped:0 overruns:0 frame:0
TX packets:1070 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:84100 (82.1 Kb) TX bytes:84100 (82.1 Kb)

wlan0 Link encap:Ethernet HWaddr 00:02:8A:98:CD:12
inet addr:192.168.2.10 Bcast:255.255.255.255 Mask:255.255.255.0
inet6 addr: fe80::202:8aff:fe98:cd12/64 Scope:Link
UP BROADCAST NOTRAILERS RUNNING MULTICAST MTU:1500 Metric:1
RX packets:813 errors:0 dropped:0 overruns:0 frame:0
TX packets:16 errors:0 dropped:3 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:268772 (262.4 Kb) TX bytes:2078 (2.0 Kb)
Interrupt:10 Memory:dc84e000-dc84f000


*** iwconfig


lo no wireless extensions.

wlan0 IEEE 802.11-b ESSID:"MSHOME" Nickname:"MSHOME"
Mode:Managed Frequency:2.437 GHz Access Point: 00:50:F2:CA:34:AA
Bit Rate:11 Mb/s Tx-Power:2346 dBm
Retry min limit:8 RTS thr:off Fragment thr:off
Encryption key:off
Link Quality=92/92 Signal level=-40 dBm Noise level=-100 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

eth0 no wireless extensions.

sit0 no wireless extensions.


*** iwlist wlan0 scanning


wlan0 Interface doesn't support scanning : Function not implemented


make any sense? thank you!

Last edited by justagirl; 12-11-2004 at 05:07 PM.
 
Old 12-12-2004, 05:59 AM   #7
snecklifter
Member
 
Registered: Mar 2004
Location: UK/West Yorkshire/Huddersfield
Distribution: Fedora 7
Posts: 982

Rep: Reputation: 30
Well the good news is I tihnk you're almost there. The problem you have here is that there are two interfaces grabbing two separate IP addresses. Not a problem if you can bridge and so forth but I'm assuming you just want to get on the net with your wireless connection. So in this case I would remove the wired NIC from the equation altogether, preferably by disabling it in the BIOS. In that way Suse wont assign resources to it on boot an go looking for an Ip for it etc. I would change the nickname of your computer so that it is different from your SSID. Anything will do but at the moment it just confuses the situation. Once you have loaded up without your wired nick you will want to check and see if you are connected. Chances are that you may well be without having to do anything further as it has obtained an IP from your router in the outputs you posted.
If it has not connected then check the commands again that I asked you to run.
Note: You do not need to log in as root (ie. log into KDE with root username) to get any of this working. The only reason you need to become root is to run some of the commands above, even though most can be run by specifying the exact path but thats for another day I guess.
See how you go - remember you're pretty much there - it all looks good.
Regards
Chris
 
Old 12-12-2004, 04:41 PM   #8
justagirl
LQ Newbie
 
Registered: Dec 2004
Distribution: suse 9.2
Posts: 8

Original Poster
Rep: Reputation: 0
*sigh*

this is so frustrating. how do i change the bios? i looked for that or anything involving setup in the manual and all i could find wouldn't tell me how to actually change the settings.

if i could just get online (and stop switching back and forth to windows) id have the patience to figure the rest out!

that applet (still can't find its name) is back to wifi0. it can change to wlan0, but it just switches back again.

hope im not moving too slow for you!
 
Old 12-12-2004, 05:40 PM   #9
2Gnu
Senior Member
 
Registered: Jan 2002
Location: Southern California
Distribution: Slackware 14.0
Posts: 1,874

Rep: Reputation: 49
Just bring down, or deactivate, the unwanted interface: ifconfig eth0 down then bring up the desired one: ifconfig wlan0 up. Again, there's a SuSE GUI if you feel more comfortable with that. The GUI should also give you options to enable (or not) each interface on boot and to either pull an IP address from the DHCP pool on the router or to sued an assigned static address.

Newbie guides abound, but a lot of the information is already on your system. From a console window:

"man command" or "info command" without the quotes will open a file containing instructions for the use of the command. man ifconfig will list out the many ways you can use it. Page up/down to scroll though the manual, "q" to quit.

Not sure what command to use? "apropos subject" will help. apropos network will list all of the commands related to networking - too many, in fact. apropos wireless will give a much more narrow range of options.

IRC. Online chat with other users who can hold your hand as you walk through the steps realtime. X-chat is a decent client that is also available for Windows. Point it to irc.freenode.net and join a channel such as #suse or #atu.

Aside from this fine site, DSLReports.com/forum/unixdsl (All Things UNIX) is very useful and newbie-tolerant. The #ATU folks are mostly DSLR crowd.

Mailing lists and news groups can be a good way to find stuff that someone else already tripped over to save yourself a fall or two.
 
Old 12-15-2004, 11:57 PM   #10
aussben
LQ Newbie
 
Registered: Dec 2004
Location: Australia
Posts: 10

Rep: Reputation: 0
You don't have to disabled it in the bios or though that would be one way to disable it.

You need to edit the interfaces file.

It's best to get used to using a terminal window such as eterm or xterm to change settings, move or delete files, restart services. That way if you loose your x windows you can still repair you system.

I would suggest learning how to use a text editor such as pico or vim to change settings.

search in google for howto pico or vim.

You need to comment out the other interfaces in the /etc/network/interfaces files.

Commented out means putting a # in front of a line. This way the system scipts over the line when reading the configuration.

e.g to open the interfaces file, open up a terminal window, logon as a super user "type su enter then password" type "less /etc/network/interfaces" this allows you view the file without allowing yourself to make any changes. Press "q" to exit the file.

You should see something like:

auto wlan0

iface wlan0 inet static
address 192.168.2.105
netmask 255.255.255.0
broadcast 192.168.2.255
gateway 192.168.2.1

This will change depending on your system. Now to comment out each line open up vim or pico and you just add # to front of each line. Command pico /etc/network/interfaces

#you can add comments to remind you of what you did on the file, just as long as there is a #comment in front of it.

#iface wlan0 inet static
#address 192.168.2.105
#netmask 255.255.255.0
#broadcast 192.168.2.255
#gateway 192.168.2.1

You just comment out the interface you want to disable. That way ifup cannot find the interface to bring it up.

Type as root "/etc/init.d/networking restart"

you should see your dhcp client trying to setup your interfaces.

Now your interface that you commented out will no longer start.

iwconfig to view interfaces.

Another really handy tools to use when getting use to navigating around using a terminal window is to use the "TAB" key.

If you press tab when trying a command or open of file it will provide a list of files matching what you typed. E.g

you are opening up /etc/network/interfaces

start typing at the prompt

/et "press tab" you should see /etc get completed. If you use TAB that way you know the directory exists or if you cannot remember the complete command. It has many uses.

You can find more info on examples of interfaces by just searching in google /etc/network/interfaces or just interfaces or the MAN file or howto interfaces in google.

Using text editors and command lines allow you to understand what you are doing, and allow you to have more control over your system.

Good luck in your learning.

Rgds

Ben
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Online music store that works under linux?Is microsoft/linux General 3 11-23-2005 02:16 AM
can't get online with orinoco gold, but works with kismet element_a Linux - Newbie 7 08-12-2005 12:21 PM
more kernel problems...online works, though!! linuxhippy Slackware 6 03-29-2005 03:43 AM
kde not starting when online. works offline. whansard Mandriva 1 08-01-2004 10:53 AM
my network works but i can't get websites online karel Linux - Networking 8 10-20-2002 04:28 AM


All times are GMT -5. The time now is 11:19 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration