LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices

Reply
 
Search this Thread
Old 02-20-2007, 04:10 PM   #1
coho66
LQ Newbie
 
Registered: Feb 2007
Posts: 2

Rep: Reputation: 0
wireless nic work w/o encryption, but not wpa


Hello all,

I"m new to linux, although I have played with an earlier version of mandrake and dabbled in unix, but this was many moons ago. So i am comfortable with command line interface, but I don't remember any of the linux commands or pertinent tools or software to use.

Anyways, I currently have an issue with trying to enable wpa with my trendnet tew-424 usb wireless nic (uses zd1211 chipset) in mandriva 2007 (powerpack).

I can get the network/internet to work fine without any encryption enabled, but I can't seem to connect to the internet while enabling wpa, regardless of whatever settings i've tried? The odd thing is i can obtain a network address using wpa through the wireless manager, but still no dice with eeenturnet access. Any suggestions on how to troubleshoot this process? All advice is appreciated.

Thanks,

Coho
 
Old 02-20-2007, 09:22 PM   #2
JimBass
Senior Member
 
Registered: Oct 2003
Location: New York City
Distribution: Debian Sid 2.6.32
Posts: 2,100

Rep: Reputation: 48
You need a program called wpa_supplicant to use wpa protected wifi. One of the interesting features of wpa is that you usually do get an address even without the wpa passkey, but you can't handle the encryption and can't browse.

Use your distro's package manager to search and install wpa_supplicant (may also be called wpa-supplicant or wpasupplicant), or install it from source.

Peace,
JimBass
 
Old 02-20-2007, 11:00 PM   #3
coho66
LQ Newbie
 
Registered: Feb 2007
Posts: 2

Original Poster
Rep: Reputation: 0
yup, wpa supplicant is installed...

but, still no dice???

in addition to regular dhcp, I tried manually configuring an ip and then it says "associated with eth2" upon successful connection with the router...and the browser will attempt to look for the domain i choose but never reaches a site...the signal strength is pitiful and the connection disconnects
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Wireless network manager using WPA encryption dgranger Linux - Wireless Networking 14 09-20-2006 12:23 PM
trying to get wpa to work, now no wireless at all tomdun2 Linux - Wireless Networking 1 09-04-2006 08:10 AM
Wireless NIC can't Authenticate to AP using WPA; ndiswrapper/wpa_supplicant patkalolo Linux - Wireless Networking 8 07-31-2006 02:47 PM
Wireless-G and WPA encryption ?? lawadm1 Linux - Wireless Networking 1 06-19-2004 05:03 PM


All times are GMT -5. The time now is 01:18 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration