LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices



Reply
 
Search this Thread
Old 01-28-2008, 05:41 AM   #1
Pedroski
Senior Member
 
Registered: Jan 2002
Location: Nanjing, China
Distribution: Ubuntu 14.04
Posts: 1,384

Rep: Reputation: 42
wifi-radar and wep


trying to connect to my friends wlan using wifi-radar in Debian 4.
I get this in the terminal.
Error for wireless request "Set Encode" (8B2A) :
invalid argument "X000138883245".
Internet Systems Consortium DHCP Client V3.0.4
Copyright 2004-2006 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/

Listening on LPF/eth1/00:14:a4:69:ad:13
Sending on LPF/eth1/00:14:a4:69:ad:13
Sending on Socket/fallback
DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 4
DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 11
DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 9
DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 21

Can't connect: seems it doesn't like the wep key, although it is the correct one. No secrets on this machine so not too worried about the security issue of wep, just want to connect.

Any tips?
 
Old 01-28-2008, 05:44 AM   #2
Pedroski
Senior Member
 
Registered: Jan 2002
Location: Nanjing, China
Distribution: Ubuntu 14.04
Posts: 1,384

Original Poster
Rep: Reputation: 42
This is the wifi-rafdar.conf:

[DEFAULT]
ifup_required = False
auto_profile_order = Jack
speak_up = False
scan_timeout = 5
interface = eth1
commit_required = False

[Jack]
prescript =
use_wpa = no
postscript =
mode = auto
key =
use_dhcp = yes
security =
channel = auto
 
Old 01-28-2008, 06:03 AM   #3
Pedroski
Senior Member
 
Registered: Jan 2002
Location: Nanjing, China
Distribution: Ubuntu 14.04
Posts: 1,384

Original Poster
Rep: Reputation: 42
This is what I get from iwlist key:
eth1 2 key sizes : 40, 104bits
4 keys available :
[1]: off
[2]: off
[3]: off
[4]: off
Current Transmit Key: [1]
Authentication capabilities :
WPA
WPA2
CIPHER TKIP
CIPHER CCMP

Does this mean I can't use wep keys with wifi-radar?
 
Old 01-28-2008, 06:24 AM   #4
Pedroski
Senior Member
 
Registered: Jan 2002
Location: Nanjing, China
Distribution: Ubuntu 14.04
Posts: 1,384

Original Poster
Rep: Reputation: 42
iwlist scan comes up with this:
eth1 Scan completed :
Cell 01 - Address: 00:01:38:874:25
ESSID:"WLAN_45"
Protocol:IEEE 802.11bg
Mode:Master
Channel:6
Encryption keyn
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 6 Mb/s; 9 Mb/s
11 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
48 Mb/s; 54 Mb/s
Quality=100/100 Signal level=-186 dBm
Extra: Last beacon: 208ms ago
 
Old 01-28-2008, 08:16 AM   #5
pixellany
LQ Veteran
 
Registered: Nov 2005
Location: Annapolis, MD
Distribution: Arch/XFCE
Posts: 17,802

Rep: Reputation: 729Reputation: 729Reputation: 729Reputation: 729Reputation: 729Reputation: 729Reputation: 729
You might want to wait for replies before making 4 posts in a row. At 2:41 AM PST, much of the US is still asleep, and most Europeans are already at work. This leaves asia and people in the middle of the Atlantic on cruise ships...

Have you tried entering the WEP key with "s:" ?

I don't think wi-fi radar gives you the option of an ascii entry.....If your key is---e.g---"spain", then enter "s:spain"
 
Old 01-29-2008, 04:49 AM   #6
Pedroski
Senior Member
 
Registered: Jan 2002
Location: Nanjing, China
Distribution: Ubuntu 14.04
Posts: 1,384

Original Poster
Rep: Reputation: 42
Well, sent all the info I could, so some expert out there would have something to go on.
Under Debian Admin there is a menu Networking. I set the wep key there, which can accept ASCII. Wifi radar picks that up. But doesn't connect on clicking connect. Trys to, but times out. The led on the router doesn't flash, so my machine is not talking to it!
Took the wep key out of wifi-radar.conf, as it didn't seem to like it, but still no luck.
Did get it running under kwifimanager and Suse. But my nephew says Debian is better. Not sure there.
 
Old 01-29-2008, 05:28 AM   #7
Pedroski
Senior Member
 
Registered: Jan 2002
Location: Nanjing, China
Distribution: Ubuntu 14.04
Posts: 1,384

Original Poster
Rep: Reputation: 42
Will try with s:thekey though, if it works, buy you a beer!
 
Old 01-29-2008, 07:52 AM   #8
pixellany
LQ Veteran
 
Registered: Nov 2005
Location: Annapolis, MD
Distribution: Arch/XFCE
Posts: 17,802

Rep: Reputation: 729Reputation: 729Reputation: 729Reputation: 729Reputation: 729Reputation: 729Reputation: 729
Quote:
Originally Posted by Pedroski View Post
But my nephew says Debian is better. Not sure there.
Better for who? SUSE is very good, as is PCLinuxOS.

The fact that your wireless worked with kwifimanager says this one is surely going to get solved.

Are you by any chance using any special characters in the WEP key?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
WIFI Radar mabreaux Linux - Wireless Networking 8 09-06-2006 01:56 PM
WIFI Radar mabreaux Linux - Wireless Networking 2 09-03-2006 06:09 AM
Syntax of WEP key in wifi-radar adamsjw2 Linux - Wireless Networking 0 08-26-2006 11:52 AM
Wifi-Radar config hosler Linux - Software 1 01-27-2006 07:43 PM
Does anybody use wifi-radar? vinoloco Ubuntu 4 06-30-2005 10:06 PM


All times are GMT -5. The time now is 07:40 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration