LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices

Reply
 
Search this Thread
Old 05-16-2006, 04:21 PM   #1
kvgeorge1
LQ Newbie
 
Registered: Jul 2005
Posts: 2

Rep: Reputation: Disabled
Ndiswrapper sees hardware, driver but will not modprobe


I am using Fedora Core 4 with NDISWRAPPER 1.16. I am also using a Belkin F5D6020 ver 3. (realtek) NIC with my 2Wire wireless gateway. NDISWRAPPER sees the driver installed, and the hardware present, but doing a modprobe ndiswrapper the link light does not turn on. The card is working as this works with M$ without a hitch.

Here is the output from ndiswrapper -l
Code:
[root@localhost network-scripts]# ndiswrapper -l
Installed drivers:
net8180         driver installed, hardware present
And a copy of the wlan0 config that ndiswrapper -m made:
Code:
[root@localhost network-scripts]# cat /etc/sysconfig/network-scripts/ifcfg-wlan0
# Please read /usr/share/doc/initscripts-*/sysconfig.txt
# for the documentation of these parameters.
IPV6INIT=no
ONBOOT=no
USERCTL=no
PEERDNS=yes
GATEWAY=
TYPE=Wireless
DEVICE=wlan0
HWADDR=
BOOTPROTO=dhcp
NETMASK=
DHCP_HOSTNAME=
IPADDR=
DOMAIN=
ESSID=2WIRE736
CHANNEL=6
MODE=Auto
RATE=Auto
Now, I am also using WEP, but this should not prevent the light from turning on (or should it???) and the key is in a file called keys-wlan0.

Any suggestions?
 
Old 05-16-2006, 06:40 PM   #2
kvgeorge1
LQ Newbie
 
Registered: Jul 2005
Posts: 2

Original Poster
Rep: Reputation: Disabled
UPDATE!!!
=======================================
Ok, through a different thread, I can now get a link light. However, I cannot get a DHCP address. When I manually assign a static IP address to the card, I am not able to ping even the gateway.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Trying to load module "ndiswrapper" with modprobe; modprobe ndiswrapper doesn't work! Benjamin Linux - Wireless Networking 30 05-25-2008 07:04 AM
Ndiswrapper installed driver installed, hardware present, but modprobe doesn't likeit Flukey Linux - Hardware 1 04-14-2007 11:22 AM
ndiswrapper driver and hardware present but no wlan0 OneSeventeen Linux - Laptop and Netbook 5 07-28-2005 11:03 AM
can't modprobe ndiswrapper with .inf driver installed Andrew Skinner Linux - Wireless Networking 2 06-25-2005 08:10 AM
ndiswrapper-hardware present but no driver sachmo Linux - Wireless Networking 4 03-28-2005 05:06 PM


All times are GMT -5. The time now is 07:02 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration