LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices

Reply
 
Search this Thread
Old 04-15-2005, 06:01 AM   #1
coolnicklas
LQ Newbie
 
Registered: Apr 2005
Posts: 15

Rep: Reputation: 0
IPW2200 - works occasionally


Hi all,

I have been struggling for some days now to get the Intel 2200BG wlan card working (nicely) on my IBM T42 Thinkpad running Debian Sarge with Kernel 2.6.10.

Some background:

I have installed the IPW2200 driver + firmware, and the card is detected by Linux. I can scan for AP's using "iwlist eth1 scan " which brings up my Access point (Netgear WTG624) in the list.

I have added the eth1 interface in the /etc/network/interface file, which now looks like this:

**************/etc/network/interfaces***************

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
#auto eth0
iface eth0 inet static
address 192.168.0.183
netmask 255.255.255.0
network 192.168.0.0
broadcast 192.168.0.255
gateway 192.168.0.1
# dns-* options are implemented by the resolvconf package, if installed
dns-nameservers 192.168.0.1

#name WLAN card
auto eth1
iface eth1 inet static
address 192.168.0.185
netmask 255.255.255.0
network 192.168.0.0
broadcast 192.168.0.255
gateway 192.168.0.1
dns-nameservers 192.168.0.1

wireless_essid SpeedStar
wireless_mode ad-hoc
wireless_key restricted xxxxxxxxxx
wireless_ap any
wireless_channel 11

***************************************************

If I have understood this correctly, "auto eth1 " should bring up the eth1 interface during boot? After boot the output from iwconfig and ifconfig are:

*************output from iwconfig**********************

eth1 IEEE 802.11g ESSID:"SpeedStar"
Mode:Managed Frequency:2.462 GHz Access Point: 00:09:5B:C5:83:8E
Bit Rate=54 Mb/s Tx-Power=20 dBm
RTS thrff Fragment thrff
Encryption key:xxxx-xxxx-xx Security mode:restricted
Power Managementff
Link Quality=88/100 Signal level=-41 dBm Noise level=-85 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:1

****************************************************

*************output from ifconfig************************

eth1 Link encap:Ethernet HWaddr 00:12:F0:02:B6:92
inet addr:192.168.0.185 Bcast:192.168.0.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:79 errors:0 dropped:0 overruns:0 frame:0
TX packets:10 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:1497 (1.4 KiB) TX bytes:10134 (9.8 KiB)
Interrupt:11 Base address:0xa000 Memory:c0210000-c0210fff

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:196 errors:0 dropped:0 overruns:0 frame:0
TX packets:196 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:27856 (27.2 KiB) TX bytes:27856 (27.2 KiB)

****************************************************

However, it's still not possible to ping my local router...

What I did now was to start the Kwifi Manager and configured it with the same parametars as in /etc/network/interfaces, and applied them- and it shows I am connected and I can ping my local router as well.

What have i forgotten to put in the /etc/network/interfaces ?

I was really happy and brought up the browser to surf the net, but it did not work. I then tried to ping ibm.com and other URL's, but it only said: "Network not availiable". It tried pingin my router and my other computer and that went fine. Is this some kind of DNS-related problem?

The only way I have got the Wlan card working fully is to.

1. Boot Linux with eth0 as auto.
2. Disable it manually
3. bring up eth1 manually
4. start Kwifi manager

This has worked sometimes, and somtimes not. When it is not working, the symptom is that DNS is not working. I have tried to see the pattern, but have no success so far.

EDIT: host and nslookup works fine but pinging ip-addresses on the WAN does not.

Any help would be much appreciated

/Nicklas

Last edited by coolnicklas; 04-15-2005 at 05:39 PM.
 
Old 04-15-2005, 10:01 PM   #2
gotmonkey
Member
 
Registered: Apr 2004
Location: Dearborn, Mi
Distribution: Slackware 10 & Xandros 3
Posts: 62

Rep: Reputation: 15
I am pretty much in the same boat. I just got my IBM T42 with the 2200GB wireless. I am using Xandros 3 deluxe with kernel 2.6.9. You are doing slightly better though. I haven't been able to get the wireless up at all. IPW2200 is installed, but I don't know about the firmware.

I tried swapping a different minipci card (atheros a/b/g 5211 chipset) into the T42, but it came back with all sorts of grief with something other than the intel wireless card.
 
Old 04-16-2005, 03:48 AM   #3
coolnicklas
LQ Newbie
 
Registered: Apr 2005
Posts: 15

Original Poster
Rep: Reputation: 0
So what's the status now?
Is there a Atheros chipset now in your T42 or do you have the 2200BG?

If you have the Atheros chipset I have heard that "Madwifif" drivers should work. I have an orinoco gold card with Atheros chipset, so I will try to make that work when I am finnished with the 2200BG...

I should be able to help you out if you still have the 2200BG, since I got it work (almost)

/Nicklas
 
Old 04-16-2005, 07:55 AM   #4
gotmonkey
Member
 
Registered: Apr 2004
Location: Dearborn, Mi
Distribution: Slackware 10 & Xandros 3
Posts: 62

Rep: Reputation: 15
Quote:
Originally posted by coolnicklas
So what's the status now?
Is there a Atheros chipset now in your T42 or do you have the 2200BG?

If you have the Atheros chipset I have heard that "Madwifif" drivers should work. I have an orinoco gold card with Atheros chipset, so I will try to make that work when I am finnished with the 2200BG...

I should be able to help you out if you still have the 2200BG, since I got it work (almost)

/Nicklas
Unfortunately, no. When I put the atheros card in, the IBM bios pitched a fit. So, I have the original card (2200BG) in the T42.
 
Old 04-17-2005, 12:08 AM   #5
gotmonkey
Member
 
Registered: Apr 2004
Location: Dearborn, Mi
Distribution: Slackware 10 & Xandros 3
Posts: 62

Rep: Reputation: 15
I did find something interesting though. When I turned off the wep on my router, the 2200BG started running at boot.

I tried to set the wep back up on the router and use the networking control under xandros's control center. Was not able to pull an ip address. Also tried to manually set the essid and wep key, but iwconfig keeps coming back with an unassociated

any thoughts?
 
Old 04-17-2005, 04:45 AM   #6
coolnicklas
LQ Newbie
 
Registered: Apr 2005
Posts: 15

Original Poster
Rep: Reputation: 0
I have only tried KWifi Mangager and manually setting the WEP so I don't know how Xandros manager works, but I have an idea.

Are the WEP key set as a hex value or as a string in your AP (router)?

It must be the same on both sides, string-string, or hex-hex.

In KWifi Manager there is a checkbox named "string", which I had accidentially checked...
I had set my WEP key in the Netgear router as a hex value. I should be an option in your AP to set the WEP key as a string or as a hex value.

If you set the key manually with the command: iwconfig eth1 key "your_key", and want to set it as a string, then use the following syntax:

iwconfig eth1 key s:mypasswd

I would reccomend using hex on both the AP side and the client side.

I have finally got everything to work and I am going to post a manual for how to get the 2200BG work properly on this site. I can say that I did a series of minor mistakes which took about 6 hours of effective time to solve...

Good Luck

/Nicklas
 
Old 04-17-2005, 06:15 PM   #7
gotmonkey
Member
 
Registered: Apr 2004
Location: Dearborn, Mi
Distribution: Slackware 10 & Xandros 3
Posts: 62

Rep: Reputation: 15
Hey Nicklas,

I downloaded the kwifi manager. The configuration editor is the same as the wireless configurator in Xandros. It looks like it runs from scripts on connect.

There are 4 Configs. All are blank.

there is a network name
Operation Mode
Speed setting
execute script on connect
use cryptography
enable power management
load preset configuration and kde start

If this is what you are referring to, could you help me set it up? I have no idea on writing scripts
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Quick flash occasionally on the monitor fof3 Linux - Newbie 6 02-11-2006 01:09 PM
PC Speaker Beeping Occasionally linux-rulz Linux - General 5 06-28-2005 05:06 PM
Slackware 10.0.0 freezing occasionally plamensl Linux - Hardware 5 12-28-2004 08:34 AM
KDE Fonts Occasionally Very Small ErikJohnson Linux - Software 1 03-13-2004 02:08 PM
Redhat hangs occasionally dubl59zy Linux - Software 4 10-10-2003 06:33 PM


All times are GMT -5. The time now is 01:32 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration