LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Virtualization and Cloud
User Name
Password
Linux - Virtualization and Cloud This forum is for the discussion of all topics relating to Linux Virtualization and Linux Cloud platforms. Xen, KVM, OpenVZ, VirtualBox, VMware, Linux-VServer and all other Linux Virtualization platforms are welcome. OpenStack, CloudStack, ownCloud, Cloud Foundry, Eucalyptus, Nimbus, OpenNebula and all other Linux Cloud platforms are welcome. Note that questions relating solely to non-Linux OS's should be asked in the General forum.

Notices



Reply
 
Search this Thread
Old 06-01-2010, 04:25 PM   #1
PrinceCruise
Member
 
Registered: Aug 2009
Location: /Universe/Earth/India/Pune
Distribution: Slackware64 14.1/Current, CentOS 6.5/7.0
Posts: 795

Rep: Reputation: Disabled
Question Not able to install Fedora64 bit in VirtualBox 3.2


Hi ,

I'm using Mint9 (64 Bit) on my laptop.
My idea was to install Fedora and Open-Solaris as virtual machines for some serious R&D. I installed VirtualBox 3.2 as a deb package for Ubuntu 10.04 (Mint9 is based on that) and it worked properly.
Now I'm able to install Open-Solaris 32 bit on it successfully but at the time of booting Fedora13 64 bit , it gives me an error of "This guest requires a x86-64 CPU but only found a i686 one" , can not proceed...!
My laptop is a C2D T6400 , 3GB RAM , but it doesn't support VT (no setting in BIOS) , So does that mean I won't be able to install any 64 bit OS under VirtualBox or VMware ?

Please help , I'm very confused...!
 
Old 06-01-2010, 04:29 PM   #2
Mr-Bisquit
Member
 
Registered: Feb 2009
Distribution: FreeBSD, OpenBSD, NetBSD, Debian, Fedora
Posts: 770
Blog Entries: 52

Rep: Reputation: 68
Code:
cat /proc/cpuinfo
Have you tried paravirtualization with PAE instead?
If it's a 64bit cpu then that option can be used.
 
Old 06-01-2010, 05:11 PM   #3
PrinceCruise
Member
 
Registered: Aug 2009
Location: /Universe/Earth/India/Pune
Distribution: Slackware64 14.1/Current, CentOS 6.5/7.0
Posts: 795

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by Mr-Bisquit View Post
Code:
cat /proc/cpuinfo
Have you tried paravirtualization with PAE instead?
If it's a 64bit cpu then that option can be used.
Thanks mate for replying . I'm in office right now so will post the output when I'll be on my system.
Would you please throw some more light on "paravirtualization with PAE" ? I guess I didn't get it fully .
 
Old 06-01-2010, 06:57 PM   #4
syg00
LQ Veteran
 
Registered: Aug 2003
Location: Australia
Distribution: Lots ...
Posts: 12,504

Rep: Reputation: 1079Reputation: 1079Reputation: 1079Reputation: 1079Reputation: 1079Reputation: 1079Reputation: 1079Reputation: 1079
Never mind - didn't read the OP properly.

Last edited by syg00; 06-01-2010 at 06:58 PM.
 
Old 06-01-2010, 07:08 PM   #5
paulsm4
Guru
 
Registered: Mar 2004
Distribution: SusE 8.2
Posts: 5,863
Blog Entries: 1

Rep: Reputation: Disabled
When you create your VM (prior to installing an OS on top of it), you need to specify that it's a AMD-64 VM (not x86).

Quote:
http://forums.virtualbox.org/viewtopic.php?t=8669

Q: Does VB support 64 bit guests?

A: Support for 64 bit guests was introduced at version 2.0.0. If you wish to create 64 bit guests then we recommend that you upgrade to the latest version. Note that VirtualBox also supports 64-bit guest operating systems, under the following conditions:

1. You need a 64-bit processor with hardware virtualization support (see User Manual chapter 1.2, Software vs. hardware virtualization (VT-x and AMD-V), page 10) and a 64-bit host operating system.
NOTE: Since version 2.1.0, you can run 64 bit Guests while running a 32 bit Host. The prior requirement for Operating System is only for version 2.0.x. You still need the proper hardware.
2. You must enable hardware virtualization through your BIOS; software virtualization is not supported for 64-bit VMs.
Note: some HP BIOSES have a glitch, When You ENABLE VT-X/AMD-V, You DISABLE it, so do try both ways.
 
Old 06-02-2010, 06:13 AM   #6
PrinceCruise
Member
 
Registered: Aug 2009
Location: /Universe/Earth/India/Pune
Distribution: Slackware64 14.1/Current, CentOS 6.5/7.0
Posts: 795

Original Poster
Rep: Reputation: Disabled
Hi Paul ,

In virtualbox 3.2.0 I can't seem to select any option for choosing 32 or 64 bit VM. It's pretty plain selection !


This is the output of cpuinfo -

Quote:
prince@prince-mint9 ~ $ cat /proc/cpuinfo
processor : 0
vendor_id : GenuineIntel
cpu family : 6
model : 23
model name : Intel(R) Core(TM)2 Duo CPU T6400 @ 2.00GHz
stepping : 10
cpu MHz : 1200.000
cache size : 2048 KB
physical id : 0
siblings : 2
core id : 0
cpu cores : 2
apicid : 0
initial apicid : 0
fpu : yes
fpu_exception : yes
cpuid level : 13
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx lm constant_tsc arch_perfmon pebs bts rep_good aperfmperf pni dtes64 monitor ds_cpl est tm2 ssse3 cx16 xtpr pdcm sse4_1 xsave lahf_lm
bogomips : 3989.65
clflush size : 64
cache_alignment : 64
address sizes : 36 bits physical, 48 bits virtual
power management:

processor : 1
vendor_id : GenuineIntel
cpu family : 6
model : 23
model name : Intel(R) Core(TM)2 Duo CPU T6400 @ 2.00GHz
stepping : 10
cpu MHz : 1200.000
cache size : 2048 KB
physical id : 0
siblings : 2
core id : 1
cpu cores : 2
apicid : 1
initial apicid : 1
fpu : yes
fpu_exception : yes
cpuid level : 13
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx lm constant_tsc arch_perfmon pebs bts rep_good aperfmperf pni dtes64 monitor ds_cpl est tm2 ssse3 cx16 xtpr pdcm sse4_1 xsave lahf_lm
bogomips : 3990.01
clflush size : 64
cache_alignment : 64
address sizes : 36 bits physical, 48 bits virtual
power management:

Now could you please suggest me what needs to be done?
 
Old 06-02-2010, 11:57 AM   #7
paulsm4
Guru
 
Registered: Mar 2004
Distribution: SusE 8.2
Posts: 5,863
Blog Entries: 1

Rep: Reputation: Disabled
Hi -

Q: The "cpuinfo" you posted is from your physical host (and not your VM), correct? The issue is whether your *VM* is 32-bit or 64-bit.

Q: Here's the VBox download page:
http://download.virtualbox.org/virtu...oad.html#linux

You downloaded this:
virtualbox-3.2_3.2.0-61806~Ubuntu~lucid_amd64.deb

and NOT this:
virtualbox-3.2_3.2.0-61806~Ubuntu~lucid_i386.deb

Correct?
 
Old 06-02-2010, 12:07 PM   #8
Mr-Bisquit
Member
 
Registered: Feb 2009
Distribution: FreeBSD, OpenBSD, NetBSD, Debian, Fedora
Posts: 770
Blog Entries: 52

Rep: Reputation: 68
If your cpu set does not contain the proper flags, then no, you cannot support 64bit guests.
If you want a 64bit guest and don't mind the work, then qemu + kqemu- although "outdated" it is very useful- may be a solution.
I'm not sure; but, you may check with Xen and paravirtualized guests.
 
Old 06-03-2010, 10:08 AM   #9
PrinceCruise
Member
 
Registered: Aug 2009
Location: /Universe/Earth/India/Pune
Distribution: Slackware64 14.1/Current, CentOS 6.5/7.0
Posts: 795

Original Poster
Rep: Reputation: Disabled
My answers in bold sir , thanks for bothering me -

Quote:
Originally Posted by paulsm4 View Post
Hi -

Q: The "cpuinfo" you posted is from your physical host (and not your VM), correct? The issue is whether your *VM* is 32-bit or 64-bit.

A: The output is of Physical machine. And let me put it again ,while creating the VM it doesn't give the option of choosing 64 or 32 bit , though in VMware it used to.

Q: Here's the VBox download page:
http://download.virtualbox.org/virtu...oad.html#linux

You downloaded this:
virtualbox-3.2_3.2.0-61806~Ubuntu~lucid_amd64.deb

and NOT this:
virtualbox-3.2_3.2.0-61806~Ubuntu~lucid_i386.deb

Correct?

A: virtualbox-3.2_3.2.0-61806~Ubuntu~lucid_amd64.deb , yes !
 
Old 06-03-2010, 10:12 AM   #10
PrinceCruise
Member
 
Registered: Aug 2009
Location: /Universe/Earth/India/Pune
Distribution: Slackware64 14.1/Current, CentOS 6.5/7.0
Posts: 795

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by Mr-Bisquit View Post
If your cpu set does not contain the proper flags, then no, you cannot support 64bit guests.
If you want a 64bit guest and don't mind the work, then qemu + kqemu- although "outdated" it is very useful- may be a solution.
I'm not sure; but, you may check with Xen and paravirtualized guests.
Hi ,Yes,May be I need to reconsider options.
I'm not very much used to of Qemu, heard and seen it's tougher to manage , but let me atleast give it and Xen a shot.

Last edited by PrinceCruise; 06-03-2010 at 11:11 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Virtualbox - 64-bit or 32-bit guests? tuxgirl Linux - Virtualization and Cloud 8 08-30-2011 05:02 PM
64-bit VirtualBox host running a single 32-bit guest, good idea? FireRaven Linux - Virtualization and Cloud 10 04-03-2010 04:21 PM
Virtualbox guest complains system is only 32 bit binary_pearl Linux - Software 1 03-02-2010 03:05 PM
Fedora64 12 Internet Problem LeechFace Fedora 9 02-08-2010 11:22 AM
VirtualBox 2.1 on Fedora 64-bit won't install Windows 7 Beta 64-bit linuxroks88 Linux - Software 18 01-27-2009 11:37 AM


All times are GMT -5. The time now is 06:07 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration