LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Virtualization and Cloud
User Name
Password
Linux - Virtualization and Cloud This forum is for the discussion of all topics relating to Linux Virtualization and Linux Cloud platforms. Xen, KVM, OpenVZ, VirtualBox, VMware, Linux-VServer and all other Linux Virtualization platforms are welcome. OpenStack, CloudStack, ownCloud, Cloud Foundry, Eucalyptus, Nimbus, OpenNebula and all other Linux Cloud platforms are welcome. Note that questions relating solely to non-Linux OS's should be asked in the General forum.

Notices

Reply
 
Search this Thread
Old 11-02-2012, 03:21 AM   #1
ram_rajavarapu
Member
 
Registered: May 2008
Posts: 41

Rep: Reputation: 15
No Internet access on virtual boxes


Hello,

I installed vmware workstation-6 on windows-7 box and running two linux virtual boxes. Virtual boxes are able to ping internet and unable to access internet. I selected automatic Bridging which is VMnet0. Please help me.

Thanks,
 
Old 11-02-2012, 09:39 AM   #2
sundialsvcs
Guru
 
Registered: Feb 2004
Location: SE Tennessee, USA
Distribution: Gentoo, LFS
Posts: 5,401

Rep: Reputation: 1120Reputation: 1120Reputation: 1120Reputation: 1120Reputation: 1120Reputation: 1120Reputation: 1120Reputation: 1120Reputation: 1120
You need to diagnose the problem, step by step. The ability to "ping" a 192.168.x.x address will establish that the VM can talk outside of the VM. Getting a meaningful response from, say, Google's IP-address will establish connectivity to the world. "Access the Internet" could thefore be a problem with DNS name-resolution ... turning "google.com" into an IP-address.

You have to diagnose the problem.
 
Old 11-02-2012, 09:27 PM   #3
kedarp
Member
 
Registered: Jul 2012
Location: Pune, India
Distribution: Mageia 4
Posts: 182

Rep: Reputation: 22
I really didn't understand 'ping internet'. Which IP address did you ping?

I use NAT whenever I have to access internet from the guest OS in VirtualBox.
You can also try that.
 
Old 01-01-2013, 10:51 AM   #4
ubume2
Member
 
Registered: Oct 2006
Distribution: Ubuntu
Posts: 65

Rep: Reputation: 15
Try this:
In Vbox, Settings>>Network, change from NAT to Bridge Adapter.

I had the problem in Kubuntu 12.10 when trying to run any guest os. I could not access internet, but could access 192.168.x.x.

I changed to bridge adapter and got access.

Good luck.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Virtual Box Centos 6.2 x86 Internet Access Issue. dailyoliver Linux - Server 15 03-11-2013 03:19 AM
[SOLVED] Virtual Machine cannot access the internet \/4A Linux - Virtualization and Cloud 6 09-20-2012 01:59 AM
Internet Access from Guest virtual machine on Fedora 8 pigwig Linux - Newbie 5 03-06-2008 11:22 PM
Cannot access internet in Virtual PC gamewolf Debian 3 01-22-2008 08:19 AM
Some suggestions about dividing internet access to three boxes? mac1234mac Linux - Networking 2 01-06-2007 03:23 PM


All times are GMT -5. The time now is 12:48 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration