LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 09-11-2007, 06:09 PM   #1
alabamaman
Member
 
Registered: Jul 2007
Location: linux-noobville.d/dfw texas
Distribution: grub multi-booter
Posts: 102

Rep: Reputation: 16
yum update fails because of faad2 dependency


okay so i was having this problem with my yum install of vlc earlier, but i got it installed by using:
Code:
yum --disablerepo=livna install vlc -y
and vlc works fine. BUT NOW when i try to do a yum update i get this:
Code:
[root@dustyfedora ~]# yum update
Loading "installonlyn" plugin
Setting up Update Process
Setting up repositories
Reading repository metadata in from local files
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
>>>>>>deleted stuff that goes here<<<<<<
--> Processing Conflict: vlc conflicts faad2 >= 2.5
--> Processing Dependency: libImlib2.so.1 for package: ffmpeg-libs
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package gsm.i386 0:1.0.12-3.fc6 set to be updated
---> Package xvidcore.i386 0:1.1.3-2.fc6 set to be updated
---> Package imlib2.i386 0:1.3.0-3.fc6 set to be updated
--> Running transaction check
--> Processing Dependency: faad2 < 2.5 for package: ffmpeg-libs
--> Processing Conflict: vlc conflicts faad2 >= 2.5
--> Finished Dependency Resolution
Error: vlc conflicts with faad2 >= 2.5
Error: Missing Dependency: faad2 < 2.5 is needed by package ffmpeg-libs
[root@dustyfedora ~]#
so i searched for some other threads about this which provided links to the pre-2.5 package of faad2, but either the links were broken or didn't work when i tried to install them. i'm sure i'm doing something wrong or missing something, but at this point i have no idea where to go, and i'd really rather not have this problem everytime i need to update packages.

if somebody can point me in the right direction i'd be more than happy. thanks
 
Old 09-11-2007, 10:41 PM   #2
alabamaman
Member
 
Registered: Jul 2007
Location: linux-noobville.d/dfw texas
Distribution: grub multi-booter
Posts: 102

Original Poster
Rep: Reputation: 16
also there's this...i tried to install the earlier version of faad and ole dustyfedora didn't like that too much...

Code:
[root@dustyfedora firefox_dl]# rpm -hiv faad2-2.0-8.fc3.rf.i386.rpm 
warning: faad2-2.0-8.fc3.rf.i386.rpm: Header V3 DSA signature: NOKEY, key ID 6b8d79e6
Preparing...                ########################################### [100%]
        package faad2-2.5-2.fc6 (which is newer than faad2-2.0-8.fc3.rf) is already installed
        file /usr/lib/libmp4v2.so.0.0.0 from install of faad2-2.0-8.fc3.rf conflicts with file from package libmp4v2-1.5.0.1-3.fc6
        file /usr/bin/faad from install of faad2-2.0-8.fc3.rf conflicts with file from package faad2-2.5-2.fc6
        file /usr/lib/libfaad.so.0.0.0 from install of faad2-2.0-8.fc3.rf conflicts with file from package faad2-2.5-2.fc6
[root@dustyfedora firefox_dl]# rpm -qi faad2
Name        : faad2                        Relocations: (not relocatable)
Version     : 2.5                               Vendor: Freshrpms.net
Release     : 2.fc6                         Build Date: Mon 08 Jan 2007 11:33:26 AM CST
Install Date: Tue 11 Sep 2007 01:52:54 PM CDT      Build Host: python3.freshrpms.net
Group       : Applications/Multimedia       Source RPM: faad2-2.5-2.fc6.src.rpm
Size        : 322723                           License: GPL
Signature   : DSA/SHA1, Mon 08 Jan 2007 11:34:45 AM CST, Key ID 692ac459e42d547b
Packager    : Matthias Saou <matthias@rpmforge.net>
URL         : http://www.audiocoding.com/
Summary     : Library and frontend for decoding MPEG2/4 AAC
Description :
FAAD 2 is a LC, MAIN and LTP profile, MPEG2 and MPEG-4 AAC decoder, completely
written from scratch.
[root@dustyfedora firefox_dl]#
so uhh....any ideas? please? anybody? this is really getting on my nerves
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Dependency problem with Yum update davesmith Red Hat 1 09-06-2007 02:23 PM
yum update dependency problem newuser455 Linux - Software 4 06-22-2007 07:10 PM
yum update - error. dependency btaylor1988 Linux - Desktop 3 06-11-2007 05:52 AM
yum update dependency issues ZeroIdea Linux - Desktop 1 09-24-2006 04:44 AM
Upgrade FC4 - FC5 using yum, fails with initscripts dependency rendle Fedora 2 04-05-2006 09:32 AM


All times are GMT -5. The time now is 05:52 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration