LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices



Reply
 
Search this Thread
Old 07-12-2008, 04:42 PM   #1
bezdomny
Member
 
Registered: May 2006
Location: North-Central California
Distribution: Debian Lenny
Posts: 154

Rep: Reputation: 30
xserver lost configuration, dpkg-reconfigure xserver-xorg isn't helping


Code:
dpkg-reconfigure xserver-xorg
has been tried numerous times with different values and even though it correctly detects my display adapter and my monitor, I still end up with a command line.

Any suggestions?

Perhaps some manual edits from the command line (with pico, I guess) of /etc/X11/xorg.conf?

display adapter according to dpkg-reconfigure xserver-xorg:
Code:
nVidia Corporation NV11 [GeForce2 MX/MX400]
display adapter according to lspci:
Code:
VGA compatible controller: nVidia Corporation NV11 [GeForce2 MX/MX 400]
adapter bus according to dpkg-reconfigure xserver-xorg:
Code:
PCI:1:0:0
adapter bus according to lspci:
Code:
01:00.0
monitor according to dpkg-reconfigure xserver-xorg:
Code:
BenQ FP731
Thanks and best regards from (smoky) Northern California USA,

bezdomny
 
Old 07-12-2008, 04:59 PM   #2
bigrigdriver
LQ Addict
 
Registered: Jul 2002
Location: East Centra Illinois, USA
Distribution: Debian Squeeze
Posts: 5,805

Rep: Reputation: 324Reputation: 324Reputation: 324Reputation: 324
A couple of things to try.

Somewhere in /var/lib, you may have a copy of the original xorg.conf that was created when you installed Linux. If you have it, you could copy it back to /etc/X11.

Second, in /etc/inittab, look for the default runlevel. If it reads id:3:initdefault:, change it to id:5:initdefault:.
 
Old 07-12-2008, 05:20 PM   #3
reddazz
Guru
 
Registered: Nov 2003
Location: N. E. England
Distribution: Fedora, CentOS, Debian
Posts: 16,298

Rep: Reputation: 73
I had similar problems when I was running a test Debian Lenny install. It seems like "dpkg -reconfigure xserver-xorg" does not work like it used to in the past. I managed to reconfigure the card using the nvidia-xconfig tool.
 
Old 07-12-2008, 10:20 PM   #4
bezdomny
Member
 
Registered: May 2006
Location: North-Central California
Distribution: Debian Lenny
Posts: 154

Original Poster
Rep: Reputation: 30
xserver lost configuration, dpkg-reconfigure xserver-xorg isn't helping-- solved!

Success! From the command line, deleted xorg.config, used pico to open the oldest backup and save it as "xorg.config", and all was well.

You're right-- dpkg-reconfigure xerver-xorg doesn't seem to work anymore. All the backups I looked at were blank compared to the oldest one that I renamed.

Thank you for your help, reddazz and bigrigdriver!

best regards from Northern California USA,

bezdomny
 
Old 07-13-2008, 12:24 AM   #5
r00tb33r
Member
 
Registered: Feb 2007
Distribution: Vector
Posts: 318

Rep: Reputation: 31
Quote:
Originally Posted by bezdomny View Post
Success! From the command line, deleted xorg.config, used pico to open the oldest backup and save it as "xorg.config", and all was well.

You're right-- dpkg-reconfigure xerver-xorg doesn't seem to work anymore. All the backups I looked at were blank compared to the oldest one that I renamed.

Thank you for your help, reddazz and bigrigdriver!

best regards from Northern California USA,

bezdomny
Quite a surprise considering it should be "xorg.conf" and not "xorg.config"... Unless its a very strange distro...
 
Old 07-13-2008, 01:33 PM   #6
bezdomny
Member
 
Registered: May 2006
Location: North-Central California
Distribution: Debian Lenny
Posts: 154

Original Poster
Rep: Reputation: 30
xserver lost configuration, dpkg-reconfigure xserver-xorg isn't helping

You are correct-- it was "xorg.conf". By the way, distro is Debian Lenny.

Best regards from Northern California, USA

bezdomny
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
dpkg-reconfigure xserver-xorg ends before screen(monitor) guide terfy Linux - Distributions 0 06-24-2008 11:29 AM
dpkg-reconfigure xserver-xfree86, why? Monkey 9 Debian 22 12-11-2005 01:57 PM
dpkg-reconfigure xserver-xfree86 HooX Linux - Newbie 6 01-10-2005 06:35 PM
dpkg-reconfigure xserver-xfree86 Advanced Now? elias4444 Debian 1 11-03-2004 07:27 PM
dpkg-reconfigure xserver doesnt save changes short101 Debian 5 09-06-2004 10:41 AM


All times are GMT -5. The time now is 08:00 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration