LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices



Reply
 
Search this Thread
Old 08-12-2005, 02:41 PM   #1
RedHatCore
Member
 
Registered: Aug 2005
Distribution: Fedora Core 4
Posts: 60

Rep: Reputation: 15
Windows Media Players files in FireFox?


How could I get windows media files to run in FireFox?

and

How do I get Windows Media files to run outside of browser(just normal system)?

I'm running Fedora Core 4

Thanks for help!
 
Old 08-12-2005, 02:47 PM   #2
reddazz
Guru
 
Registered: Nov 2003
Location: N. E. England
Distribution: Fedora, CentOS, Debian
Posts: 16,298

Rep: Reputation: 74
You need to make sure you install mplayer or xine (with totem or kaffeine as frontnds if you wish), win32 codecs and their browser plugins. The mplayer website has the codecs and the source package for mplayer (and some Fedora rpms I believe).
 
Old 08-12-2005, 03:45 PM   #3
RedHatCore
Member
 
Registered: Aug 2005
Distribution: Fedora Core 4
Posts: 60

Original Poster
Rep: Reputation: 15
K well I used the CVS installation and don't know how to use it,
and I downloaded the RPMs and installed it,
downloaded the GUI and it didn't work because it requires mplayer-default i think it is...

And I don't know how to use any of the above... any help ?
 
Old 08-12-2005, 07:40 PM   #4
reddazz
Guru
 
Registered: Nov 2003
Location: N. E. England
Distribution: Fedora, CentOS, Debian
Posts: 16,298

Rep: Reputation: 74
Setup the livna rpm repository for yum or apt and install their mplayer rpms.
 
Old 08-13-2005, 08:59 AM   #5
RedHatCore
Member
 
Registered: Aug 2005
Distribution: Fedora Core 4
Posts: 60

Original Poster
Rep: Reputation: 15
Ok, installed for yum! Now, how do I install 'their' mplayer?
 
Old 08-13-2005, 09:15 AM   #6
RedHatCore
Member
 
Registered: Aug 2005
Distribution: Fedora Core 4
Posts: 60

Original Poster
Rep: Reputation: 15
Ok, I tried yum install mplayer and it did a bunch of stuff... now what? or did I do it wrong?

Where do installations go after that? how do I start them?

edit: >_< sorry for double post
 
Old 08-13-2005, 09:45 AM   #7
linmix
Senior Member
 
Registered: Jun 2004
Location: Spain
Distribution: FC5
Posts: 1,993
Blog Entries: 1

Rep: Reputation: 46
mplayer should now have a quick access at Applications-->Sound and Video. You can also open a terminal and type 'mplayer' which will open the gui.
 
Old 08-13-2005, 10:15 AM   #8
RedHatCore
Member
 
Registered: Aug 2005
Distribution: Fedora Core 4
Posts: 60

Original Poster
Rep: Reputation: 15
1) There is no shortcut in Sound & Video
2) I'm using KDE
3) myplater in the terminal does not give me GUI, but command options
4) When I follow the 'usage: ' by typing in the file name i want to play I got this error:

MPlayer 1.0pre7-RPM-3.4.2 (C) 2000-2005 MPlayer Team
CPU: Advanced Micro Devices Athlon MP/XP Thoroughbred (Family: 6, Stepping: 1)
Detected cache-line size is 64 bytes
CPUflags: MMX: 1 MMX2: 1 3DNow: 1 3DNow2: 1 SSE: 1 SSE2: 0
Compiled with runtime CPU detection - WARNING - this is not optimal!
To get best performance, recompile MPlayer with --disable-runtime-cpudetection.


Playing snotrocket2.wmv.
Cache fill: 0.00% (0 bytes) Win32 LoadLibrary failed to load: avisynth.dll, /usr/lib/codecs/avisynth.dll, /usr/lib/win32/avisynth.dll, /usr/local/lib/win32/avisynth.dll

(*(I believe there was a slite pause about here)*)

Exiting... (End of file)
 
Old 08-13-2005, 10:20 AM   #9
reddazz
Guru
 
Registered: Nov 2003
Location: N. E. England
Distribution: Fedora, CentOS, Debian
Posts: 16,298

Rep: Reputation: 74
Try running gmplayer. If its not installed, do the following
Code:
#yum list | grep -i mplayer
A list of mplayer related packages will be listed, install the one that corresponds to the gui. Also when you download the codecs, extract them to /usr/lib/win32.
 
Old 08-13-2005, 10:47 AM   #10
RedHatCore
Member
 
Registered: Aug 2005
Distribution: Fedora Core 4
Posts: 60

Original Poster
Rep: Reputation: 15
1) Don't know anything about codec's, where to get them, how to install them, how to use them.
2) I get this error when install GUI:

#yum install mplayer-gui.i386
Setting up Install Process
Setting up repositories
livna 100% |=========================| 951 B 00:00
updates-released 100% |=========================| 951 B 00:00
extras 100% |=========================| 1.1 kB 00:00
base 100% |=========================| 1.1 kB 00:00
Reading repository metadata in from local files
Parsing package install arguments
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Downloading header for mplayer-gui to pack into transaction set.
mplayer-gui-1.0-0.lvn.0.2 100% |=========================| 21 kB 00:00
---> Package mplayer-gui.i386 0:1.0-0.lvn.0.23.pre7.4 set to be updated
--> Running transaction check
--> Processing Dependency: mplayer = 0:1.0-0.lvn.0.23.pre7.4 for package: mplayer-gui
--> Finished Dependency Resolution
Error: Missing Dependency: mplayer = 0:1.0-0.lvn.0.23.pre7.4 is needed by package mplayer-gui

I AM logged in as root, just thought I'd clear that up.

Perhaps one of you could recap everything that's been said into a sort-of 'installation intruction'? Don't have to, just a thought Thank ya'll so much for everything you've done so far!!!

Edit/Update: This is what my 'yum list | grep -i mplayer' output came out to:

[root@localhost Downloads]# yum list | grep -i mplayer
http://mirror.netglobalis.net/pub/fe...ta/repomd.xml: [Errno 4] IOError: HTTP Error 404: Date: Sat, 13 Aug 2005 15:53:01 GMT
Server:
Content-Length: 315
Connection: close
Content-Type: text/html; charset=iso-8859-1
Trying other mirror.
mplayer.i386 3:1.0pre7-1 installed
mplayer.i386 1.0-0.lvn.0.23.pre7.4 livna
mplayer-fonts.noarch 1.1-0.lvn.3.4 livna
mplayer-gui.i386 1.0-0.lvn.0.23.pre7.4 livna
mplayer-mencoder.i386 1.0-0.lvn.0.23.pre7.4 livna
mplayerplug-in.i386 2.80-0.lvn.1.4 livna
xmmplayer.i386 0.3.3-0.lvn.4.4 livna

Last edited by RedHatCore; 08-13-2005 at 12:02 PM.
 
Old 08-13-2005, 02:40 PM   #11
RedHatCore
Member
 
Registered: Aug 2005
Distribution: Fedora Core 4
Posts: 60

Original Poster
Rep: Reputation: 15
Please someone answer?
 
Old 08-13-2005, 02:44 PM   #12
linmix
Senior Member
 
Registered: Jun 2004
Location: Spain
Distribution: FC5
Posts: 1,993
Blog Entries: 1

Rep: Reputation: 46
ok here's what's happaned: if you do 'rpm -qa | grep mplayer' you'll probably see that the package you have installed didn't come from livna. For some reason (I can guess but not explain) there are different ways rpms are being made available for fc4 and they are not always compatilble when you want to update using a differnt repo.

So: 'rpm-e mplayer' to uninstall the mplayer you have installed. Then, with the livna repo enabled again do 'yum -y install mplayer mplayer-gui' (or if you have broadband and don't mind installing packages you my not really need 'yum -y install mplayer*)

That should do it.
 
Old 08-13-2005, 02:51 PM   #13
RedHatCore
Member
 
Registered: Aug 2005
Distribution: Fedora Core 4
Posts: 60

Original Poster
Rep: Reputation: 15
Ek, I thought the topic was dead, so I posted another--- ekk! If you know a mod or something, delete it lol. I'll try what you said.
 
Old 08-13-2005, 02:58 PM   #14
RedHatCore
Member
 
Registered: Aug 2005
Distribution: Fedora Core 4
Posts: 60

Original Poster
Rep: Reputation: 15
I got it working.. i typed gmplayer and it worked, GUI loaded.. looks like it might when then when i load a file(got it off ebaumsworld.com(explains the file name lol)) this error occurs:

[root@localhost ~]# gmplayer /root/Desktop/Downloads/snotrocket2.wmv
MPlayer 1.0pre7-4.0.0 (C) 2000-2005 MPlayer Team
CPU: Advanced Micro Devices Athlon MP/XP Thoroughbred (Family: 6, Stepping: 1)
Detected cache-line size is 64 bytes
CPUflags: MMX: 1 MMX2: 1 3DNow: 1 3DNow2: 1 SSE: 1 SSE2: 0



vo: X11 running at 1280x1024 with depth 24 and 32 bpp (":0.0" => local display)
Opening joystick device /dev/input/js0
Can't open joystick device /dev/input/js0 : No such file or directory
Can't init input joystick
Setting up LIRC support...
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support.
You will not be able to use your remote control.
Playing /root/Desktop/Downloads/snotrocket2.wmv.
Cache fill: 0.00% (0 bytes) Win32 LoadLibrary failed to load: avisynth.dll, /usr/lib/win32/avisynth.dll, /usr/local/lib/win32/avisynth.dll
XMMS: found plugin: libwav.so (Wave Player 1.2.10)
XMMS: found plugin: libtonegen.so (Tone Generator 1.2.10)
XMMS: found plugin: libvorbis.so (Ogg Vorbis Player 1.2.10)
XMMS: found plugin: librh_mp3.so (MPEG Layer 1/2/3 Placeholder Plugin)
XMMS: found plugin: libmikmod.so (MikMod Player 1.2.10)
XMMS: found plugin: libcdaudio.so (CD Audio Player 1.2.10)
XMMS: Closing plugin /usr/lib/xmms/Input/libcdaudio.so
XMMS: Closing plugin /usr/lib/xmms/Input/libmikmod.so
XMMS: Closing plugin /usr/lib/xmms/Input/librh_mp3.so
XMMS: Closing plugin /usr/lib/xmms/Input/libvorbis.so
XMMS: Closing plugin /usr/lib/xmms/Input/libtonegen.so
XMMS: Closing plugin /usr/lib/xmms/Input/libwav.so
 
Old 08-13-2005, 03:03 PM   #15
linmix
Senior Member
 
Registered: Jun 2004
Location: Spain
Distribution: FC5
Posts: 1,993
Blog Entries: 1

Rep: Reputation: 46
just two little things:
1) try to do as little as possible as root... you never know. You can watch movies fine as normal user.

2) patience is a virtue. allow at least24 hours before you get nervous

(I'm glad you got it working
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Firefox, Sirius, and Windows Media Player pbaumgar Linux - Software 2 11-30-2005 08:33 PM
sights that want windows media in Linux firefox AhYup Linux - Software 2 10-11-2005 04:33 PM
windows media player for firefox sailu_mvn Linux - Software 3 08-05-2005 05:15 AM
How do I make the media players play .asf files? xSTELLA Linux - Newbie 11 07-08-2005 02:12 AM
How to get xine to play quicktime/windows media in firefox rjcmi Debian 3 10-14-2004 11:27 AM


All times are GMT -5. The time now is 06:09 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration