LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 06-23-2004, 08:08 AM   #1
Elite_Gamer04
Member
 
Registered: May 2004
Posts: 57

Rep: Reputation: 15
VMware Workstation Problems with new Fedora Core 2 Kernal Update..


Hi,

Just finished updating FC2 to its new kernal and went to run VMware Workstation and it came up with a Error Box saying I have to re-configure VMware before using it on the new kernal, So I typed "vmware-config.pl" as root and followed the instructions and got the follow error:

Quote:
[root@localhost *]# vmware-config.pl
Making sure VMware Workstation's services are stopped.

Stopping VMware services:
Virtual machine monitor [ OK ]
Bridged networking on /dev/vmnet0 [ OK ]
DHCP server on /dev/vmnet8 [ OK ]
NAT service on /dev/vmnet8 [ OK ]
Host-only networking on /dev/vmnet8 [ OK ]
Virtual ethernet [ OK ]

Trying to find a suitable vmmon module for your running kernel.

None of VMware Workstation's pre-built vmmon modules is suitable for your
running kernel. Do you want this program to try to build the vmmon module for
your system (you need to have a C compiler installed on your system)? [yes] yes

Using compiler "/usr/bin/gcc". Use environment variable CC to override.

What is the location of the directory of C header files that match your running
kernel? [/lib/modules/2.6.6-1.435/build/include]

Extracting the sources of the vmmon module.

Building the vmmon module.

Using 2.6.x kernel build system.
make: Entering directory `/tmp/vmware-config1/vmmon-only'
make -C /lib/modules/2.6.6-1.435/build/include/.. SUBDIRS=$PWD SRCROOT=$PWD/. modules
make[1]: Entering directory `/lib/modules/2.6.6-1.435/build'
CC [M] /tmp/vmware-config1/vmmon-only/linux/driver.o
/tmp/vmware-config1/vmmon-only/linux/driver.c:131: warning: initialization from incompatible pointer type
/tmp/vmware-config1/vmmon-only/linux/driver.c:135: warning: initialization from incompatible pointer type
CC [M] /tmp/vmware-config1/vmmon-only/linux/hostif.o
/tmp/vmware-config1/vmmon-only/linux/hostif.c: In function `HostIF_FreeLockedPages':
/tmp/vmware-config1/vmmon-only/linux/hostif.c:738: error: structure has no member named `count'
/tmp/vmware-config1/vmmon-only/linux/hostif.c:740: error: structure has no member named `count'
make[2]: *** [/tmp/vmware-config1/vmmon-only/linux/hostif.o] Error 1
make[1]: *** [_module_/tmp/vmware-config1/vmmon-only] Error 2
make[1]: Leaving directory `/lib/modules/2.6.6-1.435/build'
make: *** [vmmon.ko] Error 2
make: Leaving directory `/tmp/vmware-config1/vmmon-only'
Unable to build the vmmon module.

For more information on how to troubleshoot module-related problems, please
visit our Web site at "http://www.vmware.com/download/modules/modules.html" and
"http://www.vmware.com/support/reference/linux/prebuilt_modules_linux.html".

Execution aborted.
Whats going on someone please help?
 
Old 06-23-2004, 08:51 AM   #2
eespenh
LQ Newbie
 
Registered: Jun 2004
Location: Norway
Distribution: Fedora Core 2/Mandrake 10
Posts: 3

Rep: Reputation: 0
This error was fixed in the newest VMware version (4.5.2, build 8848 is current, I think).

It's mentioned in another thread, but I thought I'd repeat it, since it worked flawlessly
for me. (Apart from the display behaving a little strange at times now.)

Espen
 
Old 07-01-2004, 10:27 PM   #3
Elite_Gamer04
Member
 
Registered: May 2004
Posts: 57

Original Poster
Rep: Reputation: 15
Thanks all updated and working but can someone answer me this:

Why can't I get my Full Screen mode to work? I keep recivceing an error saying "Undable to turn on direct Graphics. Failed to switch to Full Screen SVGA mode"... Im using Fedora Core 2 and I'd really like the full screen mode to work

Anyone?
 
Old 07-14-2004, 11:18 PM   #4
MHouse
LQ Newbie
 
Registered: Mar 2004
Posts: 17

Rep: Reputation: 0
Check your monitor color depth. What is on your desktop should match what is configured on your X server. I've heard of problems with that but can't confirm, myself.
 
Old 07-17-2004, 08:52 PM   #5
OrinocoRedhat
LQ Newbie
 
Registered: Apr 2004
Distribution: Redhat 9
Posts: 12

Rep: Reputation: 0
I have the same exact issue, Fedora Core 2, with Vmware 4, cannot go to full screen. Same exact depth, either 16 in guest and 16 on host, and tried 32 on host and 32 on guest. Same exact error message as you stated before. Why can't this go full-screen? I had this exact version of vmware working with Redhat 9, same identical laptop!!

Any other suggestions?

Why can't I get my Full Screen mode to work? I keep recivceing an error saying "Undable to turn on direct Graphics. Failed to switch to Full Screen SVGA mode"... Im using Fedora Core 2 and I'd really like the full screen mode to work
 
Old 07-19-2004, 02:52 PM   #6
MHouse
LQ Newbie
 
Registered: Mar 2004
Posts: 17

Rep: Reputation: 0
I ended up editing my xorg and my XFree86 configuration files and forced the VM to run at the same resolution as Windows does. Then when I started up my Virtual Machine and X was running, I was able to switch to full-screen.
 
Old 07-19-2004, 05:52 PM   #7
OrinocoRedhat
LQ Newbie
 
Registered: Apr 2004
Distribution: Redhat 9
Posts: 12

Rep: Reputation: 0
I already modified my xorg file, but you think that I need to change additional Xfree config files? I am running at 32bit depth on the xorg file and on the WinXP vm, but still I cannot go full-screen.

- Ryan
 
Old 07-19-2004, 06:10 PM   #8
MHouse
LQ Newbie
 
Registered: Mar 2004
Posts: 17

Rep: Reputation: 0
Quote:
Originally posted by OrinocoRedhat
I already modified my xorg file, but you think that I need to change additional Xfree config files? I am running at 32bit depth on the xorg file and on the WinXP vm, but still I cannot go full-screen.

- Ryan
Not sure. Can only tell you what I did. Sorry, I'm a n00b.

The biggest thing for me was changing the screen resolution, and not the color depth. When I set my default resolution to 1280x1024 in order to match what Windows was running at, I had no issues running fullscreen.
 
Old 07-19-2004, 06:58 PM   #9
OrinocoRedhat
LQ Newbie
 
Registered: Apr 2004
Distribution: Redhat 9
Posts: 12

Rep: Reputation: 0
Actually, I got the color depth to be the same as well as the screen resolution. Still does not go to to full screen. Are you running Fedora Core 2 as well? With vmware 4.0.5 or the new 4.5??
 
Old 07-20-2004, 12:40 PM   #10
MHouse
LQ Newbie
 
Registered: Mar 2004
Posts: 17

Rep: Reputation: 0
Hmmm.... Running Fedora Core 2 on VMWare 4.5.2 build 8848 with the OS option set to Linux Other (2.6.x Kernel).
 
Old 07-20-2004, 05:10 PM   #11
OrinocoRedhat
LQ Newbie
 
Registered: Apr 2004
Distribution: Redhat 9
Posts: 12

Rep: Reputation: 0
Vmware 4.0.5, kernel 2.4.20-8 with Fedora Core 2 is my setup.

vmware 4.5.2 supports kernels 2.6.x

vmware 4.0.5 works with the 2.4.x kernels and NOT the 2.6.x kernels

This means that my current setup should not conflict.

What else can I do to fix this?

What I am thinking is that 4.0.5 really likes to look for the old XF86Config and XF86Config-4 files for some reason, and since Fedora Core 2 is using xorg instead, perhaps this is why??? Can I create one of these again to make 4.0.5 like me thus going FULL-SCREEN??
 
Old 07-20-2004, 05:23 PM   #12
MHouse
LQ Newbie
 
Registered: Mar 2004
Posts: 17

Rep: Reputation: 0
I would probably try the newer VMWare first. If you have 4.0.5, you are automatically entitled to 4.5.2 I think. The update seems to be relatively painless as compared to going from 3.x to 4.x.

BTW, how are you running the 2.4 kernel with Fedora Core 2? I thought that FC2 came with the 2.6 kernel??? Sorry, told you I was a n00b...
 
Old 07-20-2004, 05:32 PM   #13
OrinocoRedhat
LQ Newbie
 
Registered: Apr 2004
Distribution: Redhat 9
Posts: 12

Rep: Reputation: 0
Well,

I am running 2.4.20-8 because, even though I got 2.6.7 (latest kernel) recompiled and configured completely, it did not allow me to use my Epson Photo 2400 scanner with the libusb thing as something got kind of screwed up, so I had to go back to a kernel old enough that had the "scanner.o" module for me to use which as soon as I got that configured, my scanner was found, and all was well in the world again. I als o have an Epson Stylus Photo 2200 printer which is also a USB/ Firewire printer.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Fedora 3.0 + VMWare Workstation + USB support dadelcas Fedora 0 01-28-2005 09:26 AM
Fedora Hangs after Kernal Update b1gfunn Linux - Newbie 7 11-12-2004 01:00 PM
VMware Workstation 4.5.1 Problems.. Elite_Gamer04 Linux - Software 15 10-23-2004 12:53 AM
VMware Workstation Virtual Machine Transfering Problems... Elite_Gamer04 Linux - Software 3 06-20-2004 08:32 AM
Vmware workstation 4+0 + Fedora and Win2K MongeK Linux - Software 5 02-15-2004 03:52 PM


All times are GMT -5. The time now is 07:09 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration