LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 04-10-2003, 11:45 PM   #1
Ridde
LQ Newbie
 
Registered: Apr 2003
Location: Sweden, norrköping
Distribution: win XP, Slackware 9.0
Posts: 6

Rep: Reputation: 0
vmware vmnet module. error in slackware 9.0


This happends when i try to install vmware 4.0 on Slackware 9.0



Extracting the sources of the vmmon module.

Building the vmmon module.

make: Entering directory `/tmp/vmware-config2/vmmon-only'
make[1]: Entering directory `/tmp/vmware-config2/vmmon-only'
make[2]: Entering directory `/tmp/vmware-config2/vmmon-only/driver-2.4.20'
make[2]: Leaving directory `/tmp/vmware-config2/vmmon-only/driver-2.4.20'
make[2]: Entering directory `/tmp/vmware-config2/vmmon-only/driver-2.4.20'
make[2]: Leaving directory `/tmp/vmware-config2/vmmon-only/driver-2.4.20'
make[1]: Leaving directory `/tmp/vmware-config2/vmmon-only'
make: Leaving directory `/tmp/vmware-config2/vmmon-only'
The module loads perfectly in the running kernel.

Extracting the sources of the vmnet module.

Building the vmnet module.

make: Entering directory `/tmp/vmware-config2/vmnet-only'
driver.c:38:22: net/sock.h: No such file or directory
make: *** [driver.o] Error 1
make: Leaving directory `/tmp/vmware-config2/vmnet-only'
Unable to build the vmnet module.

For more information on how to troubleshoot module-related problems, please
visit our Web site at "http://www.vmware.com/download/modules/modules.html" and
"http://www.vmware.com/support/reference/linux/prebuilt_modules_linux.html".

Execution aborted.

what to do ? cant find any answers
please help
 
Old 04-11-2003, 08:56 AM   #2
Ridde
LQ Newbie
 
Registered: Apr 2003
Location: Sweden, norrköping
Distribution: win XP, Slackware 9.0
Posts: 6

Original Poster
Rep: Reputation: 0
ive figured it out .. if you have the same problem as i did your ,
Kernelsource, kernelheaders, glibcdevel are fucked or not installed att all ..

install them and your configuration will work fine
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
vmware, and a module question. Kjetil4455 Slackware 9 12-03-2003 10:00 AM
VMware module building kernel error ^^ ZoNicONE Linux - Newbie 3 09-09-2003 01:52 PM
compiling vmware module on mandrake 9.1 psychonic Linux - Newbie 4 07-21-2003 08:14 PM
Vmware vmnet module error in slackware 9.0 Gordon Linux - Software 1 04-11-2003 08:57 AM
Error installing VMWare on Slackware Foxypeaches Slackware 3 03-06-2003 01:33 PM


All times are GMT -5. The time now is 11:04 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration