LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 03-10-2008, 08:40 PM   #1
rrose
LQ Newbie
 
Registered: Feb 2008
Posts: 3

Rep: Reputation: 0
URGENT: Apache Server: Directory index forbidden by rule: /aa/www/default/docs/


Newbie,

Please help my job may be at risk...

I moved an Apache server from CA to PHX data center and now it stopped working. This installation runs a Dynamo server as well and worked at one point after the move. I can put an index.html in the servers DocumentRoot and I can see the document but there is suppose to be no index.html file there and I'm not sure how it is suppose to pick up the DocumentRoot page otherwise. Currently the IE screen shows:
Forbidden You don't have permission to acess / on this server. Apache 1.3.26.
The ErrorLog shows: Directory index forbidden by rule: /aa/www/default/docs/


I've been goggling this error and have tried the following:

-Checked all directories in /aa/www/default/docs/ and they all have executable bit set for owner,group, and all.

-I tried putting in the option in <Directory />:
Options Indexes FollowSymLinks

This allowed me to see an index of files at the DocumentRoot only.

-Note: the httpd.conf file references:
<VirtualHost web1:80>
Include conf/seniorhousingnet.conf

which has among other things the following ReWrite rule that used to work but doesn't now:
RewriteRule ^/$ http://qa1.seniorhousingnet.com/seniors/ [R=301,L]

Anyway I included my httpd.conf file:
# Generic Springstreet apache configuration for Dynamo httpd
# Michael Han, Taos, 1/2001
#
# Look for CHANGEME strings if installing this file from scratch
#
ServerType standalone
ServerRoot "/usr/local/apache"
PidFile /usr/local/apache/logs/httpd.pid
ScoreBoardFile /usr/local/apache/logs/httpd.scoreboard
Timeout 30
KeepAlive Off
MaxKeepAliveRequests 100
KeepAliveTimeout 15
#MinSpareServers 20
#MaxSpareServers 40
#StartServers 40
#MaxClients 300
MaxRequestsPerChild 512
Listen 80
<IfDefine SSL>
Listen 443
</IfDefine>

ClearModuleList
AddModule mod_env.c
AddModule mod_log_config.c
AddModule mod_mime.c
AddModule mod_negotiation.c
AddModule mod_status.c
AddModule mod_include.c
AddModule mod_autoindex.c
AddModule mod_dir.c
AddModule mod_cgi.c
AddModule mod_asis.c
AddModule mod_imap.c
AddModule mod_actions.c
AddModule mod_userdir.c
AddModule mod_alias.c
AddModule mod_rewrite.c
AddModule mod_access.c
AddModule mod_auth.c
AddModule mod_so.c
AddModule mod_setenvif.c

<IfDefine SSL>
AddModule mod_ssl.c
</IfDefine>

Port 80
User www
Group www
##ServerAdmin webmaster@springstreet.com
ServerAdmin Richard.Rose@move.com
ServerName qa1.rentnet.com

#LoadModule headers_module libexec/mod_headers.so
# required for SDE 3478 -- sfrancis | 20080113
# DISABLED; the rewrite rule does not work on Apache-1.3.x
#LoadModule proxy_module libexec/libproxy.so

DocumentRoot "/aa/www/default/docs"
<Directory />
Options FollowSymLinks
## Options Indexes FollowSymLinks
AllowOverride None
</Directory>
<Directory "/aa/www">
Options FollowSymLinks
AllowOverride None
Order allow,deny
Allow from all
# Header add Pragma no-cache
# Header add Cache-Control no-cache
# Header add Expires -1
</Directory>
<IfModule mod_dir.c>
DirectoryIndex index.html index.jhtml
</IfModule>
AccessFileName .htaccess
<Files ~ "^\.ht">
Order allow,deny
Deny from all
</Files>

UseCanonicalName On
<IfModule mod_mime.c>
TypesConfig /usr/local/apache/conf/mime.types
</IfModule>
DefaultType text/plain
<IfModule mod_mime_magic.c>
MIMEMagicFile /usr/local/apache/conf/magic
</IfModule>

HostnameLookups Off
ErrorLog "|/usr/local/sbin/cronolog /aa/logs/httpd/default/%Y/%m/%d/errors"
##LogLevel warn
LogLevel error
LogFormat "%h %l %u %t \"%r\" %>s %b \"%{Referer}i\" \"%{User-Agent}i\" \"%{Cookie}i\"" combined
LogFormat "%h %l %u %t \"%r\" %>s %b" common
LogFormat "%{Referer}i -> %U" referer
LogFormat "%{User-agent}i" agent
LogFormat "%{%Y-%m-%d}t\t%{%T}t\t%a\t%u\t%v\tqa1.springstreet.com\t%m\t%U\t%q\t%s\t%B\t%{Content-Length}i\t%T\t%H\t%{Host}i\t%{User-agent}i\t%{Cookie}i\t%{Referer}i" PTO
CustomLog "|/usr/local/sbin/cronolog /aa/logs/httpd/default/ex%y%m%d.log" PTO env=!monitor_hit
#CustomLog "|/usr/local/sbin/cronolog /aa/logs/httpd/default/%Y/%m/%d/access" combined

ServerSignature On
<IfModule mod_alias.c>
Alias /icons/ "/usr/local/apache/icons/"
<Directory "/usr/local/apache/icons">
Options Indexes MultiViews
AllowOverride None
Order allow,deny
Allow from all
</Directory>
</IfModule>
<IfModule mod_mime.c>
AddEncoding x-compress Z
AddEncoding x-gzip gz tgz
AddLanguage da .dk
AddLanguage nl .nl
AddLanguage en .en
AddLanguage et .ee
AddLanguage fr .fr
AddLanguage de .de
AddLanguage el .el
AddLanguage it .it
AddLanguage ja .ja
AddCharset ISO-2022-JP .jis
AddLanguage pl .po
AddCharset ISO-8859-2 .iso-pl
AddLanguage pt .pt
AddLanguage pt-br .pt-br
AddLanguage ltz .lu
AddLanguage ca .ca
AddLanguage es .es
AddLanguage sv .se
AddLanguage cz .cz
<IfModule mod_negotiation.c>
LanguagePriority en da nl et fr de el it ja pl pt pt-br ltz ca es sv
</IfModule>
AddType application/x-tar .tgz
</IfModule>

## Next line added to address Forbidden: You dont have permission to access / on this server RHR
##ErrorDocument 403 /forbidden.html
ErrorDocument 404 /common/errors/404.jhtml
ErrorDocument 500 /common/errors/500.html

<IfModule mod_setenvif.c>
BrowserMatch "Mozilla/2" nokeepalive
BrowserMatch "MSIE 4\.0b2;" nokeepalive downgrade-1.0 force-response-1.0
BrowserMatch "RealPlayer 4\.0" force-response-1.0
BrowserMatch "Java/1\.0" force-response-1.0
BrowserMatch "JDK/1\.0" force-response-1.0
</IfModule>

<Location /server-status>
SetHandler server-status
Order deny,allow
Deny from all
Allow from 10.164.128.0/22 216.32.161.0/24
</Location>
## Allow from 10.166.0.0/22 216.32.161.0/24
## Allow from 10.131.4.0/22 216.32.161.0/24

Include conf/mod_dynamo.conf

<IfModule mod_ssl.c>
SSLEngine off
SSLSessionCache dbm:logs/ssl_cache
SSLSessionCacheTimeout 60
SSLVerifyClient 0
SSLVerifyDepth 10
SSLRandomSeed startup builtin
SSLRandomSeed connect builtin
SSLMutex file:logs/ssl_mutex
SSLLog logs/ssl_engine_log
SSLLogLevel info
# CHANGEME
SSLCertificateFile /aa/etc/certs/www.springstreet.com.cert
SSLCertificateKeyFile /aa/etc/certs/www.springstreet.com.key
</IfModule>

# CHANGEME
# These configs are for serving www.springstreet.com
#
NameVirtualHost web1:80
<VirtualHost web1:80>
Include conf/www.conf
</VirtualHost>
<VirtualHost web1:80>
Include conf/rentnet.conf
</VirtualHost>
<VirtualHost web1:80>
Include conf/springstreet.conf
</VirtualHost>
<VirtualHost web1:80>
Include conf/seniorhousingnet.conf
</VirtualHost>
<VirtualHost web1:80>
Include conf/selfstorage.conf
</VirtualHost>
<VirtualHost web1:80>
Include conf/corporatehousing.conf
</VirtualHost>
<VirtualHost web1:80>
Include conf/aol.conf
</VirtualHost>
<VirtualHost web1:80>
Include conf/moc.springstreet.com
</VirtualHost>
<VirtualHost web1:80>
Include conf/sl.conf
</VirtualHost>
<VirtualHost web1:80>
Include conf/apartments.homestore.com
</VirtualHost>
<VirtualHost web1:80>
Include conf/seniorliving.homestore.com
</VirtualHost>
<VirtualHost web1:80>
Include conf/corporatehousing.homestore.com
</VirtualHost>
<VirtualHost web1:80>
Include conf/selfstorage.homestore.com
</VirtualHost>

<IfModule mod_ssl.c>
# CHANGEME
# www.springstreet.com via HTTPS
#
NameVirtualHost web1:443
<VirtualHost web1:443>
Include conf/secure.www.conf
</VirtualHost>
<VirtualHost web1:443>
Include conf/secure.moc.springstreet.com
</VirtualHost>
</IfModule>

# CHANGEME
# community.springstreet.com services
# Because of all the CNAMEs on community, it's a good idea to use a different
# IP address
#
# NameVirtualHost secondary.server:80
# <VirtualHost secondary.server:80>
# Include conf/community.conf
# </VirtualHost>
# <VirtualHost secondary.server:80>
# Include conf/gmac.conf
# </VirtualHost>
root@qa1# wc -l httpd.conf
252 httpd.conf
root@qa1# cat httpd.conf
# Generic Springstreet apache configuration for Dynamo httpd
# Michael Han, Taos, 1/2001
#
# Look for CHANGEME strings if installing this file from scratch
#
ServerType standalone
ServerRoot "/usr/local/apache"
PidFile /usr/local/apache/logs/httpd.pid
ScoreBoardFile /usr/local/apache/logs/httpd.scoreboard
Timeout 30
KeepAlive Off
MaxKeepAliveRequests 100
KeepAliveTimeout 15
#MinSpareServers 20
#MaxSpareServers 40
#StartServers 40
#MaxClients 300
MaxRequestsPerChild 512
Listen 80
<IfDefine SSL>
Listen 443
</IfDefine>

ClearModuleList
AddModule mod_env.c
AddModule mod_log_config.c
AddModule mod_mime.c
AddModule mod_negotiation.c
AddModule mod_status.c
AddModule mod_include.c
AddModule mod_autoindex.c
AddModule mod_dir.c
AddModule mod_cgi.c
AddModule mod_asis.c
AddModule mod_imap.c
AddModule mod_actions.c
AddModule mod_userdir.c
AddModule mod_alias.c
AddModule mod_rewrite.c
AddModule mod_access.c
AddModule mod_auth.c
AddModule mod_so.c
AddModule mod_setenvif.c

<IfDefine SSL>
AddModule mod_ssl.c
</IfDefine>

Port 80
User www
Group www
##ServerAdmin webmaster@springstreet.com
ServerAdmin Richard.Rose@move.com
ServerName qa1.rentnet.com

#LoadModule headers_module libexec/mod_headers.so
# required for SDE 3478 -- sfrancis | 20080113
# DISABLED; the rewrite rule does not work on Apache-1.3.x
#LoadModule proxy_module libexec/libproxy.so

DocumentRoot "/aa/www/default/docs"
<Directory />
Options FollowSymLinks
## Options Indexes FollowSymLinks
AllowOverride None
</Directory>
<Directory "/aa/www">
Options FollowSymLinks
AllowOverride None
Order allow,deny
Allow from all
# Header add Pragma no-cache
# Header add Cache-Control no-cache
# Header add Expires -1
</Directory>
<IfModule mod_dir.c>
DirectoryIndex index.html index.jhtml
</IfModule>
AccessFileName .htaccess
<Files ~ "^\.ht">
Order allow,deny
Deny from all
</Files>

UseCanonicalName On
<IfModule mod_mime.c>
TypesConfig /usr/local/apache/conf/mime.types
</IfModule>
DefaultType text/plain
<IfModule mod_mime_magic.c>
MIMEMagicFile /usr/local/apache/conf/magic
</IfModule>

HostnameLookups Off
ErrorLog "|/usr/local/sbin/cronolog /aa/logs/httpd/default/%Y/%m/%d/errors"
##LogLevel warn
LogLevel error
LogFormat "%h %l %u %t \"%r\" %>s %b \"%{Referer}i\" \"%{User-Agent}i\" \"%{Cookie}i\"" combined
LogFormat "%h %l %u %t \"%r\" %>s %b" common
LogFormat "%{Referer}i -> %U" referer
LogFormat "%{User-agent}i" agent
LogFormat "%{%Y-%m-%d}t\t%{%T}t\t%a\t%u\t%v\tqa1.springstreet.com\t%m\t%U\t%q\t%s\t%B\t%{Content-Length}i\t%T\t%H\t%{Host}i\t%{User-agent}i\t%{Cookie}i\t%{Referer}i" PTO
CustomLog "|/usr/local/sbin/cronolog /aa/logs/httpd/default/ex%y%m%d.log" PTO env=!monitor_hit
#CustomLog "|/usr/local/sbin/cronolog /aa/logs/httpd/default/%Y/%m/%d/access" combined

ServerSignature On
<IfModule mod_alias.c>
Alias /icons/ "/usr/local/apache/icons/"
<Directory "/usr/local/apache/icons">
Options Indexes MultiViews
AllowOverride None
Order allow,deny
Allow from all
</Directory>
</IfModule>
<IfModule mod_mime.c>
AddEncoding x-compress Z
AddEncoding x-gzip gz tgz
AddLanguage da .dk
AddLanguage nl .nl
AddLanguage en .en
AddLanguage et .ee
AddLanguage fr .fr
AddLanguage de .de
AddLanguage el .el
AddLanguage it .it
AddLanguage ja .ja
AddCharset ISO-2022-JP .jis
AddLanguage pl .po
AddCharset ISO-8859-2 .iso-pl
AddLanguage pt .pt
AddLanguage pt-br .pt-br
AddLanguage ltz .lu
AddLanguage ca .ca
AddLanguage es .es
AddLanguage sv .se
AddLanguage cz .cz
<IfModule mod_negotiation.c>
LanguagePriority en da nl et fr de el it ja pl pt pt-br ltz ca es sv
</IfModule>
AddType application/x-tar .tgz
</IfModule>

## Next line added to address Forbidden: You dont have permission to access / on this server RHR
##ErrorDocument 403 /forbidden.html
ErrorDocument 404 /common/errors/404.jhtml
ErrorDocument 500 /common/errors/500.html

<IfModule mod_setenvif.c>
BrowserMatch "Mozilla/2" nokeepalive
BrowserMatch "MSIE 4\.0b2;" nokeepalive downgrade-1.0 force-response-1.0
BrowserMatch "RealPlayer 4\.0" force-response-1.0
BrowserMatch "Java/1\.0" force-response-1.0
BrowserMatch "JDK/1\.0" force-response-1.0
</IfModule>

<Location /server-status>
SetHandler server-status
Order deny,allow
Deny from all
Allow from 10.164.128.0/22 216.32.161.0/24
</Location>
## Allow from 10.166.0.0/22 216.32.161.0/24
## Allow from 10.131.4.0/22 216.32.161.0/24

Include conf/mod_dynamo.conf

<IfModule mod_ssl.c>
SSLEngine off
SSLSessionCache dbm:logs/ssl_cache
SSLSessionCacheTimeout 60
SSLVerifyClient 0
SSLVerifyDepth 10
SSLRandomSeed startup builtin
SSLRandomSeed connect builtin
SSLMutex file:logs/ssl_mutex
SSLLog logs/ssl_engine_log
SSLLogLevel info
# CHANGEME
SSLCertificateFile /aa/etc/certs/www.springstreet.com.cert
SSLCertificateKeyFile /aa/etc/certs/www.springstreet.com.key
</IfModule>

# CHANGEME
# These configs are for serving www.springstreet.com
#
NameVirtualHost web1:80
<VirtualHost web1:80>
Include conf/www.conf
</VirtualHost>
<VirtualHost web1:80>
Include conf/rentnet.conf
</VirtualHost>
<VirtualHost web1:80>
Include conf/springstreet.conf
</VirtualHost>
<VirtualHost web1:80>
Include conf/seniorhousingnet.conf
</VirtualHost>
<VirtualHost web1:80>
Include conf/selfstorage.conf
</VirtualHost>
<VirtualHost web1:80>
Include conf/corporatehousing.conf
</VirtualHost>
<VirtualHost web1:80>
Include conf/aol.conf
</VirtualHost>
<VirtualHost web1:80>
Include conf/moc.springstreet.com
</VirtualHost>
<VirtualHost web1:80>
Include conf/sl.conf
</VirtualHost>
<VirtualHost web1:80>
Include conf/apartments.homestore.com
</VirtualHost>
<VirtualHost web1:80>
Include conf/seniorliving.homestore.com
</VirtualHost>
<VirtualHost web1:80>
Include conf/corporatehousing.homestore.com
</VirtualHost>
<VirtualHost web1:80>
Include conf/selfstorage.homestore.com
</VirtualHost>

<IfModule mod_ssl.c>
# CHANGEME
# www.springstreet.com via HTTPS
#
NameVirtualHost web1:443
<VirtualHost web1:443>
Include conf/secure.www.conf
</VirtualHost>
<VirtualHost web1:443>
Include conf/secure.moc.springstreet.com
</VirtualHost>
</IfModule>

# CHANGEME
# community.springstreet.com services
# Because of all the CNAMEs on community, it's a good idea to use a different
# IP address
#
# NameVirtualHost secondary.server:80
# <VirtualHost secondary.server:80>
# Include conf/community.conf
# </VirtualHost>
# <VirtualHost secondary.server:80>
# Include conf/gmac.conf
# </VirtualHost>

Thanks for your help :[
 
Old 03-10-2008, 09:41 PM   #2
gilead
Senior Member
 
Registered: Dec 2005
Location: Brisbane, Australia
Distribution: Slackware64 14.0
Posts: 4,123

Rep: Reputation: 162Reputation: 162
You have your DocumentRoot set to "/aa/www/default/docs" but you don't have a directory entry for it. Have you tried changing the Directory line like this:
Code:
From this:
<Directory "/aa/www">
To this:
<Directory "/aa/www/default/docs">
Also, please don't mark posts as urgent
 
  


Reply

Tags
apache


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Directory index forbidden by rule: /var/www/html/ danimaldaisy Linux - Networking 6 02-11-2008 02:32 AM
Apache 2 Directory index forbidden by rule augustinemak Linux - Server 1 07-26-2007 07:03 AM
I get an error "Directory index forbidden by rule" in my error log wanna13e Linux - Server 5 07-18-2007 09:08 PM
Apache - Directory index forbidden Phaethar Linux - Software 1 01-26-2006 08:49 AM
Virtual Hosts/Directory Index Forbidden by Rule Alan Powell Linux - Newbie 4 04-26-2004 07:35 AM


All times are GMT -5. The time now is 12:47 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration