LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 05-05-2006, 05:47 AM   #1
Niceman2005
Member
 
Registered: Nov 2004
Distribution: Fedora Core 2
Posts: 330

Rep: Reputation: 30
Unable to share files from my linux to windows computers through samba


Dear friends,

All I wanted to do is to share my files from my FC2 to users from Windows machine. But I don't know why it never work.
I did the following configuration in my /etc/samba/smb.conf

workgroup = myworkgroup
hosts allow = 192.168.0. 127.

Set ENCRYPT PASSWORDS to "yes"


Set SMB PASSWORD FILE to "/etc/smbpasswd"

[homes]
comment = Home Directories
browseable = no
writable = yes


Now add any other shares you want like this:
[sharename]
comment = Comment
path = /MyMusic
read only = yes
public = yes

Save and exit.

smbpasswd -a user password

service smb restart


Suppose to be very simple and easy. But I just don't know why not work. I go to windows machine, find this linux computer (Potato) there, then I click into it and it says "\\Potato is not accessible. You might not have permission to access this network resouce."

What is wrong....please helpe me....I tried so many days already....
or is there any other way to share a file from my linux to windows computer? I just want to share file to windows computers....

thanks for taking time reading my mail....

Regards
Y
 
Old 05-05-2006, 08:57 AM   #2
satinet
Senior Member
 
Registered: Feb 2004
Location: England
Distribution: Slackware 11, Sabayon 3.1
Posts: 1,464

Rep: Reputation: 46
is this the full output of your "smb.conf" file? because you haven't defined a security level. security=share is probably what you are wanting....

what is your "[global]" section........?

have you read "using samba" that comes with samba or used google for a myriad of guides..........???

Last edited by satinet; 05-05-2006 at 08:58 AM.
 
Old 05-05-2006, 12:16 PM   #3
crispyleif
Member
 
Registered: Mar 2005
Location: Norway, by the coast
Distribution: Debian and the likes
Posts: 190

Rep: Reputation: 31
Comment out the "host allow" part, should probably by 192.168.0.0 anyway

Define a [global] section as adviced.
 
Old 05-05-2006, 10:27 PM   #4
Niceman2005
Member
 
Registered: Nov 2004
Distribution: Fedora Core 2
Posts: 330

Original Poster
Rep: Reputation: 30
Hi friends,

Sorry, previously was just part of the file. I redo another simple one. Here is the whole file:

[global]
encrypt passwords = yes
netbios name = Potato
security = share
socket options = TCP_NODELAY IPTOS_LOWDELAY
wins support = yes
workgroup = myworkgroup

[public]
path = /MyMusic
read only = no


Thats it. I have my music in /MyMusic. All I want is the windows users can access this folder. But I went to a window computer, find this samba computer (Potato) there, clicked it but it says "\\Potato is not accessible. You might not have permission to access this network resouce."
Can't even get into the first hurdle of getting into the Potato computer.

What am I missing here?

thanks for taking time helping......

Regards
Y
 
Old 05-05-2006, 11:57 PM   #5
Niceman2005
Member
 
Registered: Nov 2004
Distribution: Fedora Core 2
Posts: 330

Original Poster
Rep: Reputation: 30
Dear friends,

Thanks! I think I have solved the problem. I read somwhere that for XP, need to set wins=mysambaip. So I did that, and it worked.
thanks a lot for helping!

Regards
Y
 
Old 05-21-2006, 09:19 PM   #6
Niceman2005
Member
 
Registered: Nov 2004
Distribution: Fedora Core 2
Posts: 330

Original Poster
Rep: Reputation: 30
Suddenly today my samba share cannot work again.
Just a simple file sharing but cannot work.
Same problem as before.

Now I wrote another config file like this:
[global]
workgroup = boogey.com
netbios name = Potato
security = share

[share1]
path = /MyMusic
valid users = potato
writable = yes


But when I tried to access the Potato computer from windows, it says
"\\Potato is not accessible. You might not have permission to access this network resouce."
Can't even get into the first hurdle of getting into the Potato computer.

I am really headache, howcome suddenly it doesnt work...

pls help if you know why...thanks...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Suse 9.2 Samba, cant see Windows computers, but they can see Linux Whiskers Linux - Networking 6 05-08-2005 05:16 PM
help: when changing files on samba share from windows system, changes do not appear zero79 Linux - Software 1 06-13-2004 06:58 PM
two computers to share files neolus Linux - Networking 2 12-02-2003 07:57 AM
unable to browse samba share from windows 2003 kfloda Linux - Software 1 08-16-2003 08:14 AM
Having 2 Linux computers share files with each other? Seph64 Linux - Networking 7 03-29-2003 10:10 PM


All times are GMT -5. The time now is 09:45 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration