LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 02-21-2004, 12:49 PM   #1
mrIntegrity
LQ Newbie
 
Registered: Aug 2003
Posts: 2

Rep: Reputation: 0
ukonline isp - kinternet works wvdial wont


Hi all I cant seem to get wvdial (under gentoo) to connect ot my isp (ukonline) this is the first time i have had to use 56k and i dont know what to do! i rebooted to my old suse 8.0 installation and got kinternet to dial up np. heer are the settings i am useing for wvdial in gentoo:


[Dialer Defaults]
Modem = /dev/ttyS2
Baud = 115200
Init1 = ATZ
Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
ISDN = 0
Modem Type = Analog Modem
Phone = 08089933259
Username = mr*******
Password = *********

heer is what happens when i try to connect:

bash-2.05b# wvdial
--> WvDial: Internet dialer version 1.53
--> Initializing modem.
--> Sending: ATZ
ATZ
OK
--> Sending: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
OK
--> Modem initialized.
--> Sending: ATDT08089933259
--> Waiting for carrier.
ATDT08089933259
CONNECT 115200
--> Carrier detected. Waiting for prompt.
~[7f]}#@!}![1d]} }9}"}&} }*} } }#}%B#}%}%}&]yqm}'}"}(}"`d~
--> PPP negotiation detected.
--> Starting pppd at Sat Feb 21 08:53:47 2004
--> pid of pppd: 1091
--> Disconnecting at Sat Feb 21 08:53:51 2004
--> The PPP daemon has died: A modem hung up the phone (exit code = 16)
--> man pppd explains pppd error codes in more detail.
--> Try again and look into /var/log/messages and the wvdial and pppd man pages for more information.
--> Auto Reconnect will be attempted in 5 seconds

Heer is the output from kinternet (which connects sucessfully):

Starting connection. (2004-02-21 09:40:59 GMT)
pppd: Plugin passwordfd.so loaded.
pppd: Perms of /dev/ttyS2 are ok, no 'mesg n' neccesary.
pppd: --> WvDial: Internet dialer version 1.42
pppd: --> Initializing modem.
pppd: --> Sending: ATZ
pppd: ATZ
pppd: OK
pppd: --> Sending: AT Q0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
pppd: AT Q0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
pppd: OK
pppd: --> Sending: ATM1
pppd: ATM1
pppd: OK
pppd: --> Modem initialized.
pppd: --> Sending: ATDT08089933259
pppd: --> Waiting for carrier.
pppd: ATDT08089933259
pppd: CONNECT 57600
pppd: --> Carrier detected. Waiting for prompt.
pppd: ~[7f]}#@!}!u} }9}"}&} }*} } }#}%B#}%}%}&^%}/+}'}"}(}"{=~
pppd: --> PPP negotiation detected.
pppd: Serial connection established.
pppd: using channel 1
pppd: Using interface ppp0
pppd: Connect: ppp0 <--> /dev/ttyS2
pppd: sent [LCP ConfReq id=0x1 <asyncmap 0x0> <magic 0xab0c0cd6> <pcomp> <ac$
pppd: rcvd [LCP ConfAck id=0x1 <asyncmap 0x0> <magic 0xab0c0cd6> <pcomp> <ac$
pppd: rcvd [LCP ConfReq id=0xf6 <asyncmap 0xa0000> <auth chap MD5> <magic 0x$
pppd: sent [LCP ConfAck id=0xf6 <asyncmap 0xa0000> <auth chap MD5> <magic 0x$
pppd: sent [LCP EchoReq id=0x0 magic=0xab0c0cd6]
pppd: cbcp_lowerup
pppd: want: 2
pppd: rcvd [CHAP Challenge id=0xcb <26784f191ea37575e679f98091cdb39f>, name $
pppd: sent [CHAP Response id=0xcb <bf3d77b8cd0c6be543eb31f36a543b3f>, name =$
pppd: rcvd [LCP EchoRep id=0x0 magic=0x5e250f2b]
pppd: rcvd [CHAP Success id=0xcb ""]
pppd: sent [IPCP ConfReq id=0x1 <addr 0.0.0.0> <compress VJ 0f 01> <ms-dns1 $
pppd: sent [CCP ConfReq id=0x1 <deflate 15> <deflate(old#) 15> <bsd v1 15>]
pppd: rcvd [IPCP ConfReq id=0x1 <addr 212.135.11.11>]
pppd: sent [IPCP ConfAck id=0x1 <addr 212.135.11.11>]
pppd: rcvd [LCP EchoReq id=0x1 magic=0x5e250f2b 75 e6 79 f9]
pppd: sent [LCP EchoRep id=0x1 magic=0xab0c0cd6 15 03 2f 01]
pppd: rcvd [IPCP ConfRej id=0x1 <compress VJ 0f 01>]
pppd: sent [IPCP ConfReq id=0x2 <addr 0.0.0.0> <ms-dns1 0.0.0.0> <ms-dns3 0.$
pppd: rcvd [LCP ProtRej id=0x1 80 fd 01 01 00 0f 1a 04 78 00 18 04 78 00 15 $
pppd: rcvd [IPCP ConfNak id=0x2 <addr 217.205.241.237> <ms-dns1 212.135.1.36$
pppd: sent [IPCP ConfReq id=0x3 <addr 217.205.241.237> <ms-dns1 212.135.1.36$
pppd: rcvd [IPCP ConfAck id=0x3 <addr 217.205.241.237> <ms-dns1 212.135.1.36$
pppd: local IP address 217.205.241.237
pppd: remote IP address 212.135.11.11
pppd: primary DNS address 212.135.1.36
pppd: secondary DNS address 212.135.1.38
pppd: Script /etc/ppp/ip-up started (pid 2999)
pppd: Script /etc/ppp/ip-up finished (pid 2999), status = 0x0
We are connected. (2004-02-21 09:41:30 GMT)
pppd: rcvd [LCP EchoReq id=0x2 magic=0x5e250f2b d4 87 01 24]
pppd: sent [LCP EchoRep id=0x2 magic=0xab0c0cd6 d4 87 01 24]
pppd: sent [LCP EchoReq id=0x1 magic=0xab0c0cd6]
pppd: rcvd [LCP EchoRep id=0x1 magic=0x5e250f2b]
pppd: rcvd [LCP EchoReq id=0x3 magic=0x5e250f2b d4 87 01 24]
pppd: sent [LCP EchoRep id=0x3 magic=0xab0c0cd6 d4 87 01 24]
pppd: rcvd [LCP EchoReq id=0x4 magic=0x5e250f2b d4 87 01 24]
pppd: sent [LCP EchoRep id=0x4 magic=0xab0c0cd6 d4 87 01 24]
pppd: rcvd [LCP EchoReq id=0x5 magic=0x5e250f2b d4 87 01 24]
pppd: sent [LCP EchoRep id=0x5 magic=0xab0c0cd6 d4 87 01 24]
pppd: sent [LCP EchoReq id=0x2 magic=0xab0c0cd6]
pppd: rcvd [LCP EchoRep id=0x2 magic=0x5e250f2b]
pppd: rcvd [LCP EchoReq id=0x6 magic=0x5e250f2b d4 87 01 24]
pppd: sent [LCP EchoRep id=0x6 magic=0xab0c0cd6 d4 87 01 24]
pppd: rcvd [LCP EchoReq id=0x7 magic=0x5e250f2b d4 87 01 24]

how can i configure this connection to work with wvdial in gentoo?

/etc/ppp/pap-secrets and /etc/ppp/chap-secrets are both empty files under gentoo. Is this a bad thing?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
wvdial (modem) works w/ ubuntu not w/ others towsonu2003 Linux - Hardware 6 10-11-2005 12:13 PM
KInternet wont let WLAN to work! bin75 SUSE / openSUSE 0 07-17-2005 10:43 AM
wvdial or kppp - can't make either one connect to a local isp lefty.crupps Linux - Software 2 07-07-2005 12:51 AM
wvdial not works under slackware anindyanuri Slackware 3 06-19-2005 01:06 AM
getting Wvdial to work kinternet Janaka Linux - Networking 0 02-11-2002 01:02 AM


All times are GMT -5. The time now is 01:05 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration