LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 02-21-2005, 03:05 PM   #1
willywonka
LQ Newbie
 
Registered: Apr 2003
Location: Kansas
Distribution: Slackware 9.0
Posts: 12

Rep: Reputation: 0
Question Symbolic links work, but still flash red.


I have a Redhat 7 Box running as a web server, and I came into work today to find that all the symbolic links flash red in terminal. The funny thing is, all the symbolic links still work. I have tried removing them and recreating them.

The system has been up and running for 110 days without any problems. I guess it isn't a huge issue because everything works, but it is very strange.

Last edited by willywonka; 02-21-2005 at 03:06 PM.
 
Old 02-21-2005, 03:32 PM   #2
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,396

Rep: Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963
symlinks can do odd things. for example the symlinks could be using a relative path, e.g. ../bin/realfile. this whole directory could actually be being linked from somewhere else though, to another location. i.e. somewhere where ../bin/realfile does work as a valid path. find a link that appears broken and use "locate" or "find" to track down any other existances of that file, maybe that's a link in the correct place? if you provide some example ls output so we can see what's happening i'd expect it can be explained away.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Red symbolic links show up in Red Hat 9 guerau Red Hat 2 06-30-2005 02:32 PM
tar wont work: Cannot exec: Too many levels of symbolic links abefroman Fedora - Installation 3 09-25-2004 02:54 PM
Symbolic Links petercool Linux - General 2 08-20-2003 11:15 AM
Symbolic links bkmesenbrink Linux - Newbie 2 11-13-2002 11:54 AM
symbolic links NoahsMyBro Linux - Newbie 1 11-16-2001 11:13 AM


All times are GMT -5. The time now is 06:31 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration