LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 08-23-2004, 08:36 AM   #1
qwijibow
Guru
 
Registered: Apr 2003
Location: nottingham england
Distribution: Gentoo
Posts: 2,672

Rep: Reputation: 47
strange error, cant login but su - works !


Ive just installed Gentoo.
ive done this many times before with no problem, but this time i changed the USE flag slightly...

i set pam to off ( USE="-pam" )

from what i understand about USE flags, this means programs will not be compiled agaised pam unless they need it.

when i boot to runlevel 3, i get the usual login prompt.. but after entering a username and hitting return (any username) i get a CRITICAL PAM ERROR, ABORTING.

doesnt even ask for a password... then i get anouther login prompt...

at the moment, im in single user mode. and im able to switch users with 'su -'
ive just looked, and PAM IS installed....

anyways.... i think emerge made a mistake and dissables the getty's from being compiled againsed PAM, but maybe allowed su to be compiled againsed pam ?

what should i do to fix this ?

id rather not have to re-emerge the system, it took hours...

any help ?
any idea what went wrong ?

im running a very minimal install at the moment.... just X, twm and firefox installed.

thanks.
 
Old 08-23-2004, 09:47 AM   #2
qwijibow
Guru
 
Registered: Apr 2003
Location: nottingham england
Distribution: Gentoo
Posts: 2,672

Original Poster
Rep: Reputation: 47
fixed....
Code:
emerge --unmerge pam-login
emerge --unmerge shadow
USE="pam" emerge shadow
USE="pam" emeger pam-login

Last edited by qwijibow; 08-23-2004 at 10:00 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Graphical login fail, text login works livewire98801 Linux - General 2 10-11-2004 06:09 PM
Strange USB problems - it works AND it works not Nightfrost Linux - Hardware 2 10-07-2004 06:07 PM
Strange login error message Post Linux - General 2 04-25-2004 01:13 PM
I have re-installed MK 9.2 but cannot login as user, login as root works. bobinglis Mandriva 2 02-22-2004 11:39 AM
strange bash login error figmentium Linux - Newbie 3 08-11-2003 04:27 PM


All times are GMT -5. The time now is 09:30 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration