LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 03-25-2005, 10:53 AM   #1
ahh
Member
 
Registered: May 2004
Location: UK
Distribution: Gentoo
Posts: 293

Rep: Reputation: 31
stop konqueror executing shell scripts


I had Konqueror set up so that if I clicked on a shell script I would view it, but since upgrading to 3.3.2 it now runs the script instead - the b*****d renamed all the files and directories in my home dir when I wanted to view a script!

I've tried to find a way to stop this, imho, annoying, insecure and dangerous behaviour but failed miserably.

Any clues would be much appreciated.
 
Old 03-26-2005, 10:16 PM   #2
foo_bar_foo
Senior Member
 
Registered: Jun 2004
Posts: 2,553

Rep: Reputation: 51
wow

lets see in controll center
kde-components->file associations
known-types->executables
must be set that way under x-executable or x-executable-scrpit
make sure you have an editor set as prefered app to open those especially the x-executable-script

you said you upgraded kde
what i would do first is delete the ~/.kde folder and restart kde and let the wizard create a new
.kde folder then try to set preferences
cause there can be some differences in whats in the configs from version to version that can confuse kdelibs
 
Old 03-27-2005, 06:00 AM   #3
ahh
Member
 
Registered: May 2004
Location: UK
Distribution: Gentoo
Posts: 293

Original Poster
Rep: Reputation: 31
Success!

Thanks foo_bar_foo.

I had been trying to alter this behaviour under:-

kde-components -> file associations -> known-types -> applications(there is no "executables") -> x-shellscript.

Is actually under

kde-components -> file associations -> known-types -> applications -> x-executable-script.

Changing the settings had no effect, I set it to "show file in embedded viewer" under embedding -> left click action, so I removed the file type and now all is well with the world. (Strangely, it wouldn't let me remove x-shellscript when I tried it with that).
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to get Konqueror to execute shell scripts in a new console on double click nitrambass Mandriva 0 06-22-2004 10:38 AM
Prevent konqueror from executing shell scripts Dave Farrance Mandriva 1 05-30-2004 08:37 PM
Executing scripts upon login jungatheart Linux - Newbie 3 04-19-2004 06:06 PM
Executing Shell Scripts? l0f33t Linux - General 7 08-17-2003 03:36 PM
Executing shell scripts justinv Linux - General 6 01-26-2003 07:57 AM


All times are GMT -5. The time now is 08:40 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration